mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/ocaml to 4.02.1-1
This commit is contained in:
parent
180bc7bcd8
commit
c684b2b586
2 changed files with 8 additions and 9 deletions
|
@ -6,7 +6,7 @@
|
|||
|
||||
pkgbase='ocaml'
|
||||
pkgname=('ocaml' 'ocaml-compiler-libs')
|
||||
pkgver=4.02.0
|
||||
pkgver=4.02.1
|
||||
pkgrel=1
|
||||
pkgdesc="A functional language with OO extensions"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -63,5 +63,5 @@ optdepends=()
|
|||
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
|
||||
install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
|
||||
}
|
||||
md5sums=('8bba7e7d872083af1723dd450e07a5f4'
|
||||
'b76dff01b9152e7c829dfdfe4c0ebfd6')
|
||||
md5sums=('3c35318eefd201f96797c093c920b343'
|
||||
'bf67fe35a844f0d1a13a489f4414fd6d')
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
diff --git a/asmcomp/CSEgen.ml b/asmcomp/CSEgen.ml
|
||||
index 19019e1..260e4fa 100644
|
||||
--- a/asmcomp/CSEgen.ml
|
||||
+++ b/asmcomp/CSEgen.ml
|
||||
@@ -180,7 +180,8 @@ method private keep_checkbounds n =
|
||||
diff -urN a/asmcomp/CSEgen.ml b/asmcomp/CSEgen.ml
|
||||
--- a/asmcomp/CSEgen.ml 2014-10-09 03:21:33.000000000 -0600
|
||||
+++ b/asmcomp/CSEgen.ml 2014-12-06 14:17:49.879574784 -0700
|
||||
@@ -216,7 +216,8 @@
|
||||
(* Perform CSE on the given instruction [i] and its successors.
|
||||
[n] is the value numbering current at the beginning of [i]. *)
|
||||
|
||||
|
@ -12,7 +11,7 @@ index 19019e1..260e4fa 100644
|
|||
match i.desc with
|
||||
| Iend | Ireturn | Iop(Itailcall_ind) | Iop(Itailcall_imm _)
|
||||
| Iexit _ | Iraise _ ->
|
||||
@@ -262,6 +263,7 @@ method private cse n i =
|
||||
@@ -315,6 +316,7 @@
|
||||
{i with desc = Itrywith(self#cse n body,
|
||||
self#cse empty_numbering handler);
|
||||
next = self#cse empty_numbering i.next}
|
||||
|
|
Loading…
Reference in a new issue