mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/chromium to 120.0.6099.109-2
This commit is contained in:
parent
9aa881858e
commit
c6efa52550
3 changed files with 30 additions and 2 deletions
|
@ -1,7 +1,7 @@
|
|||
pkgbase = chromium
|
||||
pkgdesc = A web browser built for speed, simplicity, and security
|
||||
pkgver = 120.0.6099.109
|
||||
pkgrel = 1
|
||||
pkgrel = 2
|
||||
url = https://www.chromium.org/Home
|
||||
arch = x86_64
|
||||
license = BSD
|
||||
|
@ -56,12 +56,14 @@ pkgbase = chromium
|
|||
source = https://github.com/foutrelis/chromium-launcher/archive/v8/chromium-launcher-8.tar.gz
|
||||
source = https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/120/chromium-patches-120.tar.bz2
|
||||
source = libxml2-2.12.patch
|
||||
source = icu-74.patch
|
||||
source = drop-flags-unsupported-by-clang16.patch
|
||||
source = use-oauth2-client-switches-as-default.patch
|
||||
sha256sums = 87c00c525ee07c2233b78dbece1496b697f686244a67fac2c71e4a30bd96849b
|
||||
sha256sums = 213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a
|
||||
sha256sums = ffee1082fbe3d0c9e79dacb8405d5a0e1aa94d6745089a30b093f647354894d2
|
||||
sha256sums = 1808df5ba4d1e2f9efa07ac6b510bec866fa6d60e44505d82aea3f6072105a71
|
||||
sha256sums = ff9ebd86b0010e1c604d47303ab209b1d76c3e888c423166779cefbc22de297f
|
||||
sha256sums = 8d1cdf3ddd8ff98f302c90c13953f39cd804b3479b13b69b8ef138ac57c83556
|
||||
sha256sums = e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711
|
||||
|
||||
|
|
|
@ -16,7 +16,7 @@ highmem=1
|
|||
|
||||
pkgname=chromium
|
||||
pkgver=120.0.6099.109
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_launcher_ver=8
|
||||
_manual_clone=0
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
|
@ -39,6 +39,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
|
|||
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
|
||||
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
|
||||
libxml2-2.12.patch
|
||||
icu-74.patch
|
||||
drop-flags-unsupported-by-clang16.patch
|
||||
use-oauth2-client-switches-as-default.patch
|
||||
0001-widevine-support-for-arm.patch
|
||||
|
@ -48,6 +49,7 @@ sha256sums=('87c00c525ee07c2233b78dbece1496b697f686244a67fac2c71e4a30bd96849b'
|
|||
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
|
||||
'ffee1082fbe3d0c9e79dacb8405d5a0e1aa94d6745089a30b093f647354894d2'
|
||||
'1808df5ba4d1e2f9efa07ac6b510bec866fa6d60e44505d82aea3f6072105a71'
|
||||
'ff9ebd86b0010e1c604d47303ab209b1d76c3e888c423166779cefbc22de297f'
|
||||
'8d1cdf3ddd8ff98f302c90c13953f39cd804b3479b13b69b8ef138ac57c83556'
|
||||
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
|
||||
'b5bb3d0e2cd06aa92bb0ea62d6915dac1635cee79e9e1405cf17fe471baa393e'
|
||||
|
@ -138,6 +140,9 @@ prepare() {
|
|||
# Upstream fixes
|
||||
patch -Np1 -i ../libxml2-2.12.patch
|
||||
|
||||
# Fix build with ICU 74
|
||||
patch -Np1 -i ../icu-74.patch
|
||||
|
||||
# Drop compiler flags that need newer clang
|
||||
patch -Np1 -i ../drop-flags-unsupported-by-clang16.patch
|
||||
|
||||
|
|
21
extra/chromium/icu-74.patch
Normal file
21
extra/chromium/icu-74.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
https://bugs.gentoo.org/917645
|
||||
(copied patch from qtwebengine:6 - https://bugs.gentoo.org/917633)
|
||||
|
||||
Quick fix for a static_assert failure with icu74. Still waiting
|
||||
for a proper upstream fix and unknown if entirely right, but is
|
||||
an extension of [1] (is now 48 rather than 43).
|
||||
|
||||
[1] https://crrev.com/e60b571faa3f14dd9119a6792dccf12f8bf80192
|
||||
--- a/third_party/blink/renderer/platform/text/text_break_iterator.cc
|
||||
+++ b/third_party/blink/renderer/platform/text/text_break_iterator.cc
|
||||
@@ -161,7 +161,9 @@ static const unsigned char kAsciiLineBreakTable[][(kAsciiLineBreakTableLastChar
|
||||
};
|
||||
// clang-format on
|
||||
|
||||
-#if U_ICU_VERSION_MAJOR_NUM >= 58
|
||||
+#if U_ICU_VERSION_MAJOR_NUM >= 74
|
||||
+#define BA_LB_COUNT (U_LB_COUNT - 8)
|
||||
+#elif U_ICU_VERSION_MAJOR_NUM >= 58
|
||||
#define BA_LB_COUNT (U_LB_COUNT - 3)
|
||||
#else
|
||||
#define BA_LB_COUNT U_LB_COUNT
|
Loading…
Reference in a new issue