mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/meson to 0.59.2-1
This commit is contained in:
parent
dbd80e62f8
commit
c6fd28bda2
3 changed files with 33 additions and 6 deletions
|
@ -0,0 +1,22 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Dominique Leuenberger <dimstar@opensuse.org>
|
||||
Date: Wed, 29 Sep 2021 14:20:53 +0200
|
||||
Subject: [PATCH] tests/rust: add libm to fix build with rust 1.55
|
||||
|
||||
Fixes #9309
|
||||
---
|
||||
test cases/rust/5 polyglot static/meson.build | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/test cases/rust/5 polyglot static/meson.build b/test cases/rust/5 polyglot static/meson.build
|
||||
index de2e61bcb..a6e9550b6 100644
|
||||
--- a/test cases/rust/5 polyglot static/meson.build
|
||||
+++ b/test cases/rust/5 polyglot static/meson.build
|
||||
@@ -2,6 +2,7 @@ project('static rust and c polyglot executable', 'c', 'rust')
|
||||
|
||||
deps = [
|
||||
meson.get_compiler('c').find_library('dl', required: false),
|
||||
+ meson.get_compiler('c').find_library('m', required: false),
|
||||
dependency('threads'),
|
||||
]
|
||||
|
|
@ -6,7 +6,7 @@
|
|||
# - disable lto in arch-meson
|
||||
|
||||
pkgname=meson
|
||||
pkgver=0.59.1
|
||||
pkgver=0.59.2
|
||||
pkgrel=1
|
||||
pkgdesc='High productivity build system'
|
||||
url='https://mesonbuild.com/'
|
||||
|
@ -20,17 +20,22 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
|
|||
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'nasm' 'gnustep-base' 'libelf'
|
||||
'python-pytest-xdist' 'python2-setuptools' 'ldc' 'rust-bindgen' 'cuda' 'hotdoc')
|
||||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver/rc/.rc}/meson-${pkgver}.tar.gz{,.asc}
|
||||
0001-tests-rust-add-libm-to-fix-build-with-rust-1.55.patch
|
||||
skip-test.diff
|
||||
arch-meson)
|
||||
sha512sums=('c45e29869dc681675b2643c37c892e7fff365c051edce4f2ec278fc6cee25bac6818add819e4db69d2fe3c1ba9572fc55bb8f67fe791cdc9c187627c71b01963'
|
||||
sha512sums=('910e4a8c9828506b576dc8ae0b5765efec24f44a34a5694f782c8a533d75053b10b4167564c06456d05f7a32c5fd9bd657faa62329e1e4ed24bfc4c9ac1ef73e'
|
||||
'SKIP'
|
||||
'a40e3be7a4ea7048cbbab59d28fb355debdfcdc5e45244aad65ab57fa222f4a2cf3165f28cc7e1dba893a162de9c7563ef0e155fa6a77960c4d02ef622313ace'
|
||||
'c366e149fa04ce41d572fa42a1116d3ddfb25e3e6192c918127d96f2f1e50214c503ce8864473fc7712f0452b63336ac92b4e94fe8ac7f0a9ae6933e07463abc'
|
||||
'c00c3bbb6f6dfe41bb6e05e3eba94fb177f3ef9353bc132e33e54eabacc14d81ed7bff5fe965fb4d49ce8a586a7ebb887b625174f272a48b2f3c85d3288e23b1'
|
||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
# Fix tests with Rust 1.55
|
||||
patch -Np1 -i ../0001-tests-rust-add-libm-to-fix-build-with-rust-1.55.patch
|
||||
|
||||
# Our containers do not allow sanitizers to run
|
||||
patch -Np1 -i ../skip-test.diff
|
||||
}
|
||||
|
@ -61,4 +66,4 @@ package() {
|
|||
install -D ../arch-meson -t "${pkgdir}/usr/bin"
|
||||
}
|
||||
|
||||
# vim: sw=2 et:
|
||||
# vim:set sw=2 et:
|
||||
|
|
|
@ -2,10 +2,10 @@
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git c/run_unittests.py i/run_unittests.py
|
||||
index 828c80e70..7d4e448f0 100755
|
||||
index 15312731c..f9a0e494f 100755
|
||||
--- c/run_unittests.py
|
||||
+++ i/run_unittests.py
|
||||
@@ -6699,6 +6699,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
@@ -7101,6 +7101,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise unittest.SkipTest('asan not available on Cygwin')
|
||||
if is_openbsd():
|
||||
raise unittest.SkipTest('-fsanitize=address is not supported on OpenBSD')
|
||||
|
|
Loading…
Reference in a new issue