core/linux-armv7-rc to 4.18.rc4-2

This commit is contained in:
Kevin Mihelich 2018-07-13 03:30:17 +00:00
parent 696e925d71
commit c71a6666e2
15 changed files with 105 additions and 42 deletions

View file

@ -1,7 +1,7 @@
From 7b92cb52c51053c98e4e9b51f1cbdf87378562cb Mon Sep 17 00:00:00 2001
From 6cd78f818001a5e2caac7cadc3ffff95d752a021 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/13] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 01/14] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 6b335a9ff8c8..614150b53643 100644
};
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From b8a9d378bcb16978a7ab0ec75d66ed1604aca79f Mon Sep 17 00:00:00 2001
From a383c6aaa67e862797d380a5163e633637358568 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/13] ARM: atags/fdt: retrieve MAC addresses from Marvell
Subject: [PATCH 02/14] ARM: atags/fdt: retrieve MAC addresses from Marvell
boot loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 41fa7316c52b..807ed160a4b9 100644
}
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From 29007246e1a081c7675fc4b6f16e4566b10f325c Mon Sep 17 00:00:00 2001
From 121aa156d4d107cf2b174c8eac89c7c473c43829 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/13] SMILE Plug device tree file
Subject: [PATCH 03/14] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From ddc12ee4c0f18e70b485bff20a441c6cacf29b5c Mon Sep 17 00:00:00 2001
From bca0f6d98bb3003178d962f83ba795d524460346 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/13] fix mvsdio eMMC timing
Subject: [PATCH 04/14] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index e22bbff89c8d..6b30c850ce07 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From 5f45e27db60d50da68c2288f274be2835f057114 Mon Sep 17 00:00:00 2001
From 021b0a93050b75f56690bbe41fc470c77f7573c0 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/13] net/smsc95xx: Allow mac address to be set as a
Subject: [PATCH 05/14] net/smsc95xx: Allow mac address to be set as a
parameter
---
@ -92,5 +92,5 @@ index 06b4d290784d..3be3b5a4a176 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From 8a6b26a12dda9ec5efed9f4a0b1bfd393c77cd5e Mon Sep 17 00:00:00 2001
From 529b0cbe182106ce8b52cf465f3c54c3e0f12e1c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/13] set default cubietruck led triggers
Subject: [PATCH 06/14] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -29,5 +29,5 @@ index 5649161de1d7..2be64a886555 100644
};
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From 78becd54a7e941d7de7d8c1ff98cd410701fc60f Mon Sep 17 00:00:00 2001
From adec3bf3f301ddb15994be72c92f43cc5569dd03 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/13] exynos4412-odroid: set higher minimum buck2 regulator
Subject: [PATCH 07/14] exynos4412-odroid: set higher minimum buck2 regulator
voltage
Set a higher minimum voltage to help reboot issue.
@ -26,5 +26,5 @@ index a09e46c9dbc0..d8117a820812 100644
regulator-always-on;
regulator-boot-on;
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From 82f3c593297ef6f08f5fc5b01dcf58fe962e2455 Mon Sep 17 00:00:00 2001
From 58b7a9138a44bef39a860611354c3dac0f558b1f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/13] ARM: dove: enable ethernet on D3Plug
Subject: [PATCH 08/14] ARM: dove: enable ethernet on D3Plug
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From 66ab9eb562e519c47ead6ff7d5ad066896d2f2be Mon Sep 17 00:00:00 2001
From 4ddcbb9ed40c97371724245d0b8d01d471bb6570 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:03 +0800
Subject: [PATCH 09/13] power: add power sequence library
Subject: [PATCH 09/14] power: add power sequence library
We have an well-known problem that the device needs to do some power
sequence before it can be recognized by related host, the typical
@ -109,10 +109,10 @@ index 000000000000..554608e5f3b6
+.. kernel-doc:: drivers/power/pwrseq/core.c
+ :export:
diff --git a/MAINTAINERS b/MAINTAINERS
index 9d5eeff51b5f..3681cf91532d 100644
index 96e98e206b0d..99339375209c 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11393,6 +11393,15 @@ F: drivers/firmware/psci*.c
@@ -11398,6 +11398,15 @@ F: drivers/firmware/psci*.c
F: include/linux/psci.h
F: include/uapi/linux/psci.h
@ -786,5 +786,5 @@ index 000000000000..c5b278f5f2ae
+
+#endif /* __LINUX_PWRSEQ_H */
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From aca7089b9a244be44b76d4021fb38fb9ba78d5bd Mon Sep 17 00:00:00 2001
From 1358757f34c7feff4aab541814c73f6cf3e83b69 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:05 +0800
Subject: [PATCH 10/13] usb: core: add power sequence handling for USB devices
Subject: [PATCH 10/14] usb: core: add power sequence handling for USB devices
Some hard-wired USB devices need to do power sequence to let the
device work normally, the typical power sequence like: enable USB
@ -160,5 +160,5 @@ index 4accfb63f7dc..abe71c5e84cb 100644
/**
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From eb5b8019af89ca315bbe6cd9d9e89a2f4d73a953 Mon Sep 17 00:00:00 2001
From 0b61e501bdfb883df4211fdc47d246df6af06e5a Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:06 +0800
Subject: [PATCH 11/13] ARM: dts: imx6qdl: Enable usb node children with <reg>
Subject: [PATCH 11/14] ARM: dts: imx6qdl: Enable usb node children with <reg>
Give usb nodes #address and #size attributes, so that a child node
representing a permanently connected device such as an onboard hub may
@ -45,5 +45,5 @@ index 911141e24681..c74e9c7a83bf 100644
interrupts = <0 42 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clks IMX6QDL_CLK_USBOH3>;
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From 47158daa865de05bcf0c0465c22e888514793cfe Mon Sep 17 00:00:00 2001
From 3e35057ab8b11c232a7c0edeea3299d53c6d600d Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:07 +0800
Subject: [PATCH 12/13] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
Subject: [PATCH 12/14] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
property
The current dts describes USB HUB's property at USB controller's
@ -76,5 +76,5 @@ index 4f27861bbb32..dead14b0d4bf 100644
&usdhc3 {
--
2.17.1
2.18.0

View file

@ -1,7 +1,7 @@
From b47f83652c32f2bb3d1d23c89eef170d3db28d07 Mon Sep 17 00:00:00 2001
From 9d40728e452daf4d77f8924e499814138dc5363c Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:08 +0800
Subject: [PATCH 13/13] ARM: dts: imx6q-evi: Fix onboard hub reset line
Subject: [PATCH 13/14] ARM: dts: imx6q-evi: Fix onboard hub reset line
Previously the onboard hub was made to work by treating its
reset gpio as a regulator enable.
@ -70,5 +70,5 @@ index fcd257bc5ac3..d32fa81bba95 100644
>;
};
--
2.17.1
2.18.0

View file

@ -0,0 +1,61 @@
From a877c2568fc96a7a7ba89dd4cf0df20341df2a37 Mon Sep 17 00:00:00 2001
From: Ethan Tuttle <ethan@ethantuttle.com>
Date: Tue, 19 Jun 2018 21:31:08 -0700
Subject: [PATCH 14/14] ARM: mvebu: declare asm symbols as character arrays in
pmsu.c
With CONFIG_FORTIFY_SOURCE, memcpy uses the declared size of operands to
detect buffer overflows. If src or dest is declared as a char, attempts to
copy more than byte will result in a fortify_panic().
Address this problem in mvebu_setup_boot_addr_wa() by declaring
mvebu_boot_wa_start and mvebu_boot_wa_end as character arrays. Also remove
a couple addressof operators to avoid "arithmetic on pointer to an
incomplete type" compiler error.
See commit 54a7d50b9205 ("x86: mark kprobe templates as character arrays,
not single characters") for a similar fix.
Fixes "detected buffer overflow in memcpy" error during init on some mvebu
systems (armada-370-xp, armada-375):
(fortify_panic) from (mvebu_setup_boot_addr_wa+0xb0/0xb4)
(mvebu_setup_boot_addr_wa) from (mvebu_v7_cpu_pm_init+0x154/0x204)
(mvebu_v7_cpu_pm_init) from (do_one_initcall+0x7c/0x1a8)
(do_one_initcall) from (kernel_init_freeable+0x1bc/0x254)
(kernel_init_freeable) from (kernel_init+0x8/0x114)
(kernel_init) from (ret_from_fork+0x14/0x2c)
Signed-off-by: Ethan Tuttle <ethan@ethantuttle.com>
Tested-by: Ethan Tuttle <ethan@ethantuttle.com>
---
arch/arm/mach-mvebu/pmsu.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/arm/mach-mvebu/pmsu.c b/arch/arm/mach-mvebu/pmsu.c
index 27a78c80e5b1..73d5d72dfc3e 100644
--- a/arch/arm/mach-mvebu/pmsu.c
+++ b/arch/arm/mach-mvebu/pmsu.c
@@ -116,8 +116,8 @@ void mvebu_pmsu_set_cpu_boot_addr(int hw_cpu, void *boot_addr)
PMSU_BOOT_ADDR_REDIRECT_OFFSET(hw_cpu));
}
-extern unsigned char mvebu_boot_wa_start;
-extern unsigned char mvebu_boot_wa_end;
+extern unsigned char mvebu_boot_wa_start[];
+extern unsigned char mvebu_boot_wa_end[];
/*
* This function sets up the boot address workaround needed for SMP
@@ -130,7 +130,7 @@ int mvebu_setup_boot_addr_wa(unsigned int crypto_eng_target,
phys_addr_t resume_addr_reg)
{
void __iomem *sram_virt_base;
- u32 code_len = &mvebu_boot_wa_end - &mvebu_boot_wa_start;
+ u32 code_len = mvebu_boot_wa_end - mvebu_boot_wa_start;
mvebu_mbus_del_window(BOOTROM_BASE, BOOTROM_SIZE);
mvebu_mbus_add_window_by_id(crypto_eng_target, crypto_eng_attribute,
--
2.18.0

View file

@ -12,7 +12,7 @@ _srcname=linux-${_rcver}-rc${_rcrel}
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform (release candidate)"
pkgver=${_rcver}.rc${_rcrel}
pkgrel=1
pkgrel=2
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
@ -33,6 +33,7 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch'
'0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch'
'0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch'
'0014-ARM-mvebu-declare-asm-symbols-as-character-arrays-in.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -82,6 +83,7 @@ prepare() {
git apply ../0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch
git apply ../0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch
git apply ../0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch
git apply ../0014-ARM-mvebu-declare-asm-symbols-as-character-arrays-in.patch
cat "${srcdir}/config" > ./.config