mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/qt6-doc to 6.1.0-1
This commit is contained in:
parent
13648f68d7
commit
c73ce4090f
2 changed files with 7 additions and 24 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgbase=qt6-doc
|
||||
pkgname=(qt6-doc qt6-examples)
|
||||
_qtver=6.0.4
|
||||
_qtver=6.1.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=1
|
||||
arch=('any')
|
||||
|
@ -16,11 +16,11 @@ license=(GPL3 LGPL3 FDL custom)
|
|||
makedepends=(cmake mariadb-libs unixodbc postgresql alsa-lib gst-plugins-base-libs
|
||||
gtk3 libpulse cups freetds vulkan-headers clang python llvm qt6-tools)
|
||||
groups=(qt6)
|
||||
_pkgfn="qt-everywhere-src-${_qtver}"
|
||||
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfn}.tar.xz"
|
||||
qt6-doc-bindir.patch)
|
||||
sha256sums=('677db6472420f9046b16f7c0d0aa15c4f11f344462a6374feb860625c12fc72b'
|
||||
'60eebdf88559fefdb2b7c65b5f4ec091942aa1ffa371bedb4080545383b46109')
|
||||
_pkgfn="qt-everywhere-src-$_qtver"
|
||||
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/single/$_pkgfn.tar.xz
|
||||
qt6-doc-bindir.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=582fdf06)
|
||||
sha256sums=('326a710b08b0973bb4f5306a786548d8b8dd656db75ce9f3f85ea32680d3c88a'
|
||||
'7ab018729ae933f7f4ba0a4783f8f66277c681aa9dd7657ecdf011120b56bda1')
|
||||
|
||||
prepare() {
|
||||
patch -d $_pkgfn/qtbase -p1 -i ../../qt6-doc-bindir.patch # Use installed tools
|
||||
|
@ -30,6 +30,7 @@ build() {
|
|||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && echo "target_link_libraries(Core PRIVATE atomic)" >> ${_pkgfn}/qtbase/src/corelib/CMakeLists.txt
|
||||
cmake -B build -S $_pkgfn \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DQT_HOST_PATH=/usr \
|
||||
-DINSTALL_BINDIR=lib/qt6/bin \
|
||||
-DINSTALL_DOCDIR=share/doc/qt6 \
|
||||
-DINSTALL_ARCHDATADIR=lib/qt6 \
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
diff --git a/cmake/QtDocsHelpers.cmake b/cmake/QtDocsHelpers.cmake
|
||||
index 8e4bd28918..963114e1ec 100644
|
||||
--- a/cmake/QtDocsHelpers.cmake
|
||||
+++ b/cmake/QtDocsHelpers.cmake
|
||||
@@ -31,12 +31,7 @@ function(qt_internal_add_docs)
|
||||
return()
|
||||
endif()
|
||||
|
||||
- if(QT_SUPERBUILD)
|
||||
- set(doc_tools_dir "${QtBase_BINARY_DIR}/${INSTALL_BINDIR}")
|
||||
- else()
|
||||
- set(doc_tools_dir "${QT_BUILD_INTERNALS_RELOCATABLE_INSTALL_PREFIX}/${INSTALL_BINDIR}")
|
||||
- endif()
|
||||
-
|
||||
+ set(doc_tools_dir "/usr/lib/qt6/bin")
|
||||
set(qdoc_bin "${doc_tools_dir}/qdoc${CMAKE_EXECUTABLE_SUFFIX}")
|
||||
set(qtattributionsscanner_bin "${doc_tools_dir}/qtattributionsscanner${CMAKE_EXECUTABLE_SUFFIX}")
|
||||
set(qhelpgenerator_bin "${doc_tools_dir}/qhelpgenerator${CMAKE_EXECUTABLE_SUFFIX}")
|
Loading…
Reference in a new issue