community/bamf to 0.5.0-3

This commit is contained in:
Kevin Mihelich 2014-05-27 11:04:54 +00:00
parent 32d0aae307
commit c745eae7ca
2 changed files with 39 additions and 6 deletions

View file

@ -7,21 +7,30 @@
pkgname=bamf
pkgver=0.5.0
pkgrel=2
pkgdesc="Application matching framework"
pkgrel=3
pkgdesc='Application matching framework'
arch=('i686' 'x86_64')
url="https://launchpad.net/bamf"
url='https://launchpad.net/bamf'
license=('GPL')
depends=('libgtop' 'libwnck3')
makedepends=('gobject-introspection' 'python2-lxml' 'vala')
source=("http://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
sha256sums=('93b1acced96d32b36270cf18feb2761014ce2226814303c632448f717a8f9113')
source=("http://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
'fix-legacy-window-test.patch')
sha256sums=('93b1acced96d32b36270cf18feb2761014ce2226814303c632448f717a8f9113'
'0d052f6d654ae86d14d7f73c428237b9410d11986ee1112d988a7ffe1df0988e')
prepare() {
cd ${pkgname}-${pkgver}
patch -Np0 -i ../fix-legacy-window-test.patch
}
build() {
cd ${pkgname}-${pkgver}
export PYTHON='/usr/bin/python2'
./configure --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' --libexecdir="/usr/lib/${pkgname}" --disable-{static,webapps} --enable-compile-warnings=no
./configure --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' \
--libexecdir="/usr/lib/${pkgname}" --disable-{static,webapps} --enable-compile-warnings=no
make
}

View file

@ -0,0 +1,24 @@
--- src/bamf-legacy-window-test.c 2013-08-08 12:32:39 +0000
+++ src/bamf-legacy-window-test.c 2014-01-07 19:15:14 +0000
@@ -427,7 +427,7 @@
g_return_if_fail (BAMF_IS_LEGACY_WINDOW_TEST (window));
BamfLegacyWindowTest *self = BAMF_LEGACY_WINDOW_TEST (window);
- return g_hash_table_insert (self->hints, g_strdup (name), g_strdup (value));
+ g_hash_table_insert (self->hints, g_strdup (name), g_strdup (value));
}
static char *
=== modified file 'src/bamf-view.c'
--- src/bamf-view.c 2013-07-31 00:11:27 +0000
+++ src/bamf-view.c 2014-01-09 16:24:53 +0000
@@ -88,6 +88,7 @@
gboolean active = bamf_view_is_active (self);
g_signal_emit_by_name (self, "active-changed", active);
+ self->priv->active_changed_idle = 0;
return FALSE;
}