mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mesa to 20.3.4-3
This commit is contained in:
parent
92e25fdd68
commit
c74f2dfa3d
2 changed files with 120 additions and 3 deletions
|
@ -0,0 +1,109 @@
|
|||
From ccacfc317e4fac62052a22e2d092d15541e2877e Mon Sep 17 00:00:00 2001
|
||||
From: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>
|
||||
Date: Mon, 11 Jan 2021 15:20:40 +0100
|
||||
Subject: [PATCH] vulkan/device_select: Stop using device properties 2.
|
||||
|
||||
We have to choose between:
|
||||
1) Stop handling two identical GPUs
|
||||
2) Stop having crashes with other layers active.
|
||||
3) Fix the Vulkan Loader.
|
||||
|
||||
Since nobody seems to want to spend enough effort to do 3 the
|
||||
effective choice is between 1 and 2. This is choosing 2, as
|
||||
two identical GPUs is pretty uncommon since crossfire doesn't
|
||||
work on Linux anyway.
|
||||
|
||||
(And it would only work sporadically as the game needs to enable the
|
||||
extension)
|
||||
|
||||
CC: mesa-stable
|
||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/3801
|
||||
Reviewed-by: Dave Airlie <airlied@redhat.com>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8414>
|
||||
(cherry picked from commit 38ce8d4d00c2b0e567b6dd36876cf171acb1dbc7)
|
||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
||||
---
|
||||
.../device-select-layer/device_select_layer.c | 30 +++++++++++--------
|
||||
1 file changed, 18 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/src/vulkan/device-select-layer/device_select_layer.c b/src/vulkan/device-select-layer/device_select_layer.c
|
||||
index c381ac33fd1..134a3bd22dd 100644
|
||||
--- a/src/vulkan/device-select-layer/device_select_layer.c
|
||||
+++ b/src/vulkan/device-select-layer/device_select_layer.c
|
||||
@@ -51,8 +51,8 @@ struct instance_info {
|
||||
PFN_GetPhysicalDeviceProcAddr GetPhysicalDeviceProcAddr;
|
||||
PFN_vkEnumerateDeviceExtensionProperties EnumerateDeviceExtensionProperties;
|
||||
PFN_vkGetPhysicalDeviceProperties GetPhysicalDeviceProperties;
|
||||
- PFN_vkGetPhysicalDeviceProperties2KHR GetPhysicalDeviceProperties2KHR;
|
||||
- bool has_props2, has_pci_bus;
|
||||
+ PFN_vkGetPhysicalDeviceProperties2 GetPhysicalDeviceProperties2;
|
||||
+ bool has_pci_bus, has_vulkan11;
|
||||
bool has_wayland, has_xcb;
|
||||
};
|
||||
|
||||
@@ -150,8 +150,6 @@ static VkResult device_select_CreateInstance(const VkInstanceCreateInfo *pCreate
|
||||
}
|
||||
|
||||
for (unsigned i = 0; i < pCreateInfo->enabledExtensionCount; i++) {
|
||||
- if (!strcmp(pCreateInfo->ppEnabledExtensionNames[i], VK_KHR_GET_PHYSICAL_DEVICE_PROPERTIES_2_EXTENSION_NAME))
|
||||
- info->has_props2 = true;
|
||||
#ifdef VK_USE_PLATFORM_WAYLAND_KHR
|
||||
if (!strcmp(pCreateInfo->ppEnabledExtensionNames[i], VK_KHR_WAYLAND_SURFACE_EXTENSION_NAME))
|
||||
info->has_wayland = true;
|
||||
@@ -162,6 +160,14 @@ static VkResult device_select_CreateInstance(const VkInstanceCreateInfo *pCreate
|
||||
#endif
|
||||
}
|
||||
|
||||
+ /*
|
||||
+ * The loader is currently not able to handle GetPhysicalDeviceProperties2KHR calls in
|
||||
+ * EnumeratePhysicalDevices when there are other layers present. To avoid mysterious crashes
|
||||
+ * for users just use only the vulkan version for now.
|
||||
+ */
|
||||
+ info->has_vulkan11 = pCreateInfo->pApplicationInfo &&
|
||||
+ pCreateInfo->pApplicationInfo->apiVersion >= VK_MAKE_VERSION(1, 1, 0);
|
||||
+
|
||||
info->GetPhysicalDeviceProcAddr = (PFN_GetPhysicalDeviceProcAddr)info->GetInstanceProcAddr(*pInstance, "vk_layerGetPhysicalDeviceProcAddr");
|
||||
#define DEVSEL_GET_CB(func) info->func = (PFN_vk##func)info->GetInstanceProcAddr(*pInstance, "vk" #func)
|
||||
DEVSEL_GET_CB(DestroyInstance);
|
||||
@@ -169,8 +175,8 @@ static VkResult device_select_CreateInstance(const VkInstanceCreateInfo *pCreate
|
||||
DEVSEL_GET_CB(EnumeratePhysicalDeviceGroups);
|
||||
DEVSEL_GET_CB(GetPhysicalDeviceProperties);
|
||||
DEVSEL_GET_CB(EnumerateDeviceExtensionProperties);
|
||||
- if (info->has_props2)
|
||||
- DEVSEL_GET_CB(GetPhysicalDeviceProperties2KHR);
|
||||
+ if (info->has_vulkan11)
|
||||
+ DEVSEL_GET_CB(GetPhysicalDeviceProperties2);
|
||||
#undef DEVSEL_GET_CB
|
||||
|
||||
device_select_layer_add_instance(*pInstance, info);
|
||||
@@ -197,10 +203,10 @@ static void print_gpu(const struct instance_info *info, unsigned index, VkPhysic
|
||||
VkPhysicalDeviceProperties2KHR properties = (VkPhysicalDeviceProperties2KHR){
|
||||
.sType = VK_STRUCTURE_TYPE_PHYSICAL_DEVICE_PROPERTIES_2_KHR
|
||||
};
|
||||
- if (info->has_props2 && info->has_pci_bus)
|
||||
+ if (info->has_vulkan11 && info->has_pci_bus)
|
||||
properties.pNext = &ext_pci_properties;
|
||||
- if (info->GetPhysicalDeviceProperties2KHR)
|
||||
- info->GetPhysicalDeviceProperties2KHR(device, &properties);
|
||||
+ if (info->GetPhysicalDeviceProperties2)
|
||||
+ info->GetPhysicalDeviceProperties2(device, &properties);
|
||||
else
|
||||
info->GetPhysicalDeviceProperties(device, &properties.properties);
|
||||
|
||||
@@ -243,10 +249,10 @@ static bool fill_drm_device_info(const struct instance_info *info,
|
||||
.sType = VK_STRUCTURE_TYPE_PHYSICAL_DEVICE_PROPERTIES_2_KHR
|
||||
};
|
||||
|
||||
- if (info->has_props2 && info->has_pci_bus)
|
||||
+ if (info->has_vulkan11 && info->has_pci_bus)
|
||||
properties.pNext = &ext_pci_properties;
|
||||
- if (info->GetPhysicalDeviceProperties2KHR)
|
||||
- info->GetPhysicalDeviceProperties2KHR(device, &properties);
|
||||
+ if (info->GetPhysicalDeviceProperties2)
|
||||
+ info->GetPhysicalDeviceProperties2(device, &properties);
|
||||
else
|
||||
info->GetPhysicalDeviceProperties(device, &properties.properties);
|
||||
|
||||
--
|
||||
2.30.1
|
||||
|
|
@ -12,7 +12,7 @@ pkgbase=mesa
|
|||
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'vulkan-swrast' 'vulkan-broadcom' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||
pkgver=20.3.4
|
||||
pkgrel=2.1
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
||||
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
|
||||
|
@ -22,11 +22,13 @@ url="https://www.mesa3d.org/"
|
|||
license=('custom')
|
||||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||
0001-Rip-out-VC4-forced-NEON.patch
|
||||
LICENSE)
|
||||
LICENSE
|
||||
0001-vulkan-device_select-Stop-using-device-properties-2.patch)
|
||||
sha512sums=('81c4d032213b4aef842f1594e0e89bc0045f7ca7ce5f267b62a0f8236eb12ab09c1f780d8b3776b3072f37cd0bd8829f8a1330a749ccf462471b262ef8097477'
|
||||
'SKIP'
|
||||
'ba55fd9816ebd9147be120da1fd4fa0364d19967a11570e6d5dd9d8b4f7971df46ced8b151ee07afaaa98043e131eed14918ec25f8c9b0f7e5c53f452674ee5c'
|
||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7'
|
||||
'73a923dac10616ab46b825cd45f73ca849ddad69432dbf680c1129cc9a92004218affa33bd1a6ee185fa0143ccd3d3622ba40512ec049a160a61cc13fe92da0a')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||
'E3E8F480C52ADD73B278EE78E1ECBE07D7D70895' # Juan Antonio Suárez Romero (Igalia, S.L.) <jasuarez@igalia.com>
|
||||
|
@ -37,6 +39,9 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
|
|||
prepare() {
|
||||
cd mesa-$pkgver
|
||||
|
||||
# FS#69744
|
||||
patch -Np1 -i ../0001-vulkan-device_select-Stop-using-device-properties-2.patch
|
||||
|
||||
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
|
||||
}
|
||||
|
||||
|
@ -170,6 +175,7 @@ package_vulkan-broadcom() {
|
|||
package_libva-mesa-driver() {
|
||||
pkgdesc="VA-API implementation for gallium"
|
||||
depends=('libdrm' 'libx11' 'llvm-libs' 'expat' 'libelf' 'libxshmfence')
|
||||
depends+=('libexpat.so')
|
||||
|
||||
_install fakeinstall/usr/lib/dri/*_drv_video.so
|
||||
|
||||
|
@ -179,6 +185,7 @@ package_libva-mesa-driver() {
|
|||
package_mesa-vdpau() {
|
||||
pkgdesc="Mesa VDPAU drivers"
|
||||
depends=('libdrm' 'libx11' 'llvm-libs' 'expat' 'libelf' 'libxshmfence')
|
||||
depends+=('libexpat.so')
|
||||
|
||||
_install fakeinstall/usr/lib/vdpau
|
||||
|
||||
|
@ -189,6 +196,7 @@ package_mesa() {
|
|||
depends=('libdrm' 'wayland' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
|
||||
'libomxil-bellagio' 'libunwind' 'llvm-libs' 'lm_sensors' 'libglvnd'
|
||||
'zstd' 'vulkan-icd-loader')
|
||||
depends+=('libsensors.so' 'libexpat.so' 'libvulkan.so')
|
||||
optdepends=('opengl-man-pages: for the OpenGL API man pages'
|
||||
'mesa-vdpau: for accelerated video playback'
|
||||
'libva-mesa-driver: for accelerated video playback')
|
||||
|
|
Loading…
Reference in a new issue