mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-armv7-rc to 4.5.rc1-1
This commit is contained in:
parent
e9dfc31ccf
commit
c75b62df47
13 changed files with 1034 additions and 469 deletions
|
@ -1,7 +1,7 @@
|
||||||
From 7c75672c751c1a9001f39bbe76c7ee092b4e6a29 Mon Sep 17 00:00:00 2001
|
From 1865738986bfdcd18cfc5d19e8f07e25fb6bc700 Mon Sep 17 00:00:00 2001
|
||||||
From: Willy Tarreau <w@xxxxxx>
|
From: Willy Tarreau <w@xxxxxx>
|
||||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||||
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
|
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
|
||||||
|
|
||||||
Marvell uses a specific atag in its u-boot which includes among other
|
Marvell uses a specific atag in its u-boot which includes among other
|
||||||
information the MAC addresses for up to 4 network interfaces.
|
information the MAC addresses for up to 4 network interfaces.
|
||||||
|
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
|
||||||
};
|
};
|
||||||
|
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 1fea82d0497ae305d2110585af7f57c81e0375df Mon Sep 17 00:00:00 2001
|
From d2b101f19de81748f19cf4760d57efccda2c5d66 Mon Sep 17 00:00:00 2001
|
||||||
From: Willy Tarreau <w@xxxxxx>
|
From: Willy Tarreau <w@xxxxxx>
|
||||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||||
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||||
loader
|
loader
|
||||||
|
|
||||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||||
|
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
|
||||||
}
|
}
|
||||||
|
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 58707640a58c98688345a01cc4aaab5e9a5302ae Mon Sep 17 00:00:00 2001
|
From 9acdd8ae2bd23c3ef43fcef69e400672b92de95b Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||||
Subject: [PATCH 3/9] SMILE Plug device tree file
|
Subject: [PATCH 3/8] SMILE Plug device tree file
|
||||||
|
|
||||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||||
dts with the LED definitions.
|
dts with the LED definitions.
|
||||||
|
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
|
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||||
index bb8fa02..4a41a60 100644
|
index a4a6d70..c710c30 100644
|
||||||
--- a/arch/arm/boot/dts/Makefile
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
+++ b/arch/arm/boot/dts/Makefile
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
@@ -699,6 +699,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
|
@@ -767,6 +767,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||||
armada-370-db.dtb \
|
armada-370-db.dtb \
|
||||||
armada-370-dlink-dns327l.dtb \
|
armada-370-dlink-dns327l.dtb \
|
||||||
armada-370-mirabox.dtb \
|
armada-370-mirabox.dtb \
|
||||||
|
@ -205,5 +205,5 @@ index 0000000..d01308a
|
||||||
+ };
|
+ };
|
||||||
+};
|
+};
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 279ad74e38e3c692eab7c59fae909fe22ea5d1dd Mon Sep 17 00:00:00 2001
|
From f643f71b3f1a017bce6a1c6180a2c337faa4d955 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||||
Subject: [PATCH 4/9] fix mvsdio eMMC timing
|
Subject: [PATCH 4/8] fix mvsdio eMMC timing
|
||||||
|
|
||||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||||
of the Mirabox and SMILE Plug to work.
|
of the Mirabox and SMILE Plug to work.
|
||||||
|
@ -12,10 +12,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||||
index a448498..14441a6 100644
|
index 42296e5..e5ce6d2 100644
|
||||||
--- a/drivers/mmc/host/mvsdio.c
|
--- a/drivers/mmc/host/mvsdio.c
|
||||||
+++ b/drivers/mmc/host/mvsdio.c
|
+++ b/drivers/mmc/host/mvsdio.c
|
||||||
@@ -96,7 +96,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
@@ -93,7 +93,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||||
tmout_index = fls(tmout - 1) - 12;
|
tmout_index = fls(tmout - 1) - 12;
|
||||||
if (tmout_index < 0)
|
if (tmout_index < 0)
|
||||||
tmout_index = 0;
|
tmout_index = 0;
|
||||||
|
@ -24,7 +24,7 @@ index a448498..14441a6 100644
|
||||||
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
|
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
|
||||||
|
|
||||||
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
|
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
|
||||||
@@ -618,6 +618,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
|
@@ -615,6 +615,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
|
||||||
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
|
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
|
||||||
if (m > MVSD_BASE_DIV_MAX)
|
if (m > MVSD_BASE_DIV_MAX)
|
||||||
m = MVSD_BASE_DIV_MAX;
|
m = MVSD_BASE_DIV_MAX;
|
||||||
|
@ -34,5 +34,5 @@ index a448498..14441a6 100644
|
||||||
host->clock = ios->clock;
|
host->clock = ios->clock;
|
||||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,14 +1,14 @@
|
||||||
From dad3e39a200b3f91e5e4790fe95cdbfc27a18673 Mon Sep 17 00:00:00 2001
|
From 5cde4e462ceb11f52c1db73e64820e8012956c15 Mon Sep 17 00:00:00 2001
|
||||||
From: popcornmix <popcornmix@gmail.com>
|
From: popcornmix <popcornmix@gmail.com>
|
||||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||||
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
|
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
|
|
||||||
---
|
---
|
||||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||||
1 file changed, 56 insertions(+)
|
1 file changed, 56 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||||
index 26423ad..e29a323 100644
|
index 66b3ab9..3cc50f6 100644
|
||||||
--- a/drivers/net/usb/smsc95xx.c
|
--- a/drivers/net/usb/smsc95xx.c
|
||||||
+++ b/drivers/net/usb/smsc95xx.c
|
+++ b/drivers/net/usb/smsc95xx.c
|
||||||
@@ -59,6 +59,7 @@
|
@@ -59,6 +59,7 @@
|
||||||
|
@ -91,5 +91,5 @@ index 26423ad..e29a323 100644
|
||||||
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
||||||
dev->net->dev_addr) == 0) {
|
dev->net->dev_addr) == 0) {
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 7e8b6c3551ea6a2b4e9201188a5fb79c5970f114 Mon Sep 17 00:00:00 2001
|
From 563309df6c312c412771dc979994fa91918fdc15 Mon Sep 17 00:00:00 2001
|
||||||
From: dobatog <dobatog@gmail.com>
|
From: dobatog <dobatog@gmail.com>
|
||||||
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
||||||
Subject: [PATCH 6/9] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
Subject: [PATCH 6/8] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||||
related to input routing signals.
|
related to input routing signals.
|
||||||
|
|
||||||
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
||||||
|
@ -45,5 +45,5 @@ index cd8c02b..95e6b11 100644
|
||||||
/* input mux */
|
/* input mux */
|
||||||
{"Capture Source", "Line", "Line Input"},
|
{"Capture Source", "Line", "Line Input"},
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 31e04e014a3f8cc88b3755be8aa44a4d2051f53a Mon Sep 17 00:00:00 2001
|
From 48dd6fad6145335b72315ab3de6b16d2a3a0ea25 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
||||||
Subject: [PATCH 7/9] set default cubietruck led triggers
|
Subject: [PATCH 7/8] set default cubietruck led triggers
|
||||||
|
|
||||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
---
|
---
|
||||||
|
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
1 file changed, 2 insertions(+)
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||||
index e6b0192..fff91d3 100644
|
index 8da939a..9957d5f 100644
|
||||||
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||||
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||||
@@ -70,6 +70,7 @@
|
@@ -70,6 +70,7 @@
|
||||||
|
@ -29,5 +29,5 @@ index e6b0192..fff91d3 100644
|
||||||
};
|
};
|
||||||
|
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 0bef4c3483f1a30f027ae375e1c04a2e6be91150 Mon Sep 17 00:00:00 2001
|
From eac6f9c17be14dd033a7464a50aced593e7d5973 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sat, 7 Feb 2015 12:32:27 +0100
|
Date: Sat, 7 Feb 2015 12:32:27 +0100
|
||||||
Subject: [PATCH 8/9] USB armory support
|
Subject: [PATCH 8/8] USB armory support
|
||||||
|
|
||||||
---
|
---
|
||||||
arch/arm/boot/dts/Makefile | 5 +
|
arch/arm/boot/dts/Makefile | 5 +
|
||||||
|
@ -20,10 +20,10 @@ Subject: [PATCH 8/9] USB armory support
|
||||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||||
index 4a41a60..a2df2c2 100644
|
index c710c30..e9a95ef 100644
|
||||||
--- a/arch/arm/boot/dts/Makefile
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
+++ b/arch/arm/boot/dts/Makefile
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
@@ -268,6 +268,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
|
@@ -287,6 +287,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
|
||||||
imx53-smd.dtb \
|
imx53-smd.dtb \
|
||||||
imx53-tx53-x03x.dtb \
|
imx53-tx53-x03x.dtb \
|
||||||
imx53-tx53-x13x.dtb \
|
imx53-tx53-x13x.dtb \
|
||||||
|
@ -452,5 +452,5 @@ index 0000000..902a73b
|
||||||
+ status = "okay";
|
+ status = "okay";
|
||||||
+};
|
+};
|
||||||
--
|
--
|
||||||
2.6.4
|
2.7.0
|
||||||
|
|
||||||
|
|
|
@ -1,34 +0,0 @@
|
||||||
From 1fdf53fafef2ccc0684a3b655e716b9921642197 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Russell King <rmk+kernel@arm.linux.org.uk>
|
|
||||||
Date: Sun, 6 Dec 2015 23:28:37 +0000
|
|
||||||
Subject: [PATCH 9/9] ARM: dts: dove: add Dove divider clocks
|
|
||||||
|
|
||||||
Add the Dove divider clocks to the Dove dtsi file.
|
|
||||||
|
|
||||||
Acked-by: Andrew Lunn <andrew@lunn.ch>
|
|
||||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|
||||||
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
|
|
||||||
---
|
|
||||||
arch/arm/boot/dts/dove.dtsi | 6 ++++++
|
|
||||||
1 file changed, 6 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/dove.dtsi b/arch/arm/boot/dts/dove.dtsi
|
|
||||||
index 1791216..ea36a26 100644
|
|
||||||
--- a/arch/arm/boot/dts/dove.dtsi
|
|
||||||
+++ b/arch/arm/boot/dts/dove.dtsi
|
|
||||||
@@ -459,6 +459,12 @@
|
|
||||||
#clock-cells = <1>;
|
|
||||||
};
|
|
||||||
|
|
||||||
+ divider_clk: core-clock@0064 {
|
|
||||||
+ compatible = "marvell,dove-divider-clock";
|
|
||||||
+ reg = <0x0064 0x8>;
|
|
||||||
+ #clock-cells = <1>;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
pinctrl: pin-ctrl@0200 {
|
|
||||||
compatible = "marvell,dove-pinctrl";
|
|
||||||
reg = <0x0200 0x14>,
|
|
||||||
--
|
|
||||||
2.6.4
|
|
||||||
|
|
|
@ -3,9 +3,9 @@
|
||||||
|
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
_rcver=4.4
|
_rcver=4.5
|
||||||
_rcrel=8
|
_rcrel=1
|
||||||
_rcnrel=armv7-x3
|
_rcnrel=armv7-x0
|
||||||
|
|
||||||
pkgbase=linux-armv7-rc
|
pkgbase=linux-armv7-rc
|
||||||
#_srcname=linux-4.$((${_rcver##*.}-1))
|
#_srcname=linux-4.$((${_rcver##*.}-1))
|
||||||
|
@ -13,7 +13,7 @@ _srcname=linux-${_rcver}-rc${_rcrel}
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="ARMv7 multi-platform (release candidate)"
|
_desc="ARMv7 multi-platform (release candidate)"
|
||||||
pkgver=${_rcver}.rc${_rcrel}
|
pkgver=${_rcver}.rc${_rcrel}
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
|
@ -31,26 +31,24 @@ source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||||
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
||||||
'0007-set-default-cubietruck-led-triggers.patch'
|
'0007-set-default-cubietruck-led-triggers.patch'
|
||||||
'0008-USB-armory-support.patch'
|
'0008-USB-armory-support.patch'
|
||||||
'0009-ARM-dts-dove-add-Dove-divider-clocks.patch'
|
|
||||||
'config'
|
'config'
|
||||||
'cmdline'
|
'cmdline'
|
||||||
'kernel.its'
|
'kernel.its'
|
||||||
'kernel.keyblock'
|
'kernel.keyblock'
|
||||||
'kernel_data_key.vbprivk')
|
'kernel_data_key.vbprivk')
|
||||||
md5sums=('22e297f4149c08304317e26e938a965d'
|
md5sums=('22d3f0907983f0c90f5029fca541ff78'
|
||||||
'924680e95c07a5b2b74d3d62384b253d'
|
'7e987231c67207a53286f9bf4035ca4e'
|
||||||
'57a686c6674aa9896a590181ac15bdd4'
|
'961fa2a54f528b43dcb81ba2a25d7b70'
|
||||||
'd589f8eb618b9e4b15d06d61482b6925'
|
'3af7a357c66bef25efdf53d8a56f4e55'
|
||||||
'f973d396510cfd28a9e0024693d5caa7'
|
'be5dfa1c765ab00da3c47e4a334e5701'
|
||||||
'e786bc0db8a868795545616e8e87d6e7'
|
'63daab470ba29aa34e9131dc90068ec1'
|
||||||
'4384cc3a06932ef70d2981991a93ce62'
|
'64329ab3d41be3f7b95585aad1af3923'
|
||||||
'2e6c1bda9a29b4308d82371e566f4332'
|
'15a9ab8c8c2446778a29789e9415deb8'
|
||||||
'a43cc24e0fc27caf96b03a7895dc6543'
|
'82821ac063e3426d19f5e63265cc3887'
|
||||||
'47a9efe2f0114b099662706a5c4d45e5'
|
'fcdc94a493f2c6cdfdaa7cedf997e858'
|
||||||
'cc8885354fd6ce2bb63722a34c4d383a'
|
'53fa8c44213ea3b3ec3505ef4b27fb65'
|
||||||
'90de6cf7852d31f6dcb1dc654bcf2340'
|
|
||||||
'1813b39074d01af6548951764a0f6444'
|
'1813b39074d01af6548951764a0f6444'
|
||||||
'4b0392e55063eb9f89d91affd1189fc5'
|
'4f2379ed84258050edb858ee8d281678'
|
||||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||||
'584777ae88bce2c5659960151b64c7d8')
|
'584777ae88bce2c5659960151b64c7d8')
|
||||||
|
|
||||||
|
@ -72,7 +70,6 @@ prepare() {
|
||||||
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
||||||
git apply ../0007-set-default-cubietruck-led-triggers.patch
|
git apply ../0007-set-default-cubietruck-led-triggers.patch
|
||||||
git apply ../0008-USB-armory-support.patch
|
git apply ../0008-USB-armory-support.patch
|
||||||
git apply ../0009-ARM-dts-dove-add-Dove-divider-clocks.patch
|
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
@ -188,12 +185,14 @@ _package-headers() {
|
||||||
# copy arch includes for external modules
|
# copy arch includes for external modules
|
||||||
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH
|
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH
|
||||||
cp -a arch/$KARCH/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/
|
cp -a arch/$KARCH/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/
|
||||||
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-omap2
|
for i in dove exynos omap2; do
|
||||||
cp -a arch/$KARCH/mach-omap2/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-omap2/
|
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-${i}
|
||||||
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-mvebu
|
cp -a arch/$KARCH/mach-${i}/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-${i}/
|
||||||
cp -a arch/$KARCH/mach-mvebu/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-mvebu/
|
done
|
||||||
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/plat-omap
|
for i in omap orion samsung versatile; do
|
||||||
cp -a arch/$KARCH/plat-omap/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/plat-omap/
|
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/plat-${i}
|
||||||
|
cp -a arch/$KARCH/plat-${i}/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/plat-${i}/
|
||||||
|
done
|
||||||
|
|
||||||
# copy files necessary for later builds, like nvidia and vmware
|
# copy files necessary for later builds, like nvidia and vmware
|
||||||
cp Module.symvers "${pkgdir}/usr/lib/modules/${_kernver}/build"
|
cp Module.symvers "${pkgdir}/usr/lib/modules/${_kernver}/build"
|
||||||
|
@ -337,6 +336,7 @@ _package-d3plug() {
|
||||||
_package-chromebook() {
|
_package-chromebook() {
|
||||||
pkgdesc="The Linux Kernel - ${_desc} - Chromebooks"
|
pkgdesc="The Linux Kernel - ${_desc} - Chromebooks"
|
||||||
depends=('linux-armv7-rc')
|
depends=('linux-armv7-rc')
|
||||||
|
install=${pkgname}.install
|
||||||
|
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -25,6 +25,16 @@
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
fdt@2 {
|
fdt@2 {
|
||||||
|
description = "exynos5250-snow-rev5.dtb";
|
||||||
|
data = /incbin/("arch/arm/boot/dts/exynos5250-snow-rev5.dtb");
|
||||||
|
type = "flat_dt";
|
||||||
|
arch = "arm";
|
||||||
|
compression = "none";
|
||||||
|
hash@1 {
|
||||||
|
algo = "sha1";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
fdt@3 {
|
||||||
description = "exynos5250-spring.dtb";
|
description = "exynos5250-spring.dtb";
|
||||||
data = /incbin/("arch/arm/boot/dts/exynos5250-spring.dtb");
|
data = /incbin/("arch/arm/boot/dts/exynos5250-spring.dtb");
|
||||||
type = "flat_dt";
|
type = "flat_dt";
|
||||||
|
@ -34,7 +44,7 @@
|
||||||
algo = "sha1";
|
algo = "sha1";
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
fdt@3 {
|
fdt@4 {
|
||||||
description = "exynos5800-peach-pi.dtb";
|
description = "exynos5800-peach-pi.dtb";
|
||||||
data = /incbin/("arch/arm/boot/dts/exynos5800-peach-pi.dtb");
|
data = /incbin/("arch/arm/boot/dts/exynos5800-peach-pi.dtb");
|
||||||
type = "flat_dt";
|
type = "flat_dt";
|
||||||
|
@ -44,7 +54,7 @@
|
||||||
algo = "sha1";
|
algo = "sha1";
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
fdt@4 {
|
fdt@5 {
|
||||||
description = "exynos5420-peach-pit.dtb";
|
description = "exynos5420-peach-pit.dtb";
|
||||||
data = /incbin/("arch/arm/boot/dts/exynos5420-peach-pit.dtb");
|
data = /incbin/("arch/arm/boot/dts/exynos5420-peach-pit.dtb");
|
||||||
type = "flat_dt";
|
type = "flat_dt";
|
||||||
|
@ -54,7 +64,27 @@
|
||||||
algo = "sha1";
|
algo = "sha1";
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
fdt@5 {
|
fdt@6 {
|
||||||
|
description = "rk3288-veyron-brain.dtb";
|
||||||
|
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-brain.dtb");
|
||||||
|
type = "flat_dt";
|
||||||
|
arch = "arm";
|
||||||
|
compression = "none";
|
||||||
|
hash@1 {
|
||||||
|
algo = "sha1";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
fdt@7 {
|
||||||
|
description = "rk3288-veyron-jaq.dtb";
|
||||||
|
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-jaq.dtb");
|
||||||
|
type = "flat_dt";
|
||||||
|
arch = "arm";
|
||||||
|
compression = "none";
|
||||||
|
hash@1 {
|
||||||
|
algo = "sha1";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
fdt@8 {
|
||||||
description = "rk3288-veyron-jerry.dtb";
|
description = "rk3288-veyron-jerry.dtb";
|
||||||
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-jerry.dtb");
|
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-jerry.dtb");
|
||||||
type = "flat_dt";
|
type = "flat_dt";
|
||||||
|
@ -64,7 +94,17 @@
|
||||||
algo = "sha1";
|
algo = "sha1";
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
fdt@6 {
|
fdt@9 {
|
||||||
|
description = "rk3288-veyron-mickey.dtb";
|
||||||
|
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-mickey.dtb");
|
||||||
|
type = "flat_dt";
|
||||||
|
arch = "arm";
|
||||||
|
compression = "none";
|
||||||
|
hash@1 {
|
||||||
|
algo = "sha1";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
fdt@10 {
|
||||||
description = "rk3288-veyron-minnie.dtb";
|
description = "rk3288-veyron-minnie.dtb";
|
||||||
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-minnie.dtb");
|
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-minnie.dtb");
|
||||||
type = "flat_dt";
|
type = "flat_dt";
|
||||||
|
@ -74,7 +114,7 @@
|
||||||
algo = "sha1";
|
algo = "sha1";
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
fdt@7 {
|
fdt@11 {
|
||||||
description = "rk3288-veyron-pinky.dtb";
|
description = "rk3288-veyron-pinky.dtb";
|
||||||
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-pinky.dtb");
|
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-pinky.dtb");
|
||||||
type = "flat_dt";
|
type = "flat_dt";
|
||||||
|
@ -84,7 +124,7 @@
|
||||||
algo = "sha1";
|
algo = "sha1";
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
fdt@8 {
|
fdt@12 {
|
||||||
description = "rk3288-veyron-speedy.dtb";
|
description = "rk3288-veyron-speedy.dtb";
|
||||||
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-speedy.dtb");
|
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-speedy.dtb");
|
||||||
type = "flat_dt";
|
type = "flat_dt";
|
||||||
|
@ -94,6 +134,26 @@
|
||||||
algo = "sha1";
|
algo = "sha1";
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
|
fdt@13 {
|
||||||
|
description = "tegra124-nyan-big.dtb";
|
||||||
|
data = /incbin/("arch/arm/boot/dts/tegra124-nyan-big.dtb");
|
||||||
|
type = "flat_dt";
|
||||||
|
arch = "arm";
|
||||||
|
compression = "none";
|
||||||
|
hash@1 {
|
||||||
|
algo = "sha1";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
fdt@14 {
|
||||||
|
description = "tegra124-nyan-blaze.dtb";
|
||||||
|
data = /incbin/("arch/arm/boot/dts/tegra124-nyan-blaze.dtb");
|
||||||
|
type = "flat_dt";
|
||||||
|
arch = "arm";
|
||||||
|
compression = "none";
|
||||||
|
hash@1 {
|
||||||
|
algo = "sha1";
|
||||||
|
};
|
||||||
|
};
|
||||||
};
|
};
|
||||||
configurations {
|
configurations {
|
||||||
default = "conf@1";
|
default = "conf@1";
|
||||||
|
@ -129,5 +189,29 @@
|
||||||
kernel = "kernel@1";
|
kernel = "kernel@1";
|
||||||
fdt = "fdt@8";
|
fdt = "fdt@8";
|
||||||
};
|
};
|
||||||
|
conf@9 {
|
||||||
|
kernel = "kernel@1";
|
||||||
|
fdt = "fdt@9";
|
||||||
|
};
|
||||||
|
conf@10 {
|
||||||
|
kernel = "kernel@1";
|
||||||
|
fdt = "fdt@10";
|
||||||
|
};
|
||||||
|
conf@11 {
|
||||||
|
kernel = "kernel@1";
|
||||||
|
fdt = "fdt@11";
|
||||||
|
};
|
||||||
|
conf@12 {
|
||||||
|
kernel = "kernel@1";
|
||||||
|
fdt = "fdt@12";
|
||||||
|
};
|
||||||
|
conf@13 {
|
||||||
|
kernel = "kernel@1";
|
||||||
|
fdt = "fdt@13";
|
||||||
|
};
|
||||||
|
conf@14 {
|
||||||
|
kernel = "kernel@1";
|
||||||
|
fdt = "fdt@14";
|
||||||
|
};
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
|
|
25
core/linux-armv7-rc/linux-armv7-rc-chromebook.install
Normal file
25
core/linux-armv7-rc/linux-armv7-rc-chromebook.install
Normal file
|
@ -0,0 +1,25 @@
|
||||||
|
flash_kernel() {
|
||||||
|
major=$(mountpoint -d / | cut -f 1 -d ':')
|
||||||
|
minor=$(mountpoint -d / | cut -f 2 -d ':')
|
||||||
|
device=$(cat /proc/partitions | awk {'if ($1 == "'${major}'" && $2 == "'${minor}'") print $4 '})
|
||||||
|
device="/dev/${device/%2/1}"
|
||||||
|
|
||||||
|
echo "A new kernel version needs to be flashed onto ${device}."
|
||||||
|
echo "Do you want to do this now? [y|N]"
|
||||||
|
read -r shouldwe
|
||||||
|
if [[ $shouldwe =~ ^([yY][eE][sS]|[yY])$ ]]; then
|
||||||
|
dd if=/boot/vmlinux.kpart of=${device}
|
||||||
|
sync
|
||||||
|
else
|
||||||
|
echo "You can do this later by running:"
|
||||||
|
echo "# dd if=/boot/vmlinux.kpart of=${device}"
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
post_install () {
|
||||||
|
flash_kernel
|
||||||
|
}
|
||||||
|
|
||||||
|
post_upgrade() {
|
||||||
|
flash_kernel
|
||||||
|
}
|
Loading…
Reference in a new issue