mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/percona-server to 8.0.13_3-1
This commit is contained in:
parent
ba357876d3
commit
c768e1facb
5 changed files with 82 additions and 43 deletions
|
@ -6,8 +6,8 @@
|
|||
|
||||
pkgbase=percona-server
|
||||
pkgname=('libperconaserverclient' 'percona-server-clients' 'percona-server')
|
||||
pkgver=5.7.24_27
|
||||
_boost_ver=1.59.0
|
||||
pkgver=8.0.13_3
|
||||
_boost_ver=1.67.0
|
||||
_pkgver=${pkgver/_/-}
|
||||
_myver=${pkgver/_rel*}
|
||||
pkgrel=1
|
||||
|
@ -19,23 +19,24 @@ source=("https://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona
|
|||
"http://jenkins.percona.com/downloads/boost/boost_${_boost_ver//./_}.tar.gz"
|
||||
'my.cnf'
|
||||
'mysql-user.conf'
|
||||
'build-hostname.patch'
|
||||
'no-werror.patch'
|
||||
'rocksdb-systemlibs.patch')
|
||||
sha256sums=('999593afa241660bc7860264b46a826faf97d80d411966fade24084f47b249a0'
|
||||
'47f11c8844e579d02691a607fbd32540104a9ac7a2534a8ddaef50daf502baac'
|
||||
'ae451839c368f0db25a63bb0a6a890194897a8e74818bd4245140933c29e5f83'
|
||||
sha256sums=('ab00626775b85ea506c1d992d66acee50f0bfbde54b830731f61652e87ff93da'
|
||||
'8aa4e330c870ef50a896634c931adf468b21f8a69b77007e45c444151229f665'
|
||||
'b467b04d6d06152b2abc33f2a6de63fef0fc922dd5119d2ee1d07d3c1a489731'
|
||||
'e638a2657085f15b6728f43c1fd6aa551b27608fbf6b435e33afd3606a0cfb0e'
|
||||
'fcc3bea0982cda6cc35637d448a46924eccdfeb4c4da0634a26c9d190cf50fe4')
|
||||
'1537fdbb92dd1c135c1eb9f4d10c44fd02e652db66c933d731990a1196f1397c'
|
||||
'fe1cb2b079c56ff0f827c7dfb25d004b2190410406820c490dc6152cfe392b70'
|
||||
'38f1acce8d8eff8167f1defcd4ce7063e67beeb7ab67bbf15ba5630290d00b71')
|
||||
|
||||
prepare() {
|
||||
cd $pkgbase-$_pkgver
|
||||
rm -v sql/sql_yacc.{cc,h}
|
||||
|
||||
sed 's/${fullhostname}/"archbuild"/' -i storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
|
||||
sed 's/-Werror//g' -i \
|
||||
storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake \
|
||||
plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
|
||||
|
||||
patch -p1 -i "$srcdir"/rocksdb-systemlibs.patch
|
||||
patch -p1 -i "$srcdir"/build-hostname.patch
|
||||
patch -p1 -i "$srcdir"/no-werror.patch
|
||||
# patch -p1 -i "$srcdir"/rocksdb-systemlibs.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -47,6 +48,7 @@ build() {
|
|||
|
||||
cmake ../$pkgbase-$_pkgver \
|
||||
-DBUILD_CONFIG=mysql_release \
|
||||
-DREPRODUCIBLE_BUILD=ON \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DSYSCONFDIR=/etc/mysql \
|
||||
-DMYSQL_DATADIR=/var/lib/mysql \
|
||||
|
@ -106,7 +108,7 @@ package_libperconaserverclient() {
|
|||
depends=('zlib' 'openssl')
|
||||
|
||||
cd build
|
||||
for dir in include libmysql libmysqld libservices; do
|
||||
for dir in include libmysql libservices; do
|
||||
make -C $dir DESTDIR="$pkgdir" install
|
||||
done
|
||||
|
||||
|
@ -131,16 +133,16 @@ package_percona-server-clients() {
|
|||
|
||||
# install man pages
|
||||
install -d "$pkgdir"/usr/share/man/man1
|
||||
for man in mysql{,admin,check,dump,import,show,slap,pump,binlog,_plugin,_upgrade}; do
|
||||
for man in mysql{,admin,check,dump,import,show,slap,pump,binlog,_upgrade}; do
|
||||
install -m644 "$srcdir"/$pkgbase-$_pkgver/man/$man.1 "$pkgdir"/usr/share/man/man1/$man.1
|
||||
done
|
||||
|
||||
# provided by percona-server
|
||||
rm "$pkgdir"/usr/bin/mysql{_config_editor,_install_db,_secure_installation,_ssl_rsa_setup}
|
||||
rm "$pkgdir"/usr/bin/mysql{_config_editor,_secure_installation,_ssl_rsa_setup}
|
||||
}
|
||||
|
||||
package_percona-server() {
|
||||
pkgdesc='Drop-in replacement for MySQL that provides improved performance, diagnostics, instrumentation and TokuDB storage engine'
|
||||
pkgdesc='Drop-in replacement for MySQL that provides improved performance, diagnostics, instrumentation and MyRocks storage engine'
|
||||
backup=('etc/mysql/my.cnf')
|
||||
depends=('libaio' 'systemd-tools' 'pam' 'jemalloc' 'lz4' 'zstd' 'openssl' 'libtirpc')
|
||||
optdepends=('perl-dbd-mysql')
|
||||
|
@ -172,12 +174,8 @@ package_percona-server() {
|
|||
rm -r usr/share/aclocal usr/lib/pkgconfig
|
||||
|
||||
# provided by percona-server-clients
|
||||
rm usr/bin/mysql{,admin,check,dump,import,show,slap,pump,binlog,_plugin,test,_upgrade}
|
||||
rm usr/share/man/man1/mysql{,admin,check,dump,import,show,slap,pump,binlog,_plugin,_upgrade}.1
|
||||
|
||||
# deprecated/unused
|
||||
rm usr/bin/replace
|
||||
rm usr/share/man/man1/replace.1
|
||||
rm usr/bin/mysql{,admin,check,dump,import,show,slap,pump,binlog,test,_upgrade}
|
||||
rm usr/share/man/man1/mysql{,admin,check,dump,import,show,slap,pump,binlog,_upgrade}.1
|
||||
|
||||
# not needed
|
||||
rm -r usr/mysql-test
|
||||
|
|
17
community/percona-server/build-hostname.patch
Normal file
17
community/percona-server/build-hostname.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
diff --git a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
|
||||
index 5b6882cc..d165f3e7 100644
|
||||
--- a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
|
||||
+++ b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
|
||||
@@ -56,11 +56,7 @@ endmacro(whoami)
|
||||
|
||||
## gives the current hostname, minus .tokutek.com if it's there
|
||||
macro(hostname out)
|
||||
- execute_process(
|
||||
- COMMAND hostname
|
||||
- OUTPUT_VARIABLE fullhostname
|
||||
- OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
- string(REGEX REPLACE "\\.tokutek\\.com$" "" ${out} "${fullhostname}")
|
||||
+ set(${out} "archbuild")
|
||||
endmacro(hostname)
|
||||
|
||||
## gather machine info
|
|
@ -1,24 +1,19 @@
|
|||
# For advice on how to change settings please see
|
||||
# http://dev.mysql.com/doc/refman/5.6/en/server-configuration-defaults.html
|
||||
# http://dev.mysql.com/doc/refman/8.0/en/server-configuration-defaults.html
|
||||
|
||||
[client]
|
||||
#password = your_password
|
||||
port = 3306
|
||||
socket = /run/mysqld/mysqld.sock
|
||||
|
||||
[mysqld]
|
||||
port = 3306
|
||||
socket = /run/mysqld/mysqld.sock
|
||||
datadir = /var/lib/mysql
|
||||
|
||||
#
|
||||
# Remove leading # and set to the amount of RAM for the most important data
|
||||
# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
|
||||
# innodb_buffer_pool_size = 128M
|
||||
#
|
||||
# Remove leading # to turn on a very important data integrity option: logging
|
||||
# changes to the binary log between backups.
|
||||
# log_bin
|
||||
# Remove the leading "# " to disable binary logging
|
||||
# Binary logging captures changes between backups and is enabled by
|
||||
# default. It's default setting is log_bin=binlog
|
||||
# disable_log_bin
|
||||
#
|
||||
# Remove leading # to set options mainly useful for reporting servers.
|
||||
# The server defaults are faster for transactions and fast SELECTs.
|
||||
|
@ -26,13 +21,14 @@ datadir = /var/lib/mysql
|
|||
# join_buffer_size = 128M
|
||||
# sort_buffer_size = 2M
|
||||
# read_rnd_buffer_size = 2M
|
||||
#
|
||||
# Remove leading # to revert to previous value for default_authentication_plugin,
|
||||
# this will increase compatibility with older clients. For background, see:
|
||||
# https://dev.mysql.com/doc/refman/8.0/en/server-system-variables.html#sysvar_default_authentication_plugin
|
||||
# default-authentication-plugin=mysql_native_password
|
||||
|
||||
# Disabling symbolic-links is recommended to prevent assorted security risks
|
||||
symbolic-links=0
|
||||
datadir = /var/lib/mysql
|
||||
socket = /run/mysqld/mysqld.sock
|
||||
|
||||
# Recommended in standard MySQL setup
|
||||
sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES
|
||||
|
||||
[mysqld_safe]
|
||||
log-error = /var/log/mysqld.log
|
||||
pid-file = /run/mysqld/mysqld.pid
|
||||
|
|
28
community/percona-server/no-werror.patch
Normal file
28
community/percona-server/no-werror.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
diff --git a/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt b/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
|
||||
index b10edec3..fb04ed59 100644
|
||||
--- a/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
|
||||
+++ b/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
|
||||
@@ -13,7 +13,7 @@ set_property(DIRECTORY APPEND PROPERTY COMPILE_DEFINITIONS
|
||||
_FILE_OFFSET_BITS=64
|
||||
_LARGEFILE64_SOURCE)
|
||||
|
||||
-set(CMAKE_CXX_FLAGS "-Werror -W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
|
||||
+set(CMAKE_CXX_FLAGS "-W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
|
||||
|
||||
set(USE_VALGRIND OFF CACHE BOOL "whether to use valgrind headers")
|
||||
if (USE_VALGRIND)
|
||||
diff --git a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake
|
||||
index 502fd192..6d178667 100644
|
||||
--- a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake
|
||||
+++ b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake
|
||||
@@ -206,8 +206,8 @@ if (NOT CMAKE_CXX_COMPILER_ID STREQUAL Clang)
|
||||
endif ()
|
||||
|
||||
## always want these
|
||||
-set(CMAKE_C_FLAGS "-Wall -Werror ${CMAKE_C_FLAGS}")
|
||||
-set(CMAKE_CXX_FLAGS "-Wall -Werror ${CMAKE_CXX_FLAGS}")
|
||||
+set(CMAKE_C_FLAGS "-Wall ${CMAKE_C_FLAGS}")
|
||||
+set(CMAKE_CXX_FLAGS "-Wall ${CMAKE_CXX_FLAGS}")
|
||||
|
||||
# pick language dialect
|
||||
set(CMAKE_C_FLAGS "-std=c99 ${CMAKE_C_FLAGS}")
|
|
@ -1,8 +1,8 @@
|
|||
diff --git a/storage/rocksdb/CMakeLists.txt b/storage/rocksdb/CMakeLists.txt
|
||||
index 2a0a612..8424184 100644
|
||||
index 8e9086d..ccd7416 100644
|
||||
--- a/storage/rocksdb/CMakeLists.txt
|
||||
+++ b/storage/rocksdb/CMakeLists.txt
|
||||
@@ -114,38 +114,11 @@ EXECUTE_PROCESS(
|
||||
@@ -116,38 +116,11 @@ EXECUTE_PROCESS(
|
||||
# split the list into lines
|
||||
STRING(REGEX MATCHALL "[^\n]+" ROCKSDB_LIB_SOURCES ${SCRIPT_OUTPUT})
|
||||
|
||||
|
@ -41,12 +41,12 @@ index 2a0a612..8424184 100644
|
|||
)
|
||||
|
||||
ADD_DEFINITIONS(-DROCKSDB_PLATFORM_POSIX -DROCKSDB_LIB_IO_POSIX -DZLIB -DLZ4
|
||||
@@ -177,7 +150,7 @@ SET(ROCKSDB_SOURCES
|
||||
@@ -184,7 +157,7 @@ SET(ROCKSDB_SOURCES
|
||||
${ROCKSDB_LIB_SOURCES}
|
||||
)
|
||||
|
||||
-SET(rocksdb_static_libs ${rocksdb_static_libs} ${ZLIB_LIBRARY} "-lrt")
|
||||
+SET(rocksdb_static_libs ${rocksdb_static_libs} ${ZLIB_LIBRARY} "-lrt -llz4 -lzstd")
|
||||
-SET(rocksdb_static_libs ${rocksdb_static_libs} ${ZLIB_LIBRARY} regex "-lrt")
|
||||
+SET(rocksdb_static_libs ${rocksdb_static_libs} ${ZLIB_LIBRARY} regex "-lrt -llz4 -lzstd")
|
||||
|
||||
MYSQL_ADD_PLUGIN(rocksdb ${ROCKSDB_SOURCES} STORAGE_ENGINE DEFAULT MODULE_ONLY
|
||||
LINK_LIBRARIES ${rocksdb_static_libs}
|
||||
|
|
Loading…
Reference in a new issue