extra/openal to 1.21.0-1

This commit is contained in:
Kevin Mihelich 2020-11-05 00:49:19 +00:00
parent 612de30a72
commit c771b32354
2 changed files with 12 additions and 94 deletions

View file

@ -1,4 +1,4 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Jason Chu <jchu@xentac.net>
@ -7,23 +7,21 @@
pkgbase=openal
pkgname=(openal openal-examples)
pkgver=1.20.1
pkgrel=2
pkgver=1.21.0
pkgrel=1
pkgdesc="Cross-platform 3D audio library, software implementation"
arch=(x86_64)
url="https://github.com/kcat/openal-soft"
license=(LGPL)
depends=(gcc-libs)
makedepends=(alsa-lib libpulse fluidsynth portaudio jack qt5-base sdl2 sdl_sound
ffmpeg libmysofa git cmake)
makedepends=(alsa-lib libpulse fluidsynth portaudio jack qt5-base sdl2
libsndfile ffmpeg libmysofa git cmake)
optdepends=('qt5-base: alsoft-config GUI Configurator'
'fluidsynth: MIDI rendering'
'libmysofa: makemhr tool')
_commit=f5e0eef34db3a3ab94b61a2f99f84f078ba947e7 # tags/openal-soft-1.20.1
source=("git+https://github.com/kcat/openal-soft#commit=$_commit"
sdl_sound.diff)
sha512sums=('SKIP'
'ebfdb316adbfbdfc6e6236a390dc33579e9eb06918ba110e436ffa91b4535c82ad225b1379587e1ba6b444abcc5f65d53e0360823a054f860bc57bc6f4b51334')
_commit=c0cbe602ce66481a822ba16856052a47154f5cc5 # tags/openal-soft-1.21.0
source=("git+https://github.com/kcat/openal-soft#commit=$_commit")
sha512sums=('SKIP')
pkgver() {
cd openal-soft
@ -32,13 +30,10 @@ pkgver() {
prepare() {
cd openal-soft
# Fix building some things with our old SDL_sound (and SDL1)
git apply -3 ../sdl_sound.diff
}
build() {
cmake -Hopenal-soft -Bbuild \
cmake -S openal-soft -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_LIBDIR=lib \
@ -47,7 +42,7 @@ build() {
}
package_openal() {
DESTDIR="$pkgdir" cmake --build build --target install
DESTDIR="$pkgdir" cmake --install build
install -Dt "$pkgdir/usr/share/doc/openal" -m644 openal-soft/docs/*
### Split openal-examples
@ -62,7 +57,8 @@ package_openal() {
package_openal-examples() {
pkgdesc+=" (example programs)"
depends=("openal=$pkgver-$pkgrel" sdl2 sdl_sound ffmpeg)
depends=("openal=$pkgver-$pkgrel" sdl2 libsndfile ffmpeg)
optdepends=()
mv examples/* "$pkgdir"
}

View file

@ -1,78 +0,0 @@
diff --git i/examples/alhrtf.c w/examples/alhrtf.c
index 2be28a91..dfa01e5c 100644
--- i/examples/alhrtf.c
+++ w/examples/alhrtf.c
@@ -30,8 +30,6 @@
#include <string.h>
#include "SDL_sound.h"
-#include "SDL_audio.h"
-#include "SDL_stdinc.h"
#include "AL/al.h"
#include "AL/alc.h"
diff --git i/examples/allatency.c w/examples/allatency.c
index a61fb820..5705506a 100644
--- i/examples/allatency.c
+++ w/examples/allatency.c
@@ -28,8 +28,6 @@
#include <assert.h>
#include "SDL_sound.h"
-#include "SDL_audio.h"
-#include "SDL_stdinc.h"
#include "AL/al.h"
#include "AL/alext.h"
diff --git i/examples/almultireverb.c w/examples/almultireverb.c
index a90b3368..65e444f5 100644
--- i/examples/almultireverb.c
+++ w/examples/almultireverb.c
@@ -35,8 +35,6 @@
#include <string.h>
#include "SDL_sound.h"
-#include "SDL_audio.h"
-#include "SDL_stdinc.h"
#include "AL/al.h"
#include "AL/alc.h"
diff --git i/examples/alplay.c w/examples/alplay.c
index 09ad96b4..01cf769d 100644
--- i/examples/alplay.c
+++ w/examples/alplay.c
@@ -28,8 +28,6 @@
#include <assert.h>
#include "SDL_sound.h"
-#include "SDL_audio.h"
-#include "SDL_stdinc.h"
#include "AL/al.h"
diff --git i/examples/alreverb.c w/examples/alreverb.c
index d789dffe..a6dd141d 100644
--- i/examples/alreverb.c
+++ w/examples/alreverb.c
@@ -28,8 +28,6 @@
#include <assert.h>
#include "SDL_sound.h"
-#include "SDL_audio.h"
-#include "SDL_stdinc.h"
#include "AL/al.h"
#include "AL/alc.h"
diff --git i/examples/alstream.c w/examples/alstream.c
index 56505ddb..103492c7 100644
--- i/examples/alstream.c
+++ w/examples/alstream.c
@@ -30,8 +30,6 @@
#include <assert.h>
#include "SDL_sound.h"
-#include "SDL_audio.h"
-#include "SDL_stdinc.h"
#include "AL/al.h"