community/blender to 2.93.0-1

This commit is contained in:
Kevin Mihelich 2021-06-02 18:09:23 +00:00
parent ade5b992ef
commit c785341dcf
2 changed files with 2 additions and 15 deletions

View file

@ -14,8 +14,8 @@ buildarch=8
# fine with them.
pkgname=blender
pkgver=2.92.0
pkgrel=7
pkgver=2.93.0
pkgrel=1
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -34,7 +34,6 @@ source=("git+https://git.blender.org/blender.git#tag=v$pkgver"
"git+https://git.blender.org/blender-translations.git"
"git+https://git.blender.org/blender-dev-tools.git"
https://developer.download.nvidia.com/redist/optix/v7.0/OptiX-7.0.0-include.zip
blender-ffmpeg4_4.patch
blender-openexr3.patch)
sha512sums=('SKIP'
'SKIP'
@ -42,7 +41,6 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'b2cff73def3757d4259f4b4d318a8ccfe166bf7c215cbb2124f1c81bd6e742f96207285b24eb4d99b527b7b97dc6d5e8fdf2f16d78d5d1e2684c26d681328491'
'be26d2edf9c9aaf4c99f4f0a3f3c4a05296170b86b5abd7b7c3c2d900f868ebe113d5b49fbf413fb717b9ec5f36becf880c8479388616d1b34f296da24faea63'
'e2dd7210d26b70445e9ae8e33dea35111ad0b0aca9d3b4ded3df560d0fcc8dc044868f729e0f090a04b6f316f083b5505a7056ce088e8702065add87b9b457e5')
prepare() {
@ -56,7 +54,6 @@ prepare() {
git submodule update
git submodule foreach git checkout v${pkgver}
patch -p1 < "$srcdir"/blender-ffmpeg4_4.patch # Fix compatibility with with ffmpeg 4.4
patch -p1 < "$srcdir"/blender-openexr3.patch # Fix build with OpenEXR 3
}

View file

@ -1,10 +0,0 @@
--- a/source/blender/blenkernel/intern/writeffmpeg.org.c 2021-05-05 15:45:54.647257119 -0700
+++ a/source/blender/blenkernel/intern/writeffmpeg.c 2021-05-05 15:47:57.737338545 -0700
@@ -163,6 +163,7 @@
frame->pts = context->audio_time / av_q2d(c->time_base);
frame->nb_samples = context->audio_input_samples;
frame->format = c->sample_fmt;
+ frame->channels = c->channels;
# ifdef FFMPEG_HAVE_FRAME_CHANNEL_LAYOUT
frame->channel_layout = c->channel_layout;
# endif