mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/vtk to 9.4.1-3
This commit is contained in:
parent
638c475053
commit
c7acc7df7c
3 changed files with 33 additions and 4 deletions
extra/vtk
|
@ -1,7 +1,7 @@
|
|||
pkgbase = vtk
|
||||
pkgdesc = Software system for 3D computer graphics, image processing, and visualization
|
||||
pkgver = 9.4.1
|
||||
pkgrel = 2
|
||||
pkgrel = 3
|
||||
url = https://www.vtk.org
|
||||
arch = x86_64
|
||||
license = BSD-3-Clause
|
||||
|
@ -114,8 +114,10 @@ pkgbase = vtk
|
|||
source = https://www.vtk.org/files/release/9.4/VTK-9.4.1.tar.gz
|
||||
source = vtk-occt.patch
|
||||
source = fmt-11.patch
|
||||
source = netcdf-4.9.3.patch
|
||||
sha256sums = c253b0c8d002aaf98871c6d0cb76afc4936c301b72358a08d5f3f72ef8bc4529
|
||||
sha256sums = df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011
|
||||
sha256sums = c6345d09c219b5ca2efa6e7419f404a22715adb4d2ca1fd6ba34affd77cea23e
|
||||
sha256sums = 87535578bbb0023ede506fd64afae95cdf4fb698c543f9735e6267730634afbc
|
||||
|
||||
pkgname = vtk
|
||||
|
|
|
@ -18,7 +18,7 @@
|
|||
pkgname=vtk
|
||||
# May need bootstrapping on upgrades due to circular vtk <-> opencascade dependency
|
||||
pkgver=9.4.1
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="Software system for 3D computer graphics, image processing, and visualization"
|
||||
arch=(x86_64)
|
||||
url="https://www.vtk.org"
|
||||
|
@ -147,10 +147,12 @@ optdepends=(
|
|||
options=(staticlibs)
|
||||
source=(${url}/files/release/${pkgver%.*}/VTK-${pkgver}.tar.gz
|
||||
vtk-occt.patch
|
||||
fmt-11.patch)
|
||||
fmt-11.patch
|
||||
netcdf-4.9.3.patch)
|
||||
sha256sums=('c253b0c8d002aaf98871c6d0cb76afc4936c301b72358a08d5f3f72ef8bc4529'
|
||||
'df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011'
|
||||
'c6345d09c219b5ca2efa6e7419f404a22715adb4d2ca1fd6ba34affd77cea23e')
|
||||
'c6345d09c219b5ca2efa6e7419f404a22715adb4d2ca1fd6ba34affd77cea23e'
|
||||
'87535578bbb0023ede506fd64afae95cdf4fb698c543f9735e6267730634afbc')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname^^}-${pkgver}
|
||||
|
@ -159,6 +161,7 @@ prepare() {
|
|||
|
||||
patch -Np1 -i "$srcdir"/vtk-occt.patch
|
||||
patch -Np1 -i "$srcdir"/fmt-11.patch
|
||||
patch -Np1 -i "$srcdir"/netcdf-4.9.3.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
24
extra/vtk/netcdf-4.9.3.patch
Normal file
24
extra/vtk/netcdf-4.9.3.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
diff -ru VTK-9.4.1.orig/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop.c VTK-9.4.1/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop.c
|
||||
--- VTK-9.4.1.orig/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop.c 2025-02-10 13:35:17.671934279 +0100
|
||||
+++ VTK-9.4.1/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop.c 2025-02-10 13:36:10.298911583 +0100
|
||||
@@ -243,7 +243,7 @@
|
||||
vals[0] = 0; /* fill value */
|
||||
/* create attribute to cause variable to fill with zeros per routine spec
|
||||
*/
|
||||
- if ((status = nc_put_att_longlong(exoid, propid, _FillValue, int_type, 1, vals)) != NC_NOERR) {
|
||||
+ if ((status = nc_put_att_longlong(exoid, propid, NC_FillValue, int_type, 1, vals)) != NC_NOERR) {
|
||||
snprintf(errmsg, MAX_ERR_LENGTH,
|
||||
"ERROR: failed to create property name fill attribute in file id %d", exoid);
|
||||
ex_err_fn(exoid, __func__, errmsg, status);
|
||||
diff -ru VTK-9.4.1.orig/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop_names.c VTK-9.4.1/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop_names.c
|
||||
--- VTK-9.4.1.orig/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop_names.c 2025-02-10 13:35:17.671934279 +0100
|
||||
+++ VTK-9.4.1/ThirdParty/exodusII/vtkexodusII/src/ex_put_prop_names.c 2025-02-10 13:36:10.298911583 +0100
|
||||
@@ -172,7 +172,7 @@
|
||||
|
||||
/* create attribute to cause variable to fill with zeros per routine spec
|
||||
*/
|
||||
- if ((status = nc_put_att_longlong(exoid, propid, _FillValue, int_type, 1, vals)) != NC_NOERR) {
|
||||
+ if ((status = nc_put_att_longlong(exoid, propid, NC_FillValue, int_type, 1, vals)) != NC_NOERR) {
|
||||
snprintf(errmsg, MAX_ERR_LENGTH,
|
||||
"ERROR: failed to create property name fill attribute in file id %d", exoid);
|
||||
ex_err_fn(exoid, __func__, errmsg, status);
|
Loading…
Reference in a new issue