mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/libvpx to 1.7.0-1
This commit is contained in:
parent
8bd30c68dd
commit
c7e4065f5d
2 changed files with 12 additions and 12 deletions
|
@ -1,4 +1,4 @@
|
|||
From ac94b8f1653ee9a459aa26a65243d11b8c308064 Mon Sep 17 00:00:00 2001
|
||||
From 7d11fe597a30e4b65b6915b9a275f0da5b655537 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 15 Jan 2017 12:11:57 -0700
|
||||
Subject: [PATCH] ARM fixes
|
||||
|
@ -9,10 +9,10 @@ Subject: [PATCH] ARM fixes
|
|||
2 files changed, 13 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
||||
index 007e02000..c7e9076b3 100644
|
||||
index 683b43037..ee160d17a 100644
|
||||
--- a/build/make/configure.sh
|
||||
+++ b/build/make/configure.sh
|
||||
@@ -680,6 +680,14 @@ process_common_toolchain() {
|
||||
@@ -696,6 +696,14 @@ process_common_toolchain() {
|
||||
aarch64*)
|
||||
tgt_isa=arm64
|
||||
;;
|
||||
|
@ -27,7 +27,7 @@ index 007e02000..c7e9076b3 100644
|
|||
armv7*-hardfloat* | armv7*-gnueabihf | arm-*-gnueabihf)
|
||||
tgt_isa=armv7
|
||||
float_abi=hard
|
||||
@@ -873,7 +881,7 @@ process_common_toolchain() {
|
||||
@@ -915,7 +923,7 @@ process_common_toolchain() {
|
||||
soft_enable neon
|
||||
;;
|
||||
armv7|armv7s)
|
||||
|
@ -36,7 +36,7 @@ index 007e02000..c7e9076b3 100644
|
|||
# Only enable neon_asm when neon is also enabled.
|
||||
enabled neon && soft_enable neon_asm
|
||||
# If someone tries to force it through, die.
|
||||
@@ -894,13 +902,6 @@ process_common_toolchain() {
|
||||
@@ -936,13 +944,6 @@ process_common_toolchain() {
|
||||
check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
||||
|
@ -50,7 +50,7 @@ index 007e02000..c7e9076b3 100644
|
|||
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
|
||||
@@ -912,8 +913,8 @@ EOF
|
||||
@@ -954,8 +955,8 @@ EOF
|
||||
check_add_cflags -march=armv8-a
|
||||
check_add_asflags -march=armv8-a
|
||||
else
|
||||
|
@ -62,7 +62,7 @@ index 007e02000..c7e9076b3 100644
|
|||
|
||||
enabled debug && add_asflags -g
|
||||
diff --git a/configure b/configure
|
||||
index fb732acf3..43a730fdb 100755
|
||||
index e5a74c6f2..07a7e155e 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -101,6 +101,8 @@ EOF
|
||||
|
@ -75,5 +75,5 @@ index fb732acf3..43a730fdb 100755
|
|||
all_platforms="${all_platforms} armv7-darwin-gcc" #neon Cortex-A8
|
||||
all_platforms="${all_platforms} armv7-linux-rvct" #neon Cortex-A8
|
||||
--
|
||||
2.11.0
|
||||
2.14.1
|
||||
|
||||
|
|
|
@ -8,10 +8,10 @@
|
|||
# - disable neon and neon-asm
|
||||
|
||||
pkgname=libvpx
|
||||
pkgver=1.6.1
|
||||
pkgver=1.7.0
|
||||
pkgrel=1
|
||||
pkgdesc='VP8 and VP9 codec'
|
||||
arch=('i686' 'x86_64')
|
||||
arch=('x86_64')
|
||||
url='http://www.webmproject.org/'
|
||||
license=('BSD')
|
||||
depends=('glibc' 'gcc-libs')
|
||||
|
@ -19,8 +19,8 @@ makedepends=('yasm' 'git')
|
|||
provides=('libvpx.so')
|
||||
source=("libvpx-${pkgver}.tar.gz::https://github.com/webmproject/libvpx/archive/v${pkgver}.tar.gz"
|
||||
0001-ARM-fixes.patch)
|
||||
sha256sums=('cda8bb6f0e4848c018177d3a576fa83ed96d762554d7010fe4cfb9d70c22e588'
|
||||
'c2c0f2e81a97edf8795e94a58c00ca6c43f44e1e82e5b122c209e7f6ee91e6e3')
|
||||
sha256sums=('1fec931eb5c94279ad219a5b6e0202358e94a93a90cfb1603578c326abfc1238'
|
||||
'5e1be5248079a37d1ddf3e20954fde6e8b0182030bbcec87f9064aba6f1d3875')
|
||||
|
||||
prepare() {
|
||||
cd libvpx-${pkgver}
|
||||
|
|
Loading…
Reference in a new issue