mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed community/gnome-commander
This commit is contained in:
parent
bb95dd0f90
commit
c83ecf4a5d
4 changed files with 0 additions and 108 deletions
|
@ -1,57 +0,0 @@
|
||||||
# $Id$
|
|
||||||
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
|
|
||||||
# Contributor: Alexander Rødseth <rodseth@gmail.com>
|
|
||||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
|
||||||
# Contributor: Roman Kyrylych <roman@archlinux.org>
|
|
||||||
# Contributor: Johannes Sjolund <j.sjolund@gmail.com>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - patch to fix FTBFS on ARM: https://git.gnome.org/browse/gnome-commander/commit/?id=4a903688d99ea96cc026b3c0939399849ae9e2b4
|
|
||||||
# - can likely be removed on version bump
|
|
||||||
|
|
||||||
pkgname=gnome-commander
|
|
||||||
pkgver=1.4.0
|
|
||||||
pkgrel=1
|
|
||||||
pkgdesc='Graphical two-pane filemanager for Gnome'
|
|
||||||
arch=('i686' 'x86_64')
|
|
||||||
url='http://gcmd.github.io/'
|
|
||||||
license=('GPL')
|
|
||||||
depends=('libgnomeui' 'gnome-vfs' 'gconf' 'python2' 'libsm' 'libunique')
|
|
||||||
makedepends=('perl-xml-parser' 'gnome-doc-utils' 'intltool')
|
|
||||||
install=$pkgname.install
|
|
||||||
changelog=$pkgname.changelog
|
|
||||||
source=(ftp://ftp.gnome.org/pub/GNOME/sources/gnome-commander/1.4/$pkgname-$pkgver.tar.xz
|
|
||||||
vtable.patch)
|
|
||||||
sha256sums=('ffd1062dd61ca993271e6d013dccf179fd8291f3507907c873facdf893ef6fc1'
|
|
||||||
'43c19f8b0e70bf77fc8558d0f48caa4fe981f14d2d9ca440f0222e3c5a69cbd4')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "$pkgname-$pkgver"
|
|
||||||
|
|
||||||
patch -p1 -i ../vtable.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "$pkgname-$pkgver"
|
|
||||||
|
|
||||||
# Python 2 fix
|
|
||||||
for f in doc/*/gnome-commander.xml; do
|
|
||||||
sed -i 's:env python:env python2:' "$f"
|
|
||||||
done
|
|
||||||
|
|
||||||
./configure --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc \
|
|
||||||
--localstatedir=/var --disable-scrollkeeper --enable-python
|
|
||||||
make
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd "$pkgname-$pkgver"
|
|
||||||
|
|
||||||
make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="$pkgdir" install
|
|
||||||
install -d "$pkgdir/usr/share/gconf/schemas"
|
|
||||||
gconf-merge-schema "$pkgdir/usr/share/gconf/schemas/$pkgname.schemas" \
|
|
||||||
--domain "$pkgname" "$pkgdir/etc/gconf/schemas/"*.schemas
|
|
||||||
rm -rf "$pkgdir/etc/gconf/schemas/"
|
|
||||||
}
|
|
||||||
|
|
||||||
# vim:set ts=2 sw=2 et:
|
|
|
@ -1,5 +0,0 @@
|
||||||
2014-03-19 Jaroslav Lichtblau (Dragonlord) <dragonlord@aur.archlinux.org>
|
|
||||||
* gnome-commander 1.4.0-1
|
|
||||||
|
|
||||||
2014-01-14 Jaroslav Lichtblau (Dragonlord) <dragonlord@aur.archlinux.org>
|
|
||||||
* gnome-commander 1.2.8.17-1
|
|
|
@ -1,24 +0,0 @@
|
||||||
pkgname=gnome-commander
|
|
||||||
|
|
||||||
post_install() {
|
|
||||||
gconfpkg --install "$pkgname"
|
|
||||||
update-desktop-database -q
|
|
||||||
}
|
|
||||||
|
|
||||||
pre_upgrade() {
|
|
||||||
pre_remove $1
|
|
||||||
}
|
|
||||||
|
|
||||||
post_upgrade() {
|
|
||||||
post_install $1
|
|
||||||
}
|
|
||||||
|
|
||||||
pre_remove() {
|
|
||||||
gconfpkg --uninstall "$pkgname"
|
|
||||||
}
|
|
||||||
|
|
||||||
post_remove() {
|
|
||||||
update-desktop-database -q
|
|
||||||
}
|
|
||||||
|
|
||||||
# vim:set ts=2 sw=2 et:
|
|
|
@ -1,22 +0,0 @@
|
||||||
diff --git a/src/gnome-cmd-plain-path.cc b/src/gnome-cmd-plain-path.cc
|
|
||||||
index 9fb1619..1a3ceb5 100644
|
|
||||||
--- a/src/gnome-cmd-plain-path.cc
|
|
||||||
+++ b/src/gnome-cmd-plain-path.cc
|
|
||||||
@@ -27,7 +27,7 @@
|
|
||||||
using namespace std;
|
|
||||||
|
|
||||||
|
|
||||||
-inline GnomeCmdPath *GnomeCmdPlainPath::get_parent()
|
|
||||||
+GnomeCmdPath *GnomeCmdPlainPath::get_parent()
|
|
||||||
{
|
|
||||||
GnomeVFSURI *t = gnome_vfs_uri_new (G_DIR_SEPARATOR_S);
|
|
||||||
GnomeVFSURI *u1 = gnome_vfs_uri_append_path (t, path);
|
|
||||||
@@ -48,7 +48,7 @@ inline GnomeCmdPath *GnomeCmdPlainPath::get_parent()
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
-inline GnomeCmdPath *GnomeCmdPlainPath::get_child(const gchar *child)
|
|
||||||
+GnomeCmdPath *GnomeCmdPlainPath::get_child(const gchar *child)
|
|
||||||
{
|
|
||||||
GnomeVFSURI *t = gnome_vfs_uri_new (G_DIR_SEPARATOR_S);
|
|
||||||
GnomeVFSURI *u1 = gnome_vfs_uri_append_path (t, path);
|
|
Loading…
Reference in a new issue