Merge remote-tracking branch 'upstream/master'

This commit is contained in:
Willam Christensen 2014-07-26 13:19:37 -06:00
commit c8cefb5022
2 changed files with 42 additions and 1 deletions

View file

@ -0,0 +1,41 @@
From 7ca66c10c05168c7d342df7c7a70d4a1ae0629f7 Mon Sep 17 00:00:00 2001
From: Eric Nelson <eric.nelson@boundarydevices.com>
Date: Sat, 28 Jun 2014 09:45:09 -0700
Subject: [PATCH] vpu_wrapper: fix tests of return value from IOGetVirtMem
IOGetVirtMem() returns a pointer or specifically -1 (MAP_FAILED)
in the case of failure.
Upstream-Status: Pending
Signed-off-by: Laci Tele <laci@boundarydevices.com>
Signed-off-by: Eric Nelson <eric.nelson@boundarydevices.com>
---
vpu_wrapper.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/vpu_wrapper.c b/vpu_wrapper.c
index 9249174..148c5df 100755
--- a/vpu_wrapper.c
+++ b/vpu_wrapper.c
@@ -6653,7 +6653,7 @@ VpuDecRetCode VPU_DecGetMem(VpuMemDesc* pInOutMem)
return VPU_DEC_RET_FAILURE;
}
ret=IOGetVirtMem(&buff);
- if(ret==0) //if(ret!=RETCODE_SUCCESS)
+ if(ret == -1) //if(ret==MAP_FAILED)
{
VPU_ERROR("%s: get virtual memory failure: size=%d, ret=%d \r\n",__FUNCTION__,buff.size,ret);
return VPU_DEC_RET_FAILURE;
@@ -8277,7 +8277,7 @@ VpuEncRetCode VPU_EncGetMem(VpuMemDesc* pInOutMem)
return VPU_ENC_RET_FAILURE;
}
ret=IOGetVirtMem(&buff);
- if(ret==0) //if(ret!=RETCODE_SUCCESS)
+ if(ret == -1) //if(ret==MAP_FAILED)
{
VPU_ENC_ERROR("%s: get virtual memory failure: size=%d, ret=%d \r\n",__FUNCTION__,buff.size,(UINT32)ret);
return VPU_ENC_RET_FAILURE;
--
1.9.1

View file

@ -35,7 +35,7 @@ install='mythtv.install'
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
'mythbackend.service'
'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.2.patch'
'https://github.com/FFmpeg/FFmpeg/commit/8067f55edf3719182aed6e5b57b7863889f80218.patch'
'https://github.com/FFmpeg/FFmpeg/commit/8067f55edf3719182aed6e5b57b7863889f80218.patch')
sha256sums=('8eaaf8c6e42ca6eb81f180467de90d597dbeabb1bb14b7085da353d2980db8f4'
'ecfde779ded8332cc62c86fac6b432b09cbf5d254135798287ada688af9a1302'
'8270407c2074b305e0c32151f89c84f6bf980a32665a2da8e4727405fa3911f3'