mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/bogofilter to 1.2.5-1
This commit is contained in:
parent
4f829f919f
commit
c8ed52a550
2 changed files with 11 additions and 29 deletions
|
@ -6,19 +6,19 @@
|
|||
# - drop valgrind makedepend
|
||||
|
||||
pkgname=bogofilter
|
||||
pkgver=1.2.4
|
||||
pkgrel=5
|
||||
pkgver=1.2.5
|
||||
pkgrel=1
|
||||
pkgdesc="A fast Bayesian spam filtering tool"
|
||||
arch=('x86_64')
|
||||
license=('GPL3')
|
||||
url="http://bogofilter.sourceforge.net"
|
||||
url="https://bogofilter.sourceforge.io/"
|
||||
depends=('db' 'perl' 'gsl') # 'sqlite'
|
||||
makedepends=('xmlto')
|
||||
backup=('etc/bogofilter/bogofilter.cf')
|
||||
source=(https://sourceforge.net/projects/${pkgname}/files/${pkgname}-current/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2
|
||||
bogofilter-1.2.4-test-env.patch)
|
||||
md5sums=('d0a5eebb3274b23ceabe766a6443a1c5'
|
||||
'd01f23755ee9b4f5807b9feefea0b42d')
|
||||
source=(https://downloads.sourceforge.net/project/${pkgname}/${pkgname}-stable/${pkgname}-${pkgver}.tar.xz{,.asc}) # asc file doesn't work with pacman
|
||||
sha1sums=('c779c3afb3e57ae0208ee503a854aff716b0cafd'
|
||||
'SKIP')
|
||||
validpgpkeys=('DC4A655BD993CD4871FA8210E412B156EFF3855A') # "Matthias Andree <mandree@FreeBSD.org>"
|
||||
|
||||
# keep Berkeley DB as backend for now
|
||||
# sqlite3 based backend doesn't allow
|
||||
|
@ -26,17 +26,10 @@ md5sums=('d0a5eebb3274b23ceabe766a6443a1c5'
|
|||
# used to bf_compact the wordlist.db
|
||||
# other backend aren't available
|
||||
# currently in Arch repos
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
# taken from Gentoo
|
||||
patch -Np1 -i $srcdir/bogofilter-1.2.4-test-env.patch
|
||||
chmod +x src/tests/t.{ctype,leakfind,lexer.qpcr,lexer.eoh,message_id,queue_id}
|
||||
autoreconf -vfi
|
||||
}
|
||||
# as of 1.2.5 new backend can be KyotoCabinet and lmdb
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
cd "${pkgname}"-${pkgver}
|
||||
./configure --prefix=/usr \
|
||||
--sysconfdir=/etc/bogofilter \
|
||||
--localstatedir=/var \
|
||||
|
@ -46,12 +39,12 @@ build() {
|
|||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
cd "$pkgname"-$pkgver
|
||||
BF_RUN_VALGRIND=1 make -k -C src check || /bin/true
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
cd "${pkgname}"-${pkgver}
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
mv "${pkgdir}/etc/bogofilter/bogofilter.cf.example" "${pkgdir}/etc/bogofilter/bogofilter.cf"
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/tests/Makefile.am
|
||||
+++ b/src/tests/Makefile.am
|
||||
@@ -67,7 +67,7 @@
|
||||
|
||||
TESTS=$(BUILT_TESTS) $(TESTSCRIPTS)
|
||||
|
||||
-TESTS_ENVIRONMENT=RUN_FROM_MAKE=1 AWK=$(AWK) srcdir=$(srcdir) SHELL="$(SHELL)" $(SHELL) $(VERBOSE)
|
||||
+TESTS_ENVIRONMENT=RUN_FROM_MAKE=1 AWK=$(AWK) srcdir=$(srcdir) SHELL="$(SHELL)" $(VERBOSE)
|
||||
|
||||
EXTRA_DIST=$(TESTSCRIPTS) t.frame t.save t.skel \
|
||||
printcore t._abort unsort.pl \
|
Loading…
Reference in a new issue