linux-utilite-dt: kernel-CVE-2016-0728.patch

This commit is contained in:
Jason Plum 2016-01-20 15:31:45 -05:00
parent 91169fdb7f
commit c8f8ef556a
2 changed files with 87 additions and 1 deletions

View file

@ -15,7 +15,7 @@ _srcname=linux-kernel-${_commit}
_kernelname=${pkgname#linux} _kernelname=${pkgname#linux}
_basekernel=3.10 _basekernel=3.10
pkgver=${_basekernel}.70 pkgver=${_basekernel}.70
pkgrel=1 pkgrel=2
arch=('armv7h') arch=('armv7h')
url="http://www.kernel.org/" url="http://www.kernel.org/"
license=('GPL2') license=('GPL2')
@ -24,16 +24,21 @@ options=('!strip')
source=("https://github.com/pepedog/linux-kernel/archive/${_commit}.tar.gz" source=("https://github.com/pepedog/linux-kernel/archive/${_commit}.tar.gz"
'0001-Bluetooth-allocate-static-minor-for-vhci.patch' '0001-Bluetooth-allocate-static-minor-for-vhci.patch'
'update-igb-eth.patch' 'update-igb-eth.patch'
'kernel-CVE-2016-0728.patch'
"config") "config")
md5sums=('ed652cdd468428a122d73c6388714e44' md5sums=('ed652cdd468428a122d73c6388714e44'
'1b276abe16d14e133f3f28d9c9e6bd68' '1b276abe16d14e133f3f28d9c9e6bd68'
'2bbb1ada1dfd161ac4a7d43107e0732d' '2bbb1ada1dfd161ac4a7d43107e0732d'
'6470e9783bd1c7a8feddc2d67f07afd5'
'6cd72dbf43d2431a77177da04287b94f') '6cd72dbf43d2431a77177da04287b94f')
prepare() { prepare() {
cd "${srcdir}/${_srcname}" cd "${srcdir}/${_srcname}"
msg2 "ALARM patches"
patch -Np1 -i ${srcdir}/kernel-CVE-2016-0728.patch
msg2 "Fix hci_vhci no minor warning" msg2 "Fix hci_vhci no minor warning"
patch -Np1 -i ${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch patch -Np1 -i ${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch

View file

@ -0,0 +1,81 @@
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
From: Yevgeny Pats <yevgeny@perception-point.io>
Date: Tue, 19 Jan 2016 22:09:04 +0000
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
This fixes CVE-2016-0728.
If a thread is asked to join as a session keyring the keyring that's already
set as its session, we leak a keyring reference.
This can be tested with the following program:
#include <stddef.h>
#include <stdio.h>
#include <sys/types.h>
#include <keyutils.h>
int main(int argc, const char *argv[])
{
int i = 0;
key_serial_t serial;
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
if (keyctl(KEYCTL_SETPERM, serial,
KEY_POS_ALL | KEY_USR_ALL) < 0) {
perror("keyctl");
return -1;
}
for (i = 0; i < 100; i++) {
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
}
return 0;
}
If, after the program has run, there something like the following line in
/proc/keys:
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
with a usage count of 100 * the number of times the program has been run,
then the kernel is malfunctioning. If leaked-keyring has zero usages or
has been garbage collected, then the problem is fixed.
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
Signed-off-by: David Howells <dhowells@redhat.com>
Acked-by: Don Zickus <dzickus@redhat.com>
Acked-by: Prarit Bhargava <prarit@redhat.com>
Acked-by: Jarod Wilson <jarod@redhat.com>
Signed-off-by: James Morris <james.l.morris@oracle.com>
---
security/keys/process_keys.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
index a3f85d2..e6d50172 100644
--- a/security/keys/process_keys.c
+++ b/security/keys/process_keys.c
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
ret = PTR_ERR(keyring);
goto error2;
} else if (keyring == new->session_keyring) {
+ key_put(keyring);
ret = 0;
goto error2;
}
--
cgit v0.12