mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-pandaboard to 2016.01-1
This commit is contained in:
parent
7532085282
commit
c9520165e0
3 changed files with 11 additions and 52 deletions
|
@ -1,7 +1,7 @@
|
|||
From 8f7496dd6948adf16cf25e24c852ff9a73a450f1 Mon Sep 17 00:00:00 2001
|
||||
From 5d9ed9693c3696dcd528fafa115d720bcb83b7dd Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 22 Nov 2014 22:55:40 -0700
|
||||
Subject: [PATCH 1/2] arch linux arm modifications
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 49 insertions(+), 38 deletions(-)
|
||||
|
||||
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
|
||||
index 1cd7dae..12c5f69 100644
|
||||
index 08130eb..103cf82 100644
|
||||
--- a/include/configs/ti_omap4_common.h
|
||||
+++ b/include/configs/ti_omap4_common.h
|
||||
@@ -46,7 +46,6 @@
|
||||
|
@ -20,7 +20,7 @@ index 1cd7dae..12c5f69 100644
|
|||
#ifndef CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
||||
#define CONFIG_SYS_AUTOMATIC_SDRAM_DETECTION
|
||||
#define CONFIG_SYS_DEFAULT_LPDDR2_TIMINGS
|
||||
@@ -78,6 +77,9 @@
|
||||
@@ -79,6 +78,9 @@
|
||||
#define CONFIG_USB_TTY 1
|
||||
#define CONFIG_SYS_CONSOLE_IS_IN_ENV 1
|
||||
|
||||
|
@ -30,7 +30,7 @@ index 1cd7dae..12c5f69 100644
|
|||
/*
|
||||
* Environment setup
|
||||
*/
|
||||
@@ -88,23 +90,53 @@
|
||||
@@ -89,23 +91,53 @@
|
||||
"fdtfile=undefined\0" \
|
||||
"bootpart=0:2\0" \
|
||||
"bootdir=/boot\0" \
|
||||
|
@ -98,7 +98,7 @@ index 1cd7dae..12c5f69 100644
|
|||
"findfdt="\
|
||||
"if test $board_name = sdp4430; then " \
|
||||
"setenv fdtfile omap4-sdp.dtb; fi; " \
|
||||
@@ -117,32 +149,11 @@
|
||||
@@ -118,32 +150,11 @@
|
||||
"if test $board_name = duovero; then " \
|
||||
"setenv fdtfile omap4-duovero-parlor.dtb; fi;" \
|
||||
"if test $fdtfile = undefined; then " \
|
||||
|
@ -134,5 +134,5 @@ index 1cd7dae..12c5f69 100644
|
|||
/*
|
||||
* Defines for SPL
|
||||
--
|
||||
2.6.2
|
||||
2.6.4
|
||||
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
From d0c347811ffa1c865d16450e38e78f5182cf2e90 Mon Sep 17 00:00:00 2001
|
||||
From: "dbatzle@dcbcyber.com" <dbatzle@dcbcyber.com>
|
||||
Date: Tue, 25 Aug 2015 20:55:30 -0400
|
||||
Subject: [PATCH 2/2] ARM Fix pandaboard es and a4 revision ID
|
||||
|
||||
board_name environment variable was not getting set correctly for Pandaboard A4 and ES
|
||||
|
||||
Signed-off-by: David Batzle <dbatzle@dcbcyber.com>
|
||||
CC: Albert Aribaud <albert.u.boot@aribaud.net>; Tom Rini <trini@ti.com>; Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
board/ti/panda/panda.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/board/ti/panda/panda.c b/board/ti/panda/panda.c
|
||||
index 783ba35..92e1b63 100644
|
||||
--- a/board/ti/panda/panda.c
|
||||
+++ b/board/ti/panda/panda.c
|
||||
@@ -101,7 +101,7 @@ int get_board_revision(void)
|
||||
board_id4 = gpio_get_value(PANDA_ES_BOARD_ID_4_GPIO);
|
||||
|
||||
#ifdef CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
|
||||
- setenv("board_name", strcat(CONFIG_SYS_BOARD, "-es"));
|
||||
+ setenv("board_name", "panda-es");
|
||||
#endif
|
||||
board_id = ((board_id4 << 4) | (board_id3 << 3) |
|
||||
(board_id2 << 2) | (board_id1 << 1) | (board_id0));
|
||||
@@ -115,7 +115,7 @@ int get_board_revision(void)
|
||||
|
||||
#ifdef CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
|
||||
if ((board_id >= 0x3) && (processor_rev == OMAP4430_ES2_3))
|
||||
- setenv("board_name", strcat(CONFIG_SYS_BOARD, "-a4"));
|
||||
+ setenv("board_name", "panda-a4");
|
||||
#endif
|
||||
}
|
||||
|
||||
--
|
||||
2.6.2
|
||||
|
|
@ -4,8 +4,8 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=uboot-pandaboard
|
||||
pkgver=2015.10
|
||||
pkgrel=2
|
||||
pkgver=2016.01
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for Pandaboard and Pandaboard ES"
|
||||
arch=('armv7h')
|
||||
url="http://git.denx.de/u-boot.git/"
|
||||
|
@ -15,18 +15,15 @@ install=${pkgname}.install
|
|||
backup=('boot/uEnv.txt')
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'0002-ARM-Fix-pandaboard-es-and-a4-revision-ID.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('7c203b0fc3390a122d8e8b75f147eac5'
|
||||
'bcdd217ecc19efcaddcb6ceb2cff79bf'
|
||||
'b93a61d2465a80ed7f0119c623719cb6'
|
||||
md5sums=('7d4f65fd43d4d706f5c5650e020d899d'
|
||||
'12c54a3f6b540658f9854ac38878d34f'
|
||||
'86004660f2912861a040e335c9c0e85b')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-${pkgver}
|
||||
|
||||
git apply ../0001-arch-linux-arm-modifications.patch
|
||||
git apply ../0002-ARM-Fix-pandaboard-es-and-a4-revision-ID.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue