alarm/uboot-odroid to 2015.10-1

This commit is contained in:
Kevin Mihelich 2015-11-21 19:51:37 +00:00
parent d83d4cfa29
commit c9666ab046
3 changed files with 32 additions and 25 deletions

View file

@ -1,14 +1,14 @@
From e8374fe12000eaadbf2c486700138e85286bea32 Mon Sep 17 00:00:00 2001
From 50713702485708abcf718cd885825baa8a4a48c9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 22 Aug 2014 17:51:41 -0600
Subject: [PATCH 1/2] arch linux arm modifications
---
include/configs/odroid.h | 167 +++++++++++++++++++----------------------------
1 file changed, 66 insertions(+), 101 deletions(-)
include/configs/odroid.h | 174 ++++++++++++++++++-----------------------------
1 file changed, 65 insertions(+), 109 deletions(-)
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
index 807e96b..0bc008b 100644
index 4c85e85..8ae43e8 100644
--- a/include/configs/odroid.h
+++ b/include/configs/odroid.h
@@ -14,6 +14,7 @@
@ -16,9 +16,9 @@ index 807e96b..0bc008b 100644
#include <configs/exynos4-common.h>
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
#define CONFIG_SYS_PROMPT "Odroid # " /* Monitor Command Prompt */
#define CONFIG_SYS_L2CACHE_OFF
#ifndef CONFIG_SYS_L2CACHE_OFF
#define CONFIG_SYS_L2_PL310
@@ -35,6 +36,7 @@
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_SDRAM_BASE + 0x5E00000)
#define CONFIG_SYS_LOAD_ADDR (CONFIG_SYS_SDRAM_BASE + 0x3E00000)
@ -41,7 +41,7 @@ index 807e96b..0bc008b 100644
#define CONFIG_SYS_INIT_SP_ADDR (CONFIG_SYS_LOAD_ADDR \
- GENERATED_GBL_DATA_SIZE)
@@ -66,35 +67,6 @@
@@ -64,35 +65,6 @@
#define CONFIG_ENV_OFFSET (SZ_1K * 1280) /* 1.25 MiB offset */
#define CONFIG_ENV_OVERWRITE
@ -77,7 +77,7 @@ index 807e96b..0bc008b 100644
/*
* Bootable media layout:
* dev: SD eMMC(part boot)
@@ -103,77 +75,70 @@
@@ -101,85 +73,69 @@
* UBOOT 63 62
* TZSW 2111 2110
* ENV 2560 2560(part user)
@ -87,13 +87,14 @@ index 807e96b..0bc008b 100644
- * 1. BOOT: 100MiB 2MiB
- * 2. ROOT: -
*/
+
#define CONFIG_EXTRA_ENV_SETTINGS \
- "loadkernel=fatload mmc ${mmcbootdev}:${mmcbootpart} ${kerneladdr} " \
- "loadbootscript=load mmc ${mmcbootdev}:${mmcbootpart} ${scriptaddr} " \
- "boot.scr\0" \
- "loadkernel=load mmc ${mmcbootdev}:${mmcbootpart} ${kerneladdr} " \
- "${kernelname}\0" \
- "loadinitrd=fatload mmc ${mmcbootdev}:${mmcbootpart} ${initrdaddr} " \
- "loadinitrd=load mmc ${mmcbootdev}:${mmcbootpart} ${initrdaddr} " \
- "${initrdname}\0" \
- "loaddtb=fatload mmc ${mmcbootdev}:${mmcbootpart} ${fdtaddr} " \
- "loaddtb=load mmc ${mmcbootdev}:${mmcbootpart} ${fdtaddr} " \
- "${fdtfile}\0" \
- "check_ramdisk=" \
- "if run loadinitrd; then " \
@ -110,6 +111,9 @@ index 807e96b..0bc008b 100644
- "kernel_args=" \
- "setenv bootargs root=/dev/mmcblk${mmcrootdev}p${mmcrootpart}" \
- " rootwait ${console} ${opts}\0" \
- "boot_script=" \
- "run loadbootscript;" \
- "source ${scriptaddr}\0" \
- "boot_fit=" \
- "setenv kerneladdr 0x42000000;" \
- "setenv kernelname Image.itb;" \
@ -133,7 +137,9 @@ index 807e96b..0bc008b 100644
- "run kernel_args;" \
- "bootz ${kerneladdr} ${initrd_addr} ${fdt_addr};\0" \
- "autoboot=" \
- "if test -e mmc 0 Image.itb; then; " \
- "if test -e mmc 0 boot.scr; then; " \
- "run boot_script; " \
- "elif test -e mmc 0 Image.itb; then; " \
- "run boot_fit;" \
- "elif test -e mmc 0 zImage; then; " \
- "run boot_zimg;" \
@ -152,6 +158,7 @@ index 807e96b..0bc008b 100644
- "consoleoff=set console console=ram; save; reset\0" \
- "initrdname=uInitrd\0" \
- "initrdaddr=42000000\0" \
- "scriptaddr=0x42000000\0" \
- "fdtaddr=40800000\0"
+ "bootfile=zImage\0" \
+ "bootdir=/boot\0" \
@ -218,5 +225,5 @@ index 807e96b..0bc008b 100644
/* I2C */
#define CONFIG_CMD_I2C
--
2.2.2
2.6.2

View file

@ -1,4 +1,4 @@
From e118875e0bbb7d08d424081592660ea6b07ba163 Mon Sep 17 00:00:00 2001
From 0eaca48880b25df1a04dff34e7d5740e1df188f9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 6 Feb 2015 05:40:56 -0700
Subject: [PATCH 2/2] odroid-x support
@ -9,10 +9,10 @@ Subject: [PATCH 2/2] odroid-x support
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/board/samsung/odroid/odroid.c b/board/samsung/odroid/odroid.c
index b7d2381..f7e793c 100644
index 32155f1..f6fa7b7 100644
--- a/board/samsung/odroid/odroid.c
+++ b/board/samsung/odroid/odroid.c
@@ -54,7 +54,7 @@ void set_board_type(void)
@@ -64,7 +64,7 @@ void set_board_type(void)
const char *get_board_type(void)
{
@ -22,10 +22,10 @@ index b7d2381..f7e793c 100644
return board_type[gd->board_type];
}
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
index 0bc008b..dfd8fd5 100644
index 8ae43e8..9ed9e5e 100644
--- a/include/configs/odroid.h
+++ b/include/configs/odroid.h
@@ -26,7 +26,7 @@
@@ -23,7 +23,7 @@
#define CONFIG_MACH_TYPE 4289
@ -35,5 +35,5 @@ index 0bc008b..dfd8fd5 100644
#define SDRAM_BANK_SIZE (256 << 20) /* 256 MB */
#define PHYS_SDRAM_1 CONFIG_SYS_SDRAM_BASE
--
2.2.2
2.6.2

View file

@ -5,7 +5,7 @@ buildarch=4
pkgbase=uboot-odroid
pkgname=('uboot-odroid' 'uboot-odroid-x')
pkgver=2015.07
pkgver=2015.10
pkgrel=1
arch=('armv7h')
url='http://www.denx.de/wiki/U-Boot/WebHome'
@ -22,13 +22,13 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
'0001-arch-linux-arm-modifications.patch'
'0002-odroid-x-support.patch'
'uEnv.txt')
md5sums=('3dac9a0b46fed77fc768ad3bd2d68c05'
md5sums=('7c203b0fc3390a122d8e8b75f147eac5'
'3ab6d3cc2061bc2590d60320254017c6'
'841502de02bd42f2898e36c89c260b0f'
'c38faafa02a6a1ae834457f378c82113'
'17909ae93a0ae7b4c155234040105035'
'5f6296fe2c79b2b799fb4420bafbca60'
'ff6e82e3c0bf31aff53572e759e30bca'
'a54a0045f6c2021cf91bc9fc9aa4566c'
'cb47c5faedc37609731e4bc2f23b5ce2'
'fb5c9ea3108afa298087549f0453b00f')
prepare() {