mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/firefox to 80.0-1
This commit is contained in:
parent
700f591b21
commit
c9799a82bc
2 changed files with 3 additions and 84 deletions
|
@ -10,7 +10,7 @@ buildarch=12
|
||||||
highmem=1
|
highmem=1
|
||||||
|
|
||||||
pkgname=firefox
|
pkgname=firefox
|
||||||
pkgver=79.0
|
pkgver=80.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="Standalone web browser from mozilla.org"
|
pkgdesc="Standalone web browser from mozilla.org"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
|
@ -30,14 +30,12 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
|
||||||
arm.patch
|
arm.patch
|
||||||
build-arm-libopus.patch
|
build-arm-libopus.patch
|
||||||
0001-Use-remoting-name-for-GDK-application-names.patch
|
0001-Use-remoting-name-for-GDK-application-names.patch
|
||||||
bug1654465.diff
|
|
||||||
$pkgname.desktop)
|
$pkgname.desktop)
|
||||||
sha256sums=('12a922855914ec6b4d4f06a4ac58bc549aca6bdafd3722d68a3d709a935e5713'
|
sha256sums=('380d9853e0712442ba2d4acd85c0e09c19ad36561a3ea8932705ad6b8a91146a'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
|
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
|
||||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||||
'3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
|
'3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
|
||||||
'e577f7e5636deda0026b0e385186f3ecb2212c9b84b6a2949a1811dab3e410d6'
|
|
||||||
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
|
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
|
||||||
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
||||||
|
|
||||||
|
@ -61,14 +59,12 @@ prepare() {
|
||||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
||||||
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
||||||
|
|
||||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1654465
|
|
||||||
patch -Np1 -i ../bug1654465.diff
|
|
||||||
|
|
||||||
echo -n "$_google_api_key" >google-api-key
|
echo -n "$_google_api_key" >google-api-key
|
||||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||||
|
|
||||||
cat >.mozconfig <<END
|
cat >.mozconfig <<END
|
||||||
ac_add_options --enable-application=browser
|
ac_add_options --enable-application=browser
|
||||||
|
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
|
||||||
|
|
||||||
ac_add_options --prefix=/usr
|
ac_add_options --prefix=/usr
|
||||||
ac_add_options --enable-release
|
ac_add_options --enable-release
|
||||||
|
|
|
@ -1,77 +0,0 @@
|
||||||
build/moz.configure/rust.configure | 2 +-
|
|
||||||
config/makefiles/rust.mk | 5 +++++
|
|
||||||
.../mozbuild/test/configure/test_toolchain_configure.py | 14 --------------
|
|
||||||
3 files changed, 6 insertions(+), 15 deletions(-)
|
|
||||||
|
|
||||||
diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
|
|
||||||
index aaa693059d95..c90ae5ca7b25 100644
|
|
||||||
--- c/build/moz.configure/rust.configure
|
|
||||||
+++ i/build/moz.configure/rust.configure
|
|
||||||
@@ -146,7 +146,7 @@ def rust_compiler(rustc_info, cargo_info, build_project):
|
|
||||||
or by directly running the installer from https://rustup.rs/
|
|
||||||
'''))
|
|
||||||
if build_project == 'tools/crashreporter':
|
|
||||||
- rustc_min_version = Version('1.31.0')
|
|
||||||
+ rustc_min_version = Version('1.38.0')
|
|
||||||
else:
|
|
||||||
rustc_min_version = Version('1.43.0')
|
|
||||||
cargo_min_version = rustc_min_version
|
|
||||||
diff --git c/config/makefiles/rust.mk i/config/makefiles/rust.mk
|
|
||||||
index a9abcc9af4c0..b5c7973104ce 100644
|
|
||||||
--- c/config/makefiles/rust.mk
|
|
||||||
+++ i/config/makefiles/rust.mk
|
|
||||||
@@ -63,6 +63,11 @@ ifndef MOZ_DEBUG_RUST
|
|
||||||
ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
|
|
||||||
cargo_rustc_flags += -Clto
|
|
||||||
endif
|
|
||||||
+# Versions of rust >= 1.45 need -Cembed-bitcode=yes for all crates when
|
|
||||||
+# using -Clto.
|
|
||||||
+ifeq (,$(filter 1.38.% 1.39.% 1.40.% 1.41.% 1.42.% 1.43.% 1.44.%,$(RUSTC_VERSION)))
|
|
||||||
+RUSTFLAGS += -Cembed-bitcode=yes
|
|
||||||
+endif
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
diff --git c/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py i/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
|
|
||||||
index e1921ece6865..759d4d98cc0d 100755
|
|
||||||
--- c/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
|
|
||||||
+++ i/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
|
|
||||||
@@ -1796,38 +1796,24 @@ class RustTest(BaseConfigureTest):
|
|
||||||
arm_arch=7, fpu='neon', thumb2=True, float_abi='softfp')),
|
|
||||||
'thumbv7neon-linux-androideabi')
|
|
||||||
|
|
||||||
- self.assertEqual(
|
|
||||||
- self.get_rust_target('arm-unknown-linux-androideabi',
|
|
||||||
- version='1.32.0',
|
|
||||||
- arm_target=ReadOnlyNamespace(
|
|
||||||
- arm_arch=7, fpu='neon', thumb2=True, float_abi='softfp')),
|
|
||||||
- 'armv7-linux-androideabi')
|
|
||||||
-
|
|
||||||
self.assertEqual(
|
|
||||||
self.get_rust_target('arm-unknown-linux-androideabi',
|
|
||||||
arm_target=ReadOnlyNamespace(
|
|
||||||
arm_arch=7, fpu='neon', thumb2=False, float_abi='softfp')),
|
|
||||||
'armv7-linux-androideabi')
|
|
||||||
|
|
||||||
self.assertEqual(
|
|
||||||
self.get_rust_target('arm-unknown-linux-androideabi',
|
|
||||||
arm_target=ReadOnlyNamespace(
|
|
||||||
arm_arch=7, fpu='vfpv2', thumb2=True, float_abi='softfp')),
|
|
||||||
'armv7-linux-androideabi')
|
|
||||||
|
|
||||||
self.assertEqual(
|
|
||||||
self.get_rust_target('armv7-unknown-linux-gnueabihf',
|
|
||||||
arm_target=ReadOnlyNamespace(
|
|
||||||
arm_arch=7, fpu='neon', thumb2=True, float_abi='hard')),
|
|
||||||
'thumbv7neon-unknown-linux-gnueabihf')
|
|
||||||
|
|
||||||
- self.assertEqual(
|
|
||||||
- self.get_rust_target('armv7-unknown-linux-gnueabihf',
|
|
||||||
- version='1.32.0',
|
|
||||||
- arm_target=ReadOnlyNamespace(
|
|
||||||
- arm_arch=7, fpu='neon', thumb2=True, float_abi='hard')),
|
|
||||||
- 'armv7-unknown-linux-gnueabihf')
|
|
||||||
-
|
|
||||||
self.assertEqual(
|
|
||||||
self.get_rust_target('armv7-unknown-linux-gnueabihf',
|
|
||||||
arm_target=ReadOnlyNamespace(
|
|
Loading…
Reference in a new issue