mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/nodejs: fix
This commit is contained in:
parent
75b2564db4
commit
c97dd165ee
2 changed files with 9 additions and 9 deletions
|
@ -26,7 +26,7 @@ optdepends=('npm: nodejs package manager')
|
|||
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz"
|
||||
'atomic.patch')
|
||||
sha512sums=('a1d2fee2517e19d6e17b49f687b4f91c60da2a15d4741a03748f7799b7f2c7f702597d9046c1e4911808e7781180f0a66aff9e60fdaf0f5818d1c968e4481aa2'
|
||||
'a547a4c9db4ab7609d759bf1d0f1c1809389ce3d3288234470e427438db71551e246791eafab5456f57682989c360d0c78407003ceb1f2f073613ab8c37646d3')
|
||||
'3d7378b80a9729f5dd5c6c7446531244a67bd6021ccf6feb270af2b698d9bd2ff3c6bf84f8d0a6eb3671c59ea920de8ec081cac0b705236b474b61427f5c1e39')
|
||||
|
||||
prepare() {
|
||||
cd node-$pkgver
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- node.gyp.orig 2019-08-24 10:05:57.160565594 -0600
|
||||
+++ node.gyp 2019-08-24 10:07:00.240470669 -0600
|
||||
@@ -311,6 +311,12 @@
|
||||
--- node.gyp.orig 2019-10-14 05:32:27.370777519 -0600
|
||||
+++ node.gyp 2019-10-14 05:39:18.842470025 -0600
|
||||
@@ -314,6 +314,12 @@
|
||||
'deps/v8/include'
|
||||
],
|
||||
|
||||
|
@ -13,14 +13,14 @@
|
|||
'sources': [
|
||||
'src/node_main.cc'
|
||||
],
|
||||
--- tools/v8_gypfiles/v8.gyp.orig 2019-08-24 12:42:33.041596717 -0600
|
||||
+++ tools/v8_gypfiles/v8.gyp 2019-08-24 13:02:49.504187934 -0600
|
||||
@@ -858,7 +858,7 @@
|
||||
--- tools/v8_gypfiles/v8.gyp.orig 2019-10-14 05:32:59.750753410 -0600
|
||||
+++ tools/v8_gypfiles/v8.gyp 2019-10-14 05:39:18.842470025 -0600
|
||||
@@ -795,7 +795,7 @@
|
||||
}],
|
||||
# Platforms that don't have Compare-And-Swap (CAS) support need to link atomic library
|
||||
# to implement atomic memory access
|
||||
- ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "ppc64", "s390x"]', {
|
||||
+ ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "ppc64", "s390x", "arm"]', {
|
||||
- ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc"]', {
|
||||
+ ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "arm"]', {
|
||||
'link_settings': {
|
||||
'libraries': ['-latomic', ],
|
||||
},
|
||||
|
|
Loading…
Reference in a new issue