mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/firefox to 57.0.1-1
This commit is contained in:
parent
5bcb5aed6f
commit
c9a7a2c168
4 changed files with 307 additions and 46 deletions
|
@ -1,9 +1,9 @@
|
|||
From 34508b32f65d5ad8143623b1258eb92d347514e2 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <34508b32f65d5ad8143623b1258eb92d347514e2.1511260210.git.jan.steffens@gmail.com>
|
||||
From 05ec1aa0d5e8806dd0c5c6d08c82846a1389b599 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <05ec1aa0d5e8806dd0c5c6d08c82846a1389b599.1512038840.git.jan.steffens@gmail.com>
|
||||
From: Robin Grenet <robin.grenet@wanadoo.fr>
|
||||
Date: Thu, 16 Nov 2017 13:35:58 +0100
|
||||
Subject: [PATCH] Bug 1360278 - Add preference to trigger context menu on mouse
|
||||
up for GTK+ and macOS, r=mstange,smaug
|
||||
Subject: [PATCH 1/2] Bug 1360278 - Add preference to trigger context menu on
|
||||
mouse up for GTK+ and macOS, r=mstange,smaug
|
||||
|
||||
MozReview-Commit-ID: Bg60bD8jIg6
|
||||
|
||||
|
@ -19,11 +19,11 @@ extra : rebase_source : cc8bd5796096f49ad4fdab81885a426afd6117e4
|
|||
6 files changed, 69 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/modules/libpref/init/all.js b/modules/libpref/init/all.js
|
||||
index 315422a6e2255e5f..92bcf5f02564d46e 100644
|
||||
index 9febead1d363d792..7a6e6a20f3cc3fd6 100644
|
||||
--- a/modules/libpref/init/all.js
|
||||
+++ b/modules/libpref/init/all.js
|
||||
@@ -234,6 +234,10 @@ pref("browser.sessionhistory.max_total_viewers", -1);
|
||||
|
||||
@@ -231,6 +231,10 @@ pref("browser.sessionhistory.max_total_viewers", -1);
|
||||
|
||||
pref("ui.use_native_colors", true);
|
||||
pref("ui.click_hold_context_menus", false);
|
||||
+
|
||||
|
@ -34,39 +34,39 @@ index 315422a6e2255e5f..92bcf5f02564d46e 100644
|
|||
pref("ui.menu.incremental_search.timeout", 1000);
|
||||
// If true, all popups won't hide automatically on blur
|
||||
diff --git a/widget/cocoa/nsChildView.mm b/widget/cocoa/nsChildView.mm
|
||||
index cac897327a190422..bf42b4f8c0950753 100644
|
||||
index 25b4c1ba7a2d1207..2affd1ef386cbfd0 100644
|
||||
--- a/widget/cocoa/nsChildView.mm
|
||||
+++ b/widget/cocoa/nsChildView.mm
|
||||
@@ -4700,30 +4700,49 @@ NSEvent* gLastDragMouseDownEvent = nil;
|
||||
@@ -4719,30 +4719,49 @@ NSEvent* gLastDragMouseDownEvent = nil;
|
||||
if (!mGeckoChild)
|
||||
return;
|
||||
|
||||
|
||||
- // Let the superclass do the context menu stuff.
|
||||
- [super rightMouseDown:theEvent];
|
||||
+ if (!nsBaseWidget::ShowContextMenuAfterMouseUp()) {
|
||||
+ // Let the superclass do the context menu stuff.
|
||||
+ [super rightMouseDown:theEvent];
|
||||
+ }
|
||||
|
||||
|
||||
NS_OBJC_END_TRY_ABORT_BLOCK;
|
||||
}
|
||||
|
||||
|
||||
- (void)rightMouseUp:(NSEvent *)theEvent
|
||||
{
|
||||
NS_OBJC_BEGIN_TRY_ABORT_BLOCK;
|
||||
|
||||
|
||||
if (!mGeckoChild)
|
||||
return;
|
||||
if (mTextInputHandler->OnHandleEvent(theEvent)) {
|
||||
return;
|
||||
}
|
||||
|
||||
|
||||
WidgetMouseEvent geckoEvent(true, eMouseUp, mGeckoChild,
|
||||
WidgetMouseEvent::eReal);
|
||||
[self convertCocoaMouseEvent:theEvent toGeckoEvent:&geckoEvent];
|
||||
geckoEvent.button = WidgetMouseEvent::eRightButton;
|
||||
geckoEvent.mClickCount = [theEvent clickCount];
|
||||
|
||||
|
||||
nsAutoRetainCocoaObject kungFuDeathGrip(self);
|
||||
mGeckoChild->DispatchInputEvent(&geckoEvent);
|
||||
+ if (!mGeckoChild)
|
||||
|
@ -86,17 +86,17 @@ index cac897327a190422..bf42b4f8c0950753 100644
|
|||
+
|
||||
+ [super rightMouseDown:dupeEvent];
|
||||
+ }
|
||||
|
||||
|
||||
NS_OBJC_END_TRY_ABORT_BLOCK;
|
||||
}
|
||||
diff --git a/widget/gtk/nsWindow.cpp b/widget/gtk/nsWindow.cpp
|
||||
index 87cc858ca7efd11d..17992f78bbf0a0a7 100644
|
||||
index 37b6aae4c3d0b4e7..2b80124538c20ed6 100644
|
||||
--- a/widget/gtk/nsWindow.cpp
|
||||
+++ b/widget/gtk/nsWindow.cpp
|
||||
@@ -2737,6 +2737,19 @@ static guint ButtonMaskFromGDKButton(guint button)
|
||||
@@ -2727,6 +2727,19 @@ static guint ButtonMaskFromGDKButton(guint button)
|
||||
return GDK_BUTTON1_MASK << (button - 1);
|
||||
}
|
||||
|
||||
|
||||
+void
|
||||
+nsWindow::DispatchContextMenuEventFromMouseEvent(uint16_t domButton,
|
||||
+ GdkEventButton *aEvent)
|
||||
|
@ -113,9 +113,9 @@ index 87cc858ca7efd11d..17992f78bbf0a0a7 100644
|
|||
void
|
||||
nsWindow::OnButtonPressEvent(GdkEventButton *aEvent)
|
||||
{
|
||||
@@ -2806,13 +2819,8 @@ nsWindow::OnButtonPressEvent(GdkEventButton *aEvent)
|
||||
@@ -2796,13 +2809,8 @@ nsWindow::OnButtonPressEvent(GdkEventButton *aEvent)
|
||||
DispatchInputEvent(&event);
|
||||
|
||||
|
||||
// right menu click on linux should also pop up a context menu
|
||||
- if (domButton == WidgetMouseEvent::eRightButton &&
|
||||
- MOZ_LIKELY(!mIsDestroyed)) {
|
||||
|
@ -128,9 +128,9 @@ index 87cc858ca7efd11d..17992f78bbf0a0a7 100644
|
|||
+ DispatchContextMenuEventFromMouseEvent(domButton, aEvent);
|
||||
}
|
||||
}
|
||||
|
||||
@@ -2848,6 +2856,11 @@ nsWindow::OnButtonReleaseEvent(GdkEventButton *aEvent)
|
||||
|
||||
|
||||
@@ -2838,6 +2846,11 @@ nsWindow::OnButtonReleaseEvent(GdkEventButton *aEvent)
|
||||
|
||||
DispatchInputEvent(&event);
|
||||
mLastMotionPressure = pressure;
|
||||
+
|
||||
|
@ -139,29 +139,29 @@ index 87cc858ca7efd11d..17992f78bbf0a0a7 100644
|
|||
+ DispatchContextMenuEventFromMouseEvent(domButton, aEvent);
|
||||
+ }
|
||||
}
|
||||
|
||||
|
||||
void
|
||||
diff --git a/widget/gtk/nsWindow.h b/widget/gtk/nsWindow.h
|
||||
index 0fafc8994579fe3c..7a28e3260c0fdefb 100644
|
||||
index f7c07d57491b0b83..b969c9db4306ba6a 100644
|
||||
--- a/widget/gtk/nsWindow.h
|
||||
+++ b/widget/gtk/nsWindow.h
|
||||
@@ -245,6 +245,8 @@ private:
|
||||
|
||||
|
||||
void UpdateClientOffset();
|
||||
|
||||
|
||||
+ void DispatchContextMenuEventFromMouseEvent(uint16_t domButton,
|
||||
+ GdkEventButton *aEvent);
|
||||
public:
|
||||
void ThemeChanged(void);
|
||||
void OnDPIChanged(void);
|
||||
diff --git a/widget/nsBaseWidget.cpp b/widget/nsBaseWidget.cpp
|
||||
index 13fccd7f7d6627fb..e4ca5e011894f5c4 100644
|
||||
index 996409f45db11cc7..de73fe36d27955cd 100644
|
||||
--- a/widget/nsBaseWidget.cpp
|
||||
+++ b/widget/nsBaseWidget.cpp
|
||||
@@ -1218,6 +1218,22 @@ nsBaseWidget::DispatchEventToAPZOnly(mozilla::WidgetInputEvent* aEvent)
|
||||
@@ -1222,6 +1222,22 @@ nsBaseWidget::DispatchEventToAPZOnly(mozilla::WidgetInputEvent* aEvent)
|
||||
}
|
||||
}
|
||||
|
||||
|
||||
+// static
|
||||
+bool
|
||||
+nsBaseWidget::ShowContextMenuAfterMouseUp()
|
||||
|
@ -182,13 +182,13 @@ index 13fccd7f7d6627fb..e4ca5e011894f5c4 100644
|
|||
nsBaseWidget::GetDocument() const
|
||||
{
|
||||
diff --git a/widget/nsBaseWidget.h b/widget/nsBaseWidget.h
|
||||
index f4e8e3d783307cc1..3cb56f38b6ced983 100644
|
||||
index 6d6b93ea73d64b38..cdc6aa0c87279832 100644
|
||||
--- a/widget/nsBaseWidget.h
|
||||
+++ b/widget/nsBaseWidget.h
|
||||
@@ -417,6 +417,12 @@ public:
|
||||
@@ -418,6 +418,12 @@ public:
|
||||
void RecvScreenPixels(mozilla::ipc::Shmem&& aMem, const ScreenIntSize& aSize) override {};
|
||||
#endif
|
||||
|
||||
|
||||
+ /**
|
||||
+ * Whether context menus should only appear on mouseup instead of mousedown,
|
||||
+ * on OSes where they normally appear on mousedown (macOS, *nix).
|
||||
|
@ -198,5 +198,6 @@ index f4e8e3d783307cc1..3cb56f38b6ced983 100644
|
|||
protected:
|
||||
// These are methods for CompositorWidgetWrapper, and should only be
|
||||
// accessed from that class. Derived widgets can choose which methods to
|
||||
--
|
||||
2.15.0
|
||||
--
|
||||
2.15.1
|
||||
|
||||
|
|
|
@ -0,0 +1,254 @@
|
|||
From f19a0f3bc5e1e87d3c663cc2b147c5c0831519c5 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <f19a0f3bc5e1e87d3c663cc2b147c5c0831519c5.1512038840.git.jan.steffens@gmail.com>
|
||||
In-Reply-To: <05ec1aa0d5e8806dd0c5c6d08c82846a1389b599.1512038840.git.jan.steffens@gmail.com>
|
||||
References: <05ec1aa0d5e8806dd0c5c6d08c82846a1389b599.1512038840.git.jan.steffens@gmail.com>
|
||||
From: Bob Silverberg <bsilverberg@mozilla.com>
|
||||
Date: Fri, 24 Nov 2017 07:45:03 -0500
|
||||
Subject: [PATCH 2/2] Bug 1419426 - Implement
|
||||
browserSettings.contextMenuShowEvent, r=kmag a=gchang
|
||||
|
||||
Uplift for 58.
|
||||
---
|
||||
.../components/extensions/ext-browserSettings.js | 45 ++++++++++++++++
|
||||
.../extensions/schemas/browser_settings.json | 10 ++++
|
||||
.../test/xpcshell/test_ext_browserSettings.js | 62 ++++++++++++++++++++--
|
||||
3 files changed, 114 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/toolkit/components/extensions/ext-browserSettings.js b/toolkit/components/extensions/ext-browserSettings.js
|
||||
index f3212f351baf6975..2b24bcc1d09091f2 100644
|
||||
--- a/toolkit/components/extensions/ext-browserSettings.js
|
||||
+++ b/toolkit/components/extensions/ext-browserSettings.js
|
||||
@@ -2,17 +2,23 @@
|
||||
/* vim: set sts=2 sw=2 et tw=80: */
|
||||
"use strict";
|
||||
|
||||
+XPCOMUtils.defineLazyModuleGetter(this, "AppConstants",
|
||||
+ "resource://gre/modules/AppConstants.jsm");
|
||||
XPCOMUtils.defineLazyModuleGetter(this, "ExtensionSettingsStore",
|
||||
"resource://gre/modules/ExtensionSettingsStore.jsm");
|
||||
XPCOMUtils.defineLazyModuleGetter(this, "Services",
|
||||
"resource://gre/modules/Services.jsm");
|
||||
|
||||
XPCOMUtils.defineLazyServiceGetter(this, "aboutNewTabService",
|
||||
"@mozilla.org/browser/aboutnewtab-service;1",
|
||||
"nsIAboutNewTabService");
|
||||
|
||||
Cu.import("resource://gre/modules/ExtensionPreferencesManager.jsm");
|
||||
|
||||
+var {
|
||||
+ ExtensionError,
|
||||
+} = ExtensionUtils;
|
||||
+
|
||||
const HOMEPAGE_OVERRIDE_SETTING = "homepage_override";
|
||||
const HOMEPAGE_URL_PREF = "browser.startup.homepage";
|
||||
const URL_STORE_TYPE = "url_overrides";
|
||||
@@ -82,6 +88,16 @@ ExtensionPreferencesManager.addSetting("imageAnimationBehavior", {
|
||||
},
|
||||
});
|
||||
|
||||
+ExtensionPreferencesManager.addSetting("contextMenuShowEvent", {
|
||||
+ prefNames: [
|
||||
+ "ui.context_menus.after_mouseup",
|
||||
+ ],
|
||||
+
|
||||
+ setCallback(value) {
|
||||
+ return {[this.prefNames[0]]: value === "mouseup"};
|
||||
+ },
|
||||
+});
|
||||
+
|
||||
this.browserSettings = class extends ExtensionAPI {
|
||||
getAPI(context) {
|
||||
let {extension} = context;
|
||||
@@ -114,6 +130,35 @@ this.browserSettings = class extends ExtensionAPI {
|
||||
() => {
|
||||
return aboutNewTabService.newTabURL;
|
||||
}, URL_STORE_TYPE, true),
|
||||
+ contextMenuShowEvent: Object.assign(
|
||||
+ getSettingsAPI(
|
||||
+ extension,
|
||||
+ "contextMenuShowEvent",
|
||||
+ () => {
|
||||
+ if (AppConstants.platform === "win") {
|
||||
+ return "mouseup";
|
||||
+ }
|
||||
+ let prefValue = Services.prefs.getBoolPref(
|
||||
+ "ui.context_menus.after_mouseup", null);
|
||||
+ return prefValue ? "mouseup" : "mousedown";
|
||||
+ }
|
||||
+ ),
|
||||
+ {
|
||||
+ set: details => {
|
||||
+ if (!["mouseup", "mousedown"].includes(details.value)) {
|
||||
+ throw new ExtensionError(
|
||||
+ `${details.value} is not a valid value for contextMenuShowEvent.`);
|
||||
+ }
|
||||
+ if (AppConstants.platform === "android" ||
|
||||
+ (AppConstants.platform === "win" &&
|
||||
+ details.value === "mousedown")) {
|
||||
+ return false;
|
||||
+ }
|
||||
+ return ExtensionPreferencesManager.setSetting(
|
||||
+ extension, "contextMenuShowEvent", details.value);
|
||||
+ },
|
||||
+ }
|
||||
+ ),
|
||||
},
|
||||
};
|
||||
}
|
||||
diff --git a/toolkit/components/extensions/schemas/browser_settings.json b/toolkit/components/extensions/schemas/browser_settings.json
|
||||
index af073d933723cbd5..4f354e69dfedaf96 100644
|
||||
--- a/toolkit/components/extensions/schemas/browser_settings.json
|
||||
+++ b/toolkit/components/extensions/schemas/browser_settings.json
|
||||
@@ -27,28 +27,38 @@
|
||||
"type": "string",
|
||||
"enum": ["normal", "none", "once"],
|
||||
"description": "How images should be animated in the browser."
|
||||
+ },
|
||||
+ {
|
||||
+ "id": "ContextMenuMouseEvent",
|
||||
+ "type": "string",
|
||||
+ "enum": ["mouseup", "mousedown"],
|
||||
+ "description": "After which mouse event context menus should popup."
|
||||
}
|
||||
],
|
||||
"properties": {
|
||||
"allowPopupsForUserEvents": {
|
||||
"$ref": "types.Setting",
|
||||
"description": "Allows or disallows pop-up windows from opening in response to user events."
|
||||
},
|
||||
"cacheEnabled": {
|
||||
"$ref": "types.Setting",
|
||||
"description": "Enables or disables the browser cache."
|
||||
},
|
||||
"homepageOverride": {
|
||||
"$ref": "types.Setting",
|
||||
"description": "Returns the value of the overridden home page. Read-only."
|
||||
},
|
||||
"imageAnimationBehavior": {
|
||||
"$ref": "types.Setting",
|
||||
"description": "Controls the behaviour of image animation in the browser. This setting's value is of type ImageAnimationBehavior, defaulting to <code>normal</code>."
|
||||
},
|
||||
"newTabPageOverride": {
|
||||
"$ref": "types.Setting",
|
||||
"description": "Returns the value of the overridden new tab page. Read-only."
|
||||
+ },
|
||||
+ "contextMenuShowEvent": {
|
||||
+ "$ref": "types.Setting",
|
||||
+ "description": "Controls after which mouse event context menus popup. This setting's value is of type ContextMenuMouseEvent, which has possible values of <code>mouseup</code> and <code>mousedown</code>."
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/toolkit/components/extensions/test/xpcshell/test_ext_browserSettings.js b/toolkit/components/extensions/test/xpcshell/test_ext_browserSettings.js
|
||||
index 5c441df3e4198671..7e9c1576a723dfc6 100644
|
||||
--- a/toolkit/components/extensions/test/xpcshell/test_ext_browserSettings.js
|
||||
+++ b/toolkit/components/extensions/test/xpcshell/test_ext_browserSettings.js
|
||||
@@ -24,13 +24,20 @@ add_task(async function test_browser_settings() {
|
||||
"browser.cache.memory.enable": true,
|
||||
"dom.popup_allowed_events": Preferences.get("dom.popup_allowed_events"),
|
||||
"image.animation_mode": "none",
|
||||
+ "ui.context_menus.after_mouseup": false,
|
||||
};
|
||||
|
||||
async function background() {
|
||||
browser.test.onMessage.addListener(async (msg, apiName, value) => {
|
||||
let apiObj = browser.browserSettings[apiName];
|
||||
- await apiObj.set({value});
|
||||
- browser.test.sendMessage("settingData", await apiObj.get({}));
|
||||
+ let result = await apiObj.set({value});
|
||||
+ if (msg === "set") {
|
||||
+ browser.test.assertTrue(result, "set returns true.");
|
||||
+ browser.test.sendMessage("settingData", await apiObj.get({}));
|
||||
+ } else {
|
||||
+ browser.test.assertFalse(result, "set returns false for a no-op.");
|
||||
+ browser.test.sendMessage("no-op set");
|
||||
+ }
|
||||
});
|
||||
}
|
||||
|
||||
@@ -69,33 +76,82 @@ add_task(async function test_browser_settings() {
|
||||
}
|
||||
}
|
||||
|
||||
+ async function testNoOpSetting(setting, value, expected) {
|
||||
+ extension.sendMessage("setNoOp", setting, value);
|
||||
+ await extension.awaitMessage("no-op set");
|
||||
+ for (let pref in expected) {
|
||||
+ equal(Preferences.get(pref), expected[pref], `${pref} set correctly for ${value}`);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
await testSetting(
|
||||
"cacheEnabled", false,
|
||||
{
|
||||
"browser.cache.disk.enable": false,
|
||||
"browser.cache.memory.enable": false,
|
||||
});
|
||||
await testSetting(
|
||||
"cacheEnabled", true,
|
||||
{
|
||||
"browser.cache.disk.enable": true,
|
||||
"browser.cache.memory.enable": true,
|
||||
});
|
||||
|
||||
await testSetting(
|
||||
"allowPopupsForUserEvents", false,
|
||||
{"dom.popup_allowed_events": ""});
|
||||
await testSetting(
|
||||
"allowPopupsForUserEvents", true,
|
||||
{"dom.popup_allowed_events": PREFS["dom.popup_allowed_events"]});
|
||||
|
||||
for (let value of ["normal", "none", "once"]) {
|
||||
await testSetting(
|
||||
"imageAnimationBehavior", value,
|
||||
{"image.animation_mode": value});
|
||||
}
|
||||
|
||||
- await extension.unload();
|
||||
+ // This setting is a no-op on Android.
|
||||
+ if (AppConstants.platform === "android") {
|
||||
+ await testNoOpSetting("contextMenuShowEvent", "mouseup",
|
||||
+ {"ui.context_menus.after_mouseup": false});
|
||||
+ } else {
|
||||
+ await testSetting(
|
||||
+ "contextMenuShowEvent", "mouseup",
|
||||
+ {"ui.context_menus.after_mouseup": true});
|
||||
+ }
|
||||
|
||||
+ // "mousedown" is also a no-op on Windows.
|
||||
+ if (["android", "win"].includes(AppConstants.platform)) {
|
||||
+ await testNoOpSetting("contextMenuShowEvent", "mousedown",
|
||||
+ {"ui.context_menus.after_mouseup": AppConstants.platform === "win"});
|
||||
+ } else {
|
||||
+ await testSetting(
|
||||
+ "contextMenuShowEvent", "mousedown",
|
||||
+ {"ui.context_menus.after_mouseup": false});
|
||||
+ }
|
||||
+
|
||||
+ await extension.unload();
|
||||
await promiseShutdownManager();
|
||||
});
|
||||
+
|
||||
+add_task(async function test_bad_value() {
|
||||
+ async function background() {
|
||||
+ await browser.test.assertRejects(
|
||||
+ browser.browserSettings.contextMenuShowEvent.set({value: "bad"}),
|
||||
+ /bad is not a valid value for contextMenuShowEvent/,
|
||||
+ "contextMenuShowEvent.set rejects with an invalid value.");
|
||||
+
|
||||
+ browser.test.sendMessage("done");
|
||||
+ }
|
||||
+
|
||||
+ let extension = ExtensionTestUtils.loadExtension({
|
||||
+ background,
|
||||
+ manifest: {
|
||||
+ permissions: ["browserSettings"],
|
||||
+ },
|
||||
+ });
|
||||
+
|
||||
+ await extension.startup();
|
||||
+ await extension.awaitMessage("done");
|
||||
+ await extension.unload();
|
||||
+});
|
||||
--
|
||||
2.15.1
|
||||
|
|
@ -11,8 +11,8 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=57.0
|
||||
pkgrel=2
|
||||
pkgver=57.0.1
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=(x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
|
@ -29,15 +29,17 @@ options=(!emptydirs !makeflags !strip)
|
|||
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
|
||||
$pkgname.desktop firefox-symbolic.svg
|
||||
0001-Bug-1360278-Add-preference-to-trigger-context-menu-o.patch
|
||||
0002-Bug-1419426-Implement-browserSettings.contextMenuSho.patch
|
||||
wifi-disentangle.patch wifi-fix-interface.patch
|
||||
firefox-install-dir.patch no-plt.diff)
|
||||
sha256sums=('603af00155be87f2c9c58047dd0072971f1cdab1f632695aae6ad072efefbb8f'
|
||||
sha256sums=('7db7829e0771acf1be253a8841b9dc96d2ad6490a8f1430fa074e5fd857181ba'
|
||||
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
|
||||
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
|
||||
'1f71b379f2262d7319624c2aed31fa2dbed42828feccc27b1cd82153b76ad707'
|
||||
'd45c97782a77e7c5ebacfa7b983019f6bb831794d3c707abbe3bb01cddb80f72'
|
||||
'52c56c33f7ab98232d9c0644965f149da9b7266f607c84b80aca8a5534cee3bb'
|
||||
'f068b84ad31556095145d8fefc012dd3d1458948533ed3fff6cbc7250b6e73ed'
|
||||
'e98a3453d803cc7ddcb81a7dc83f883230dd8591bdf936fc5a868428979ed1f1'
|
||||
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
|
||||
'a94f80abe65608cd49054a30acc31e4d0885fe5b2a38cf08ded5e5b51b87c99d'
|
||||
'ea8e1b871c0f1dd29cdea1b1a2e7f47bf4713e2ae7b947ec832dba7dfcc67daa')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -63,6 +65,9 @@ prepare() {
|
|||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1360278
|
||||
patch -Np1 -i ../0001-Bug-1360278-Add-preference-to-trigger-context-menu-o.patch
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1419426
|
||||
patch -Np1 -i ../0002-Bug-1419426-Implement-browserSettings.contextMenuSho.patch
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
|
||||
patch -Np1 -i ../wifi-disentangle.patch
|
||||
patch -Np1 -i ../wifi-fix-interface.patch
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
diff -up firefox-29.0/mozilla-release/config/baseconfig.mk.orig firefox-29.0/mozilla-release/config/baseconfig.mk
|
||||
--- mozilla-release/config/baseconfig.mk.orig 2014-04-22 15:38:52.948165295 +0200
|
||||
+++ mozilla-release/config/baseconfig.mk 2014-04-22 15:42:20.387481673 +0200
|
||||
diff --git i/config/baseconfig.mk w/config/baseconfig.mk
|
||||
index e204533ac9b66b88..27ae154ce265ca2b 100644
|
||||
--- i/config/baseconfig.mk
|
||||
+++ w/config/baseconfig.mk
|
||||
@@ -4,7 +4,7 @@
|
||||
# whether a normal build is happening or whether the check is running.
|
||||
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
|
@ -8,5 +9,5 @@ diff -up firefox-29.0/mozilla-release/config/baseconfig.mk.orig firefox-29.0/moz
|
|||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
ifndef TOP_DIST
|
||||
TOP_DIST = dist
|
||||
ifeq (.,$(DEPTH))
|
||||
DIST = dist
|
||||
|
|
Loading…
Reference in a new issue