community/gimp-nufraw to 0.42-4

This commit is contained in:
Kevin Mihelich 2019-05-20 22:49:37 +00:00
parent 3e3cafd34c
commit c9eb5f357a
3 changed files with 42 additions and 3 deletions

View file

@ -5,7 +5,7 @@
pkgname=gimp-nufraw pkgname=gimp-nufraw
pkgver=0.42 pkgver=0.42
pkgrel=3 pkgrel=4
pkgdesc='Converter for raw files; utility and GIMP plugin' pkgdesc='Converter for raw files; utility and GIMP plugin'
url='https://sourceforge.net/projects/nufraw/' url='https://sourceforge.net/projects/nufraw/'
arch=('x86_64') arch=('x86_64')
@ -15,11 +15,15 @@ makedepends=('gimp')
conflicts=('gimp-ufraw') conflicts=('gimp-ufraw')
replaces=('gimp-ufraw') replaces=('gimp-ufraw')
optdepends=('gimp: to use the gimp import plugin for raw images') optdepends=('gimp: to use the gimp import plugin for raw images')
source=("https://downloads.sourceforge.net/nufraw/nufraw-$pkgver.tar.gz") source=("https://downloads.sourceforge.net/nufraw/nufraw-$pkgver.tar.gz" nufraw-iostream.patch nufraw-exiv2-0.27.patch)
sha256sums=('ddfb592a183618c802e990211f6efce75f4801a7708ecc364666f53af25c9f90') sha256sums=('ddfb592a183618c802e990211f6efce75f4801a7708ecc364666f53af25c9f90'
'fd0120af2cfa8783edd3d91a39b638fbb30ced8c692815be230a302bc55a71ad'
'ec7caabbdaa8fb67097bfb72c26a1140754e184e756ec2013863af37eed67220')
prepare() { prepare() {
cd "nufraw-$pkgver" cd "nufraw-$pkgver"
patch -p1 -i ../nufraw-iostream.patch # Add missing include
patch -p1 -i ../nufraw-exiv2-0.27.patch # Fix build with exiv2 0.27 (Gentoo)
autoreconf -fi autoreconf -fi

View file

@ -0,0 +1,25 @@
--- a/nufraw_exiv2.cc
+++ b/nufraw_exiv2.cc
@@ -15,9 +15,7 @@
#include "nufraw.h"
#ifdef HAVE_EXIV2
-#include <exiv2/image.hpp>
-#include <exiv2/easyaccess.hpp>
-#include <exiv2/exif.hpp>
+#include <exiv2/exiv2.hpp>
#include <sstream>
#include <cassert>
@@ -67,7 +65,11 @@
if (exifData.empty()) {
std::string error(uf->filename);
error += ": No Exif data found in the file";
+#if EXIV2_TEST_VERSION(0,27,0)
+ throw Exiv2::Error(Exiv2::kerErrorMessage, error);
+#else
throw Exiv2::Error(1, error);
+#endif
}
/* List of tag names taken from exiv2's printSummary() in actions.cpp */

View file

@ -0,0 +1,10 @@
--- nufraw-0.42/nufraw_exiv2.cc.orig 2019-05-18 08:41:34.220544309 +0000
+++ nufraw-0.42/nufraw_exiv2.cc 2019-05-18 08:41:41.170631700 +0000
@@ -20,6 +20,7 @@
#include <exiv2/exif.hpp>
#include <sstream>
#include <cassert>
+#include <iostream>
/*
* Helper function to copy a string to a buffer, converting it from