mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/linux-tools to 5.9-1
This commit is contained in:
parent
889c523db7
commit
c9f55d40ac
3 changed files with 10 additions and 45 deletions
|
@ -1,39 +0,0 @@
|
|||
From 61bd66f4424d5f216a23c19b1b6133323fc4f6ba Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 14 Jul 2019 21:34:17 -0600
|
||||
Subject: [PATCH] perf: fix debug printf for 32-bit
|
||||
|
||||
---
|
||||
tools/perf/util/session.c | 2 +-
|
||||
tools/perf/util/zstd.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/perf/util/session.c b/tools/perf/util/session.c
|
||||
index 37efa1f43d8b..db34760a07bf 100644
|
||||
--- a/tools/perf/util/session.c
|
||||
+++ b/tools/perf/util/session.c
|
||||
@@ -82,7 +82,7 @@ static int perf_session__process_compressed_event(struct perf_session *session,
|
||||
session->decomp_last = decomp;
|
||||
}
|
||||
|
||||
- pr_debug("decomp (B): %ld to %ld\n", src_size, decomp_size);
|
||||
+ pr_debug("decomp (B): %ld to %ld\n", (long)src_size, (long)decomp_size);
|
||||
|
||||
return 0;
|
||||
}
|
||||
diff --git a/tools/perf/util/zstd.c b/tools/perf/util/zstd.c
|
||||
index d2202392ffdb..290f048963d6 100644
|
||||
--- a/tools/perf/util/zstd.c
|
||||
+++ b/tools/perf/util/zstd.c
|
||||
@@ -100,7 +100,7 @@ size_t zstd_decompress_stream(struct zstd_data *data, void *src, size_t src_size
|
||||
ret = ZSTD_decompressStream(data->dstream, &output, &input);
|
||||
if (ZSTD_isError(ret)) {
|
||||
pr_err("failed to decompress (B): %ld -> %ld, dst_size %ld : %s\n",
|
||||
- src_size, output.size, dst_size, ZSTD_getErrorName(ret));
|
||||
+ (long)src_size, (long)output.size, (long)dst_size, ZSTD_getErrorName(ret));
|
||||
break;
|
||||
}
|
||||
output.dst = dst + output.pos;
|
||||
--
|
||||
2.23.0
|
||||
|
|
@ -5,6 +5,7 @@
|
|||
# - removed numactl dep
|
||||
# - use tarball source
|
||||
# - add GPIO and IIO utilities packages
|
||||
# - build perf with WERROR=0
|
||||
|
||||
pkgbase=linux-tools
|
||||
pkgname=(
|
||||
|
@ -21,7 +22,7 @@ pkgname=(
|
|||
'gpio-utils'
|
||||
'iio-utils'
|
||||
)
|
||||
pkgver=5.7
|
||||
pkgver=5.9
|
||||
pkgrel=1
|
||||
license=('GPL2')
|
||||
arch=('x86_64')
|
||||
|
@ -43,8 +44,7 @@ makedepends+=('ncurses')
|
|||
makedepends+=('python-docutils')
|
||||
groups=("$pkgbase")
|
||||
source=("https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz"
|
||||
# "https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-$pkgver.1.xz"
|
||||
'0001-perf-fix-debug-printf-for-32-bit.patch'
|
||||
"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-$pkgver.1.xz"
|
||||
'cpupower.default'
|
||||
'cpupower.systemd'
|
||||
'cpupower.service'
|
||||
|
@ -52,11 +52,11 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz"
|
|||
'hv_fcopy_daemon.service'
|
||||
'hv_kvp_daemon.service'
|
||||
'hv_vss_daemon.service')
|
||||
sha256sums=('a6fbd4ee903c128367892c2393ee0d9657b6ed3ea90016d4dc6f1f6da20b2330'
|
||||
'8dce2b1e5dec90473677adf289c50745daaa059b9f61487d0bc857b16fdef5ae'
|
||||
sha256sums=('3239a4ee1250bf2048be988cc8cb46c487b2c8a0de5b1b032d38394d5c6b1a06'
|
||||
'7edb7b9d06b02f9b88d868c74ab618baf899c94edb19a73291f640dbea55c312'
|
||||
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
|
||||
'd2e8e5e8b22c6089a91f573aa1c59e442a1f3b67a2c9f047abe3b57d3d6558cc'
|
||||
'fa2560630576464739ede14c9292249f4007f36a684bc378add174fc88394550'
|
||||
'42d2ec9f1d9cc255ee7945a27301478364ef482f5a6ddfc960189f03725ccec2'
|
||||
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
|
||||
'16855c197d2334f820cb190312a5a7fffe9165189db01344a957e582e39e17d8'
|
||||
'b1315cb77a35454e1af9172f821a52e2a0cb18561be05a340d21cf337b01ae61'
|
||||
|
@ -90,6 +90,7 @@ build() {
|
|||
lib=lib/perf \
|
||||
perfexecdir=lib/perf \
|
||||
NO_SDT=1 \
|
||||
WERROR=0 \
|
||||
PYTHON=python \
|
||||
PYTHON_CONFIG=python-config \
|
||||
PERF_VERSION=$pkgver-$pkgrel \
|
||||
|
@ -171,6 +172,7 @@ package_libtraceevent() {
|
|||
cd linux-$pkgver/tools/lib/traceevent
|
||||
install -dm 755 "$pkgdir/usr/lib"
|
||||
install -m 644 libtraceevent.so "$pkgdir/usr/lib"
|
||||
ln -sf libtraceevent.so "$pkgdir/usr/lib/libtraceevent.so.1"
|
||||
}
|
||||
|
||||
package_perf() {
|
||||
|
@ -185,6 +187,7 @@ package_perf() {
|
|||
lib=lib/perf \
|
||||
perfexecdir=lib/perf \
|
||||
NO_SDT=1 \
|
||||
WERROR=0 \
|
||||
PYTHON=python \
|
||||
PYTHON_CONFIG=python-config \
|
||||
PERF_VERSION=$pkgver-$pkgrel \
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
[Unit]
|
||||
Description=Apply cpupower configuration
|
||||
ConditionVirtualization=!container
|
||||
|
||||
[Service]
|
||||
Type=oneshot
|
||||
|
|
Loading…
Reference in a new issue