extra/mesa: fix

This commit is contained in:
Kevin Mihelich 2019-02-05 02:25:39 +00:00
parent f99b960c4f
commit ca145e4505
2 changed files with 41 additions and 2 deletions

View file

@ -0,0 +1,35 @@
From 6c4887f62dcb56eca5fd447f72c16f61628fce54 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 4 Feb 2019 17:54:45 -0700
Subject: [PATCH] Rip out VC4 forced NEON
Breaks with distro-supplied CFLAGS.
---
src/gallium/drivers/vc4/meson.build | 11 -----------
1 file changed, 11 deletions(-)
diff --git a/src/gallium/drivers/vc4/meson.build b/src/gallium/drivers/vc4/meson.build
index 0d7a03cd242..dbf116c2ce1 100644
--- a/src/gallium/drivers/vc4/meson.build
+++ b/src/gallium/drivers/vc4/meson.build
@@ -84,17 +84,6 @@ files_libvc4 = files(
vc4_c_args = []
libvc4_neon = []
-if host_machine.cpu_family() == 'arm'
- libvc4_neon = static_library(
- 'vc4_neon',
- 'vc4_tiling_lt_neon.c',
- include_directories : [
- inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_broadcom
- ],
- c_args : '-mfpu=neon',
- )
- vc4_c_args += '-DUSE_ARM_ASM'
-endif
dep_simpenrose = dependency('simpenrose', required : false)
if dep_simpenrose.found()
--
2.20.1

View file

@ -3,6 +3,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - Removed DRI and Gallium3D drivers/packages for chipsets that don't exist in our ARM devices (intel, radeon, VMware svga).
# - disable assembly and rip out VC4 forced NEON for v6/v7
pkgbase=mesa
pkgname=('libva-mesa-driver' 'mesa-vdpau' 'mesa')
@ -17,9 +18,11 @@ makedepends=('python-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dr
url="https://www.mesa3d.org/"
license=('custom')
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
0001-Rip-out-VC4-forced-NEON.patch
LICENSE)
sha512sums=('cd6214b8bbeb3e3d187139ae1e949684f32f90152e1d7ba8d81222bd088770e28cff7ff165f2ccc41c068950561fe952420c6e54472f7204532a8d8700ff18bb'
'SKIP'
'df13eaff1f3a95821221637c56d482945c42faca789e8bc71c36d0526750863aac891afab9d51ce0a912d7eede5b2af7c14a1c36ebd17c1bde945c3e057b773b'
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
@ -30,11 +33,12 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
prepare() {
cd mesa-${pkgver}
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
}
build() {
[[ $CARCH == "armv7h" ]] && GALLIUM=",etnaviv,imx,tegra"
[[ $CARCH == "armv6h" || $CARCH == "armv7h" || $CARCH == "aarch64" ]] && GALLIUM+=",vc4"
[[ $CARCH == "armv6h" || $CARCH == "armv7h" || $CARCH == "aarch64" ]] && GALLIUM+=",vc4" && MESON_OPT="-D asm=false"
arch-meson mesa-$pkgver build \
-D b_lto=false \
@ -63,7 +67,7 @@ build() {
-D osmesa=gallium \
-D shared-glapi=true \
-D texture-float=true \
-D valgrind=false
-D valgrind=false $MESON_OPT
# Print config
meson configure build