mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-boundary to 3.14.28-1
This commit is contained in:
parent
287411bc7c
commit
ca385406c1
4 changed files with 1256 additions and 794 deletions
|
@ -0,0 +1,52 @@
|
|||
From 05430e77089e48314d9ff8400d8225dc56a4cb8e Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Wed, 24 Sep 2014 01:06:46 +0100
|
||||
Subject: [PATCH 1/2] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). In this case using static inline
|
||||
and removing the NULL version of return_address in return_address.c does
|
||||
the right thing.
|
||||
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
Acked-by: Steven Rostedt <rostedt@goodmis.org>
|
||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
---
|
||||
arch/arm/include/asm/ftrace.h | 2 +-
|
||||
arch/arm/kernel/return_address.c | 5 -----
|
||||
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
|
||||
index f89515a..2bb8cac 100644
|
||||
--- a/arch/arm/include/asm/ftrace.h
|
||||
+++ b/arch/arm/include/asm/ftrace.h
|
||||
@@ -45,7 +45,7 @@ void *return_address(unsigned int);
|
||||
|
||||
#else
|
||||
|
||||
-extern inline void *return_address(unsigned int level)
|
||||
+static inline void *return_address(unsigned int level)
|
||||
{
|
||||
return NULL;
|
||||
}
|
||||
diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
|
||||
index fafedd8..f6aa84d 100644
|
||||
--- a/arch/arm/kernel/return_address.c
|
||||
+++ b/arch/arm/kernel/return_address.c
|
||||
@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
|
||||
#warning "TODO: return_address should use unwind tables"
|
||||
#endif
|
||||
|
||||
-void *return_address(unsigned int level)
|
||||
-{
|
||||
- return NULL;
|
||||
-}
|
||||
-
|
||||
#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
|
||||
|
||||
EXPORT_SYMBOL_GPL(return_address);
|
||||
--
|
||||
2.4.4
|
||||
|
|
@ -0,0 +1,59 @@
|
|||
From da5e08dd912acdf8b7d69b4396ab57c0f52a1576 Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Tue, 3 Sep 2013 22:27:26 -0400
|
||||
Subject: [PATCH 2/2] ARM: LLVMLinux: Change "extern inline" to "static inline"
|
||||
in glue-cache.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). "static inline" is the correct choice
|
||||
instead.
|
||||
|
||||
Author: Behan Webster <behanw@converseincode.com>
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
---
|
||||
arch/arm/include/asm/glue-cache.h | 22 +++++++++++-----------
|
||||
1 file changed, 11 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/glue-cache.h b/arch/arm/include/asm/glue-cache.h
|
||||
index c81adc0..a3c24cd 100644
|
||||
--- a/arch/arm/include/asm/glue-cache.h
|
||||
+++ b/arch/arm/include/asm/glue-cache.h
|
||||
@@ -130,22 +130,22 @@
|
||||
#endif
|
||||
|
||||
#ifndef __ASSEMBLER__
|
||||
-extern inline void nop_flush_icache_all(void) { }
|
||||
-extern inline void nop_flush_kern_cache_all(void) { }
|
||||
-extern inline void nop_flush_kern_cache_louis(void) { }
|
||||
-extern inline void nop_flush_user_cache_all(void) { }
|
||||
-extern inline void nop_flush_user_cache_range(unsigned long a,
|
||||
+static inline void nop_flush_icache_all(void) { }
|
||||
+static inline void nop_flush_kern_cache_all(void) { }
|
||||
+static inline void nop_flush_kern_cache_louis(void) { }
|
||||
+static inline void nop_flush_user_cache_all(void) { }
|
||||
+static inline void nop_flush_user_cache_range(unsigned long a,
|
||||
unsigned long b, unsigned int c) { }
|
||||
|
||||
-extern inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
|
||||
-extern inline int nop_coherent_user_range(unsigned long a,
|
||||
+static inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
|
||||
+static inline int nop_coherent_user_range(unsigned long a,
|
||||
unsigned long b) { return 0; }
|
||||
-extern inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
|
||||
+static inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
|
||||
|
||||
-extern inline void nop_dma_flush_range(const void *a, const void *b) { }
|
||||
+static inline void nop_dma_flush_range(const void *a, const void *b) { }
|
||||
|
||||
-extern inline void nop_dma_map_area(const void *s, size_t l, int f) { }
|
||||
-extern inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
|
||||
+static inline void nop_dma_map_area(const void *s, size_t l, int f) { }
|
||||
+static inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
|
||||
#endif
|
||||
|
||||
#ifndef MULTI_CACHE
|
||||
--
|
||||
2.4.4
|
||||
|
|
@ -4,25 +4,32 @@
|
|||
buildarch=4
|
||||
|
||||
pkgbase=linux-boundary
|
||||
_commit=b1c425eb2b11a1282043a06e55c4683db3bb83b5
|
||||
_commit=f00318b25db64bf19feb7b94c55f520c0a094274
|
||||
_srcname=linux-imx6-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="i.MX6 Nitrogen6X/Sabre Lite"
|
||||
pkgver=3.10.17
|
||||
pkgrel=18
|
||||
pkgver=3.14.28
|
||||
pkgrel=1
|
||||
arch=('armv7h')
|
||||
url="https://github.com/boundarydevices/linux-imx6/tree/boundary-imx_3.10.17_1.0.2_ga"
|
||||
url="https://github.com/boundarydevices/linux-imx6/tree/boundary-imx_3.14.28_1.0.0_ga"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||
options=('!strip')
|
||||
source=("https://github.com/boundarydevices/linux-imx6/archive/${_commit}.tar.gz"
|
||||
'0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch'
|
||||
'0002-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch'
|
||||
'config')
|
||||
md5sums=('13ba39742ed4adf080c5d5770c2e40a7'
|
||||
'8301ac70965fac93cafa9481607caef5')
|
||||
md5sums=('b2e7ff3fa3fbd9438bfa0cc41eb657b4'
|
||||
'a8a3b53a080275c227948d33a9944180'
|
||||
'b373e054b8eb5dffba986bc80b354d23'
|
||||
'98a285241af1b54f81aa7dc312b30ed0')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
git apply ../0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
|
||||
git apply ../0002-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
# add pkgrel to extraversion
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue