mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
removed extra/js52
This commit is contained in:
parent
025abebe03
commit
ca9a83fd98
4 changed files with 0 additions and 205 deletions
|
@ -1,97 +0,0 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove --enable-gold
|
||||
|
||||
pkgname=js52
|
||||
pkgver=52.9.0
|
||||
pkgrel=4
|
||||
pkgdesc="JavaScript interpreter and libraries - Version 52"
|
||||
arch=(x86_64)
|
||||
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
|
||||
license=(MPL)
|
||||
depends=(gcc-libs readline zlib sh)
|
||||
makedepends=(python2 zip autoconf2.13)
|
||||
_relver=${pkgver}esr
|
||||
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz
|
||||
mozjs52-copy-headers.patch
|
||||
mozjs52-disable-mozglue.patch
|
||||
mozjs52-disable-wformat.patch)
|
||||
sha256sums=('c01d09658c53c1b3a496e353a24dad03b26b81d3b1d099abc26a06f81c199dd6'
|
||||
'c5b3a88e4d10ef149aba6fc48d431db54ff266323fa22a5d549028fd794423cc'
|
||||
'5a84f02521f37de873991dd360a4c4bfdbdd2fb4a218e11be73f9cbbf02050e8'
|
||||
'4c5a1662e36c6a5a11db0263bb264d104ff801789d5b6bc6a6104439457afb90')
|
||||
|
||||
prepare() {
|
||||
cd firefox-$_relver
|
||||
mkdir obj
|
||||
|
||||
# https://salsa.debian.org/gnome-team/mozjs52/tree/debian/master/debian/patches
|
||||
patch -Np1 -i ../mozjs52-copy-headers.patch
|
||||
patch -Np1 -i ../mozjs52-disable-mozglue.patch
|
||||
|
||||
# New errors in test code as of GCC 9
|
||||
patch -Np1 -i ../mozjs52-disable-wformat.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
local configure_args=(
|
||||
--prefix=/usr
|
||||
--disable-debug
|
||||
--disable-debug-symbols
|
||||
--disable-jemalloc
|
||||
--disable-strip
|
||||
--enable-optimize="-O2"
|
||||
--enable-pie
|
||||
--enable-posix-nspr-emulation
|
||||
--enable-readline
|
||||
--enable-release
|
||||
--enable-shared-js
|
||||
--enable-tests
|
||||
--with-intl-api
|
||||
--with-system-zlib
|
||||
--without-system-icu
|
||||
) flags=(
|
||||
-fno-delete-null-pointer-checks
|
||||
-fno-strict-aliasing
|
||||
-fno-tree-vrp
|
||||
)
|
||||
|
||||
cd firefox-$_relver/obj
|
||||
|
||||
unset CPPFLAGS
|
||||
CFLAGS+=" ${flags[*]}"
|
||||
CXXFLAGS+=" ${flags[*]}"
|
||||
export CC=gcc CXX=g++ PYTHON=/usr/bin/python2
|
||||
|
||||
touch ../js/src/configure
|
||||
sh ../js/src/configure "${configure_args[@]}"
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
local jstests_extra_args=(
|
||||
--format=none
|
||||
--exclude-random
|
||||
) jittest_extra_args=(
|
||||
--format=none
|
||||
--timeout 300
|
||||
) jittest_test_args=(
|
||||
basic
|
||||
)
|
||||
|
||||
cd firefox-$_relver/obj
|
||||
make -C js/src check-jstests check-jit-test \
|
||||
JSTESTS_EXTRA_ARGS="${jstests_extra_args[*]}" \
|
||||
JITTEST_EXTRA_ARGS="${jittest_extra_args[*]}" \
|
||||
JITTEST_TEST_ARGS="${jittest_test_args[*]}"
|
||||
}
|
||||
|
||||
package() {
|
||||
cd firefox-$_relver/obj
|
||||
make DESTDIR="$pkgdir" install
|
||||
rm "$pkgdir"/usr/lib/*.ajs
|
||||
find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -c a-x {} +
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,30 +0,0 @@
|
|||
From 8b2d7a77bfb4dbd513763501ed7e9722058ee9af Mon Sep 17 00:00:00 2001
|
||||
From: Rico Tzschichholz <ricotz@ubuntu.com>
|
||||
Date: Wed, 5 Jul 2017 22:45:59 -0700
|
||||
Subject: [PATCH] build: Copy headers on install instead of symlinking
|
||||
|
||||
Patch ported forward to mozjs52 by Philip Chimento
|
||||
<philip.chimento@gmail.com>.
|
||||
---
|
||||
python/mozbuild/mozbuild/backend/recursivemake.py | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/python/mozbuild/mozbuild/backend/recursivemake.py b/python/mozbuild/mozbuild/backend/recursivemake.py
|
||||
index 132dcf94..33d489a6 100644
|
||||
--- a/python/mozbuild/mozbuild/backend/recursivemake.py
|
||||
+++ b/python/mozbuild/mozbuild/backend/recursivemake.py
|
||||
@@ -1307,11 +1307,11 @@ def _process_final_target_files(self, obj, files, backend_file):
|
||||
raise Exception("Wildcards are only supported in the filename part of "
|
||||
"srcdir-relative or absolute paths.")
|
||||
|
||||
- install_manifest.add_pattern_symlink(basepath, wild, path)
|
||||
+ install_manifest.add_pattern_copy(basepath, wild, path)
|
||||
else:
|
||||
- install_manifest.add_pattern_symlink(f.srcdir, f, path)
|
||||
+ install_manifest.add_pattern_copy(f.srcdir, f, path)
|
||||
else:
|
||||
- install_manifest.add_symlink(f.full_path, dest)
|
||||
+ install_manifest.add_copy(f.full_path, dest)
|
||||
else:
|
||||
install_manifest.add_optional_exists(dest)
|
||||
backend_file.write('%s_FILES += %s\n' % (
|
|
@ -1,66 +0,0 @@
|
|||
From 7e6d628456af3e99ebcb9a01a27e1461585082a4 Mon Sep 17 00:00:00 2001
|
||||
From: Till Schneidereit <till@tillschneidereit.net>
|
||||
Date: Thu, 1 Oct 2015 12:59:09 +0200
|
||||
Subject: [PATCH] Disable MOZ_GLUE_IN_PROGRAM in stand-alone builds on all
|
||||
platforms
|
||||
|
||||
Otherwise, build fails not being able to find HashBytes.
|
||||
|
||||
Patch ported forward to mozjs52 by Philip Chimento
|
||||
<philip.chimento@gmail.com>.
|
||||
|
||||
https://bugzilla.mozilla.org/show_bug.cgi?id=1176787
|
||||
---
|
||||
js/src/old-configure.in | 23 ++++++++++++++---------
|
||||
mozglue/build/moz.build | 2 +-
|
||||
2 files changed, 15 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/js/src/old-configure.in b/js/src/old-configure.in
|
||||
index 1c5c9e21..ff0617e3 100644
|
||||
--- a/js/src/old-configure.in
|
||||
+++ b/js/src/old-configure.in
|
||||
@@ -1623,16 +1623,21 @@ dnl ========================================================
|
||||
dnl = Enable jemalloc
|
||||
dnl ========================================================
|
||||
|
||||
-case "${OS_TARGET}" in
|
||||
-Android|WINNT|Darwin)
|
||||
+dnl In stand-alone builds we always only want to link executables against mozglue.
|
||||
+if test "$JS_STANDALONE"; then
|
||||
MOZ_GLUE_IN_PROGRAM=
|
||||
- ;;
|
||||
-*)
|
||||
- dnl On !Android !Windows !OSX, we only want to link executables against mozglue
|
||||
- MOZ_GLUE_IN_PROGRAM=1
|
||||
- AC_DEFINE(MOZ_GLUE_IN_PROGRAM)
|
||||
- ;;
|
||||
-esac
|
||||
+else
|
||||
+ case "${OS_TARGET}" in
|
||||
+ Android|WINNT|Darwin)
|
||||
+ MOZ_GLUE_IN_PROGRAM=
|
||||
+ ;;
|
||||
+ *)
|
||||
+ dnl On !Android !Windows !OSX, we only want to link executables against mozglue
|
||||
+ MOZ_GLUE_IN_PROGRAM=1
|
||||
+ AC_DEFINE(MOZ_GLUE_IN_PROGRAM)
|
||||
+ ;;
|
||||
+ esac
|
||||
+fi
|
||||
|
||||
if test "$MOZ_MEMORY"; then
|
||||
if test "x$MOZ_DEBUG" = "x1"; then
|
||||
diff --git a/mozglue/build/moz.build b/mozglue/build/moz.build
|
||||
index d2897477..e3be5a2b 100644
|
||||
--- a/mozglue/build/moz.build
|
||||
+++ b/mozglue/build/moz.build
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
# Build mozglue as a shared lib on Windows, OSX and Android.
|
||||
# If this is ever changed, update MOZ_SHARED_MOZGLUE in browser/installer/Makefile.in
|
||||
-if CONFIG['OS_TARGET'] in ('WINNT', 'Darwin', 'Android'):
|
||||
+if CONFIG['OS_TARGET'] in ('WINNT', 'Darwin', 'Android') and not CONFIG['JS_STANDALONE']:
|
||||
SharedLibrary('mozglue')
|
||||
else:
|
||||
Library('mozglue')
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
diff -u -r firefox-52.9.0esr/js/src/jsapi-tests/moz.build firefox-52.9.0esr-noerror/js/src/jsapi-tests/moz.build
|
||||
--- firefox-52.9.0esr/js/src/jsapi-tests/moz.build 2017-04-11 02:13:16.000000000 +0000
|
||||
+++ firefox-52.9.0esr-noerror/js/src/jsapi-tests/moz.build 2019-06-20 20:10:31.092230735 +0000
|
||||
@@ -147,7 +147,7 @@
|
||||
OS_LIBS += CONFIG['MOZ_ZLIB_LIBS']
|
||||
|
||||
if CONFIG['GNU_CXX']:
|
||||
- CXXFLAGS += ['-Wno-shadow', '-Werror=format']
|
||||
+ CXXFLAGS += ['-Wno-shadow']
|
||||
|
||||
# This is intended as a temporary workaround to enable VS2015.
|
||||
if CONFIG['_MSC_VER']:
|
Loading…
Reference in a new issue