mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
Merge branch 'master' of github.com:archlinuxarm/PKGBUILDs
This commit is contained in:
commit
caa8460b38
3 changed files with 178 additions and 9 deletions
|
@ -3,7 +3,7 @@
|
||||||
buildarch=16
|
buildarch=16
|
||||||
|
|
||||||
pkgname=libcec-rpi
|
pkgname=libcec-rpi
|
||||||
pkgver=2.0.1
|
pkgver=2.0.4
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter with support for raspberry pi"
|
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter with support for raspberry pi"
|
||||||
arch=('armv6h')
|
arch=('armv6h')
|
||||||
|
@ -12,9 +12,9 @@ license=('GPL')
|
||||||
depends=('udev' 'lockdev' 'raspberrypi-firmware')
|
depends=('udev' 'lockdev' 'raspberrypi-firmware')
|
||||||
conflicts=('libcec')
|
conflicts=('libcec')
|
||||||
provides=('libcec')
|
provides=('libcec')
|
||||||
source=("libcec-2.0.1.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/libcec-2.0.1")
|
source=("libcec-2.0.4.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/libcec-2.0.4")
|
||||||
_srcfolder=Pulse-Eight-libcec-6be84fc
|
_srcfolder=Pulse-Eight-libcec-178d498
|
||||||
sha256sums=('3dc6d7080a98dbfddcab4605a1267c24751b4334a95f845583f34d9f24c9269a')
|
sha256sums=('652f8bddf8629eb4d14c93bc97efbeb7406482f69626302c8489df8e1fd8431f')
|
||||||
options=(!libtool)
|
options=(!libtool)
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
# Contributor tomasgroth at yahoo.dk
|
# Contributor tomasgroth at yahoo.dk
|
||||||
# Contributor WarheadsSE <max@warheads.net>
|
# Contributor WarheadsSE <max@warheads.net>
|
||||||
pkgname=xbmc-rbp-git
|
pkgname=xbmc-rbp-git
|
||||||
pkgver=20121011
|
pkgver=20121125
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
buildarch=16
|
buildarch=16
|
||||||
|
|
||||||
|
@ -18,9 +18,9 @@ optdepends=(
|
||||||
'upower: used to trigger suspend functionality'
|
'upower: used to trigger suspend functionality'
|
||||||
'unrar: access compressed files without unpacking them'
|
'unrar: access compressed files without unpacking them'
|
||||||
)
|
)
|
||||||
source=(https://raw.github.com/OpenELEC/OpenELEC.tv/master/packages/mediacenter/xbmc/patches/xbmc-11.0.3-321-texturepacker-hostflags-and-rework.patch)
|
source=(xbmc-ae04d99-321-texturepacker-hostflags-and-rework.patch)
|
||||||
|
|
||||||
md5sums=('87321ce6712439e3584943f5a267ff19')
|
md5sums=('fc6a925a09ba1b13d84daf1121b42ab9')
|
||||||
|
|
||||||
_gitroot="git://github.com/xbmc"
|
_gitroot="git://github.com/xbmc"
|
||||||
_gitname="xbmc"
|
_gitname="xbmc"
|
||||||
|
@ -44,8 +44,8 @@ build() {
|
||||||
# fix lsb_release dependency
|
# fix lsb_release dependency
|
||||||
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
||||||
|
|
||||||
# Patch to fix TexturePacker build. Ignore that parts of the patch doesn't apply.
|
# Patch to fix TexturePacker build.
|
||||||
patch -i ${srcdir}/xbmc-11.0.3-321-texturepacker-hostflags-and-rework.patch -p1 || true
|
patch -i ${srcdir}/xbmc-ae04d99-321-texturepacker-hostflags-and-rework.patch -p1
|
||||||
|
|
||||||
# Bootstrapping XBMC
|
# Bootstrapping XBMC
|
||||||
./bootstrap
|
./bootstrap
|
||||||
|
|
|
@ -0,0 +1,169 @@
|
||||||
|
diff -Naur xbmc-frodo-0ff0d2e/configure.in xbmc-frodo-0ff0d2e.patch/configure.in
|
||||||
|
--- xbmc-frodo-0ff0d2e/configure.in 2012-10-11 15:45:44.000000000 +0200
|
||||||
|
+++ xbmc-frodo-0ff0d2e.patch/configure.in 2012-10-11 16:49:08.872850880 +0200
|
||||||
|
@@ -452,6 +452,12 @@
|
||||||
|
[use_texturepacker=$enableval],
|
||||||
|
[use_texturepacker=auto])
|
||||||
|
|
||||||
|
+AC_ARG_WITH([texturepacker-root],
|
||||||
|
+ [AS_HELP_STRING([--with-texturepacker-root],
|
||||||
|
+ [root dir to search for librarys and includes if building native TexturePacker (default is \$prefix)])],
|
||||||
|
+ [use_texturepacker_root=$withval],
|
||||||
|
+ [use_texturepacker_root=$prefix])
|
||||||
|
+
|
||||||
|
AC_ARG_WITH([lirc-device],
|
||||||
|
[AS_HELP_STRING([--with-lirc-device=file],
|
||||||
|
[specify the default LIRC device (default is /dev/lircd)])],
|
||||||
|
@@ -2000,13 +2006,13 @@
|
||||||
|
|
||||||
|
USE_TEXTUREPACKER_NATIVE=0
|
||||||
|
if test "x$use_texturepacker" != "xno"; then
|
||||||
|
- final_message="$final_message\n TexturePacker:Yes"
|
||||||
|
USE_TEXTUREPACKER=1
|
||||||
|
- if test "x$use_texturepacker_native" = "xyes"; then
|
||||||
|
+ if test "x$cross_compiling" = "xyes"; then
|
||||||
|
USE_TEXTUREPACKER_NATIVE=1
|
||||||
|
- if [[ ! -d "$USE_TEXTUREPACKER_NATIVE_ROOT" ]]; then
|
||||||
|
- USE_TEXTUREPACKER_NATIVE_ROOT=
|
||||||
|
- fi
|
||||||
|
+ USE_TEXTUREPACKER_NATIVE_ROOT="$use_texturepacker_root"
|
||||||
|
+ final_message="$final_message\n TexturePacker:Native ($USE_TEXTUREPACKER_NATIVE_ROOT)"
|
||||||
|
+ else
|
||||||
|
+ final_message="$final_message\n TexturePacker:Yes"
|
||||||
|
fi
|
||||||
|
else
|
||||||
|
final_message="$final_message\n TexturePacker:No"
|
||||||
|
diff -Naur xbmc-frodo-0ff0d2e/lib/libsquish/Makefile.in xbmc-frodo-0ff0d2e.patch/lib/libsquish/Makefile.in
|
||||||
|
--- xbmc-frodo-0ff0d2e/lib/libsquish/Makefile.in 2012-10-11 15:47:26.000000000 +0200
|
||||||
|
+++ xbmc-frodo-0ff0d2e.patch/lib/libsquish/Makefile.in 2012-10-11 16:49:08.873850900 +0200
|
||||||
|
@@ -11,26 +11,25 @@
|
||||||
|
singlecolourfit.cpp \
|
||||||
|
squish.cpp
|
||||||
|
|
||||||
|
-CXXFLAGS+=-I.
|
||||||
|
-
|
||||||
|
-LIB=libsquish.a
|
||||||
|
-
|
||||||
|
-ifeq (@USE_TEXTUREPACKER_NATIVE@,1)
|
||||||
|
-NATIVE_LIB=libsquish-native.so
|
||||||
|
-CLEAN_FILES+=$(NATIVE_LIB)
|
||||||
|
+LIB = libsquish.a
|
||||||
|
+NATIVE_LIB = libsquish-native.so
|
||||||
|
+CLEAN_FILES += $(NATIVE_LIB)
|
||||||
|
+
|
||||||
|
+HOST_CXX ?= g++
|
||||||
|
+CXXFLAGS += -I.
|
||||||
|
+HOST_CXXFLAGS += -I.
|
||||||
|
|
||||||
|
ifeq ($(findstring Darwin,$(shell uname -s)),Darwin)
|
||||||
|
-NATIVE_ARCH=@DARWIN_NATIVE_ARCH@
|
||||||
|
+ HOST_CXXFLAGS += @DARWIN_NATIVE_ARCH@
|
||||||
|
endif
|
||||||
|
|
||||||
|
-all: $(LIB) $(NATIVE_LIB)
|
||||||
|
+$(LIB): $(SRCS)
|
||||||
|
# TexturePacker links to libsquish and needs to run on build system, so make a native flavor.
|
||||||
|
$(NATIVE_LIB): $(SRCS)
|
||||||
|
ifeq ($(findstring Darwin,$(shell uname -s)),Darwin)
|
||||||
|
- g++ $(NATIVE_ARCH) -I. $(SRCS) -dynamiclib -install_name `pwd`/libsquish-native.so -o $@
|
||||||
|
+ $(HOST_CXX) $(HOST_CXXFLAGS) $(SRCS) -dynamiclib -install_name `pwd`/libsquish-native.so -o $@
|
||||||
|
else
|
||||||
|
- g++ -I. $(SRCS) -shared -fPIC -Wl,-soname,`pwd`/libsquish-native.so -o $@
|
||||||
|
-endif
|
||||||
|
+ $(HOST_CXX) $(HOST_CXXFLAGS) $(SRCS) -shared -fPIC -Wl,-soname,`pwd`/libsquish-native.so -o $@
|
||||||
|
endif
|
||||||
|
|
||||||
|
include ../../Makefile.include
|
||||||
|
diff -Naur xbmc-frodo-0ff0d2e/tools/TexturePacker/Makefile.in xbmc-frodo-0ff0d2e.patch/tools/TexturePacker/Makefile.in
|
||||||
|
--- xbmc-frodo-0ff0d2e/tools/TexturePacker/Makefile.in 2012-10-11 15:47:05.000000000 +0200
|
||||||
|
+++ xbmc-frodo-0ff0d2e.patch/tools/TexturePacker/Makefile.in 2012-10-11 16:49:08.874850920 +0200
|
||||||
|
@@ -1,56 +1,54 @@
|
||||||
|
-DEFINES += -D_LINUX -DUSE_LZO_PACKING
|
||||||
|
+DEFINES += -D_LINUX -DUSE_LZO_PACKING
|
||||||
|
ifneq ($(or $(findstring powerpc,@ARCH@),$(findstring ppc, @ARCH@)),)
|
||||||
|
-DEFINES += -DHOST_BIGENDIAN
|
||||||
|
+DEFINES += -DHOST_BIGENDIAN
|
||||||
|
endif
|
||||||
|
|
||||||
|
-CXXFLAGS+= \
|
||||||
|
+SRCS = \
|
||||||
|
+ md5.cpp \
|
||||||
|
+ SDL_anigif.cpp \
|
||||||
|
+ XBTFWriter.cpp \
|
||||||
|
+ XBMCTex.cpp \
|
||||||
|
+ @abs_top_srcdir@/xbmc/guilib/XBTF.cpp
|
||||||
|
+
|
||||||
|
+TARGET = TexturePacker
|
||||||
|
+CLEAN_FILES = $(TARGET)
|
||||||
|
+
|
||||||
|
+all: $(TARGET)
|
||||||
|
+
|
||||||
|
+HOST_CXX ?= g++
|
||||||
|
+HOST_ROOT_PATH = @USE_TEXTUREPACKER_NATIVE_ROOT@
|
||||||
|
+
|
||||||
|
+LIBS += -lSDL_image -lSDL -llzo2
|
||||||
|
+LIBS += -L@abs_top_srcdir@/lib/libsquish -lsquish
|
||||||
|
+HOST_LIBS += -L$(HOST_ROOT_PATH)/lib -lSDL_image -lSDL -llzo2
|
||||||
|
+HOST_LIBS += -L@abs_top_srcdir@/lib/libsquish -lsquish-native
|
||||||
|
+
|
||||||
|
+CXXFLAGS += \
|
||||||
|
-I. \
|
||||||
|
-I@abs_top_srcdir@/lib \
|
||||||
|
-I@abs_top_srcdir@/xbmc \
|
||||||
|
-I@abs_top_srcdir@/xbmc/linux
|
||||||
|
|
||||||
|
-RPATH=-Wl,-rpath=$(NATIVE_ROOT_PATH)/lib
|
||||||
|
+HOST_CXXFLAGS += \
|
||||||
|
+ -I. \
|
||||||
|
+ -I@abs_top_srcdir@/lib \
|
||||||
|
+ -I@abs_top_srcdir@/xbmc \
|
||||||
|
+ -I@abs_top_srcdir@/xbmc/linux \
|
||||||
|
+ -I$(HOST_ROOT_PATH)/include
|
||||||
|
+
|
||||||
|
+RPATH=-Wl,-rpath=$(HOST_ROOT_PATH)/lib
|
||||||
|
|
||||||
|
-ifeq (@USE_TEXTUREPACKER_NATIVE@,1)
|
||||||
|
-NATIVE_ROOT_PATH=@USE_TEXTUREPACKER_NATIVE_ROOT@
|
||||||
|
-ifdef NATIVE_ROOT_PATH
|
||||||
|
ifeq ($(findstring Darwin,$(shell uname -s)),Darwin)
|
||||||
|
DEFINES += -DTARGET_DARWIN
|
||||||
|
NATIVE_ARCH=@DARWIN_NATIVE_ARCH@
|
||||||
|
RPATH=
|
||||||
|
endif
|
||||||
|
-NATIVE_CXXFLAGS+= -I. \
|
||||||
|
- -I$(NATIVE_ROOT_PATH)/include \
|
||||||
|
- -I@abs_top_srcdir@/lib \
|
||||||
|
- -I@abs_top_srcdir@/xbmc \
|
||||||
|
- -I@abs_top_srcdir@/xbmc/linux
|
||||||
|
-NATIVE_LIBS += -L$(NATIVE_ROOT_PATH)/lib
|
||||||
|
-endif
|
||||||
|
-NATIVE_LIBS += -lSDL_image -lSDL -llzo2
|
||||||
|
-NATIVE_LIBS += -L@abs_top_srcdir@/lib/libsquish -lsquish-native
|
||||||
|
-else
|
||||||
|
-LIBS += -L@abs_top_srcdir@/lib/libsquish -lsquish
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
-LIBS += -lSDL_image -lSDL -llzo2
|
||||||
|
-
|
||||||
|
-SRCS = \
|
||||||
|
- md5.cpp \
|
||||||
|
- SDL_anigif.cpp \
|
||||||
|
- XBTFWriter.cpp \
|
||||||
|
- XBMCTex.cpp \
|
||||||
|
- @abs_top_srcdir@/xbmc/guilib/XBTF.cpp
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-TARGET = TexturePacker
|
||||||
|
-CLEAN_FILES=$(TARGET)
|
||||||
|
-
|
||||||
|
-all: $(TARGET)
|
||||||
|
|
||||||
|
ifeq (@USE_TEXTUREPACKER_NATIVE@,1)
|
||||||
|
# TexturePacker run native on build system, build it with native tools
|
||||||
|
$(TARGET): $(SRCS) @abs_top_srcdir@/xbmc/guilib/XBTF.h
|
||||||
|
- g++ $(DEFINES) $(NATIVE_ARCH) $(NATIVE_CXXFLAGS) $(SRCS) $(NATIVE_LIBS) $(RPATH) -o $(TARGET)
|
||||||
|
+ make -C @abs_top_srcdir@/lib/libsquish libsquish-native.so
|
||||||
|
+ $(HOST_CXX) $(DEFINES) $(NATIVE_ARCH) $(HOST_CXXFLAGS) $(SRCS) $(HOST_LIBS) $(RPATH) -o $(TARGET)
|
||||||
|
clean:
|
||||||
|
rm -f $(TARGET)
|
||||||
|
else
|
Loading…
Reference in a new issue