community/tightvnc to 1.3.10-7

This commit is contained in:
Kevin Mihelich 2012-03-17 15:35:34 -04:00
parent 4c36350ba5
commit caf03352f0
2 changed files with 26 additions and 34 deletions

View file

@ -1,5 +1,6 @@
# $Id: PKGBUILD 150962 2012-02-24 10:13:24Z pierre $
# Maintainer: Paul Mattal <paul@archlinux.org>
# $Id: PKGBUILD 67960 2012-03-16 12:47:31Z arodseth $
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Paul Mattal <paul@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to enable ARM building, contributed by vahokif
@ -8,44 +9,48 @@ plugrel=1
pkgname=tightvnc
pkgver=1.3.10
pkgrel=6
pkgrel=7
pkgdesc="VNC Unix server && viewer"
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.tightvnc.com"
depends=('libjpeg' 'zlib' 'libxaw' 'libxp' 'xorg-xauth')
makedepends=('imake')
depends=('libjpeg' 'zlib' 'libxaw' 'libxp' 'xorg-xauth' 'perl')
makedepends=('imake' 'setconf')
conflicts=('vnc')
options=('!makeflags')
source=("http://downloads.sf.net/sourceforge/vnc-tight/$pkgname-${pkgver}_unixsrc.tar.bz2"
'tightvnc-fontpath-xcolors.patch'
'http://people.csail.mit.edu/jaffer/Color/rgb.txt'
'tightvnc-1.3.10-arm.patch')
md5sums=('397b35faad32d5246b6d44b142f8304f'
'21aa7f3376ec3c608ff22d199a19c601'
'0c10d9cd275d90ba5f13ffe3109443a2')
sha256sums=('f48c70fea08d03744ae18df6b1499976362f16934eda3275cead87baad585c0d'
'af6c056a95ae725f98534db22b9a4916d17f2356fdca84a4a038211a82fa8a73'
'8ee519594642ab9309f9f7a91bcd6938f2117a23452d19edf78259b46381bd40')
build() {
cd $srcdir/vnc_unixsrc
patch -Np1 -i ../tightvnc-fontpath-xcolors.patch
patch -Np1 -i ../tightvnc-1.3.10-arm.patch
sed -i 's|/usr/local/|/usr/share/|' vncserver
patch -Np1 -i "${srcdir}"/tightvnc-1.3.10-arm.patch
setconf tightvncserver.conf '$colorPath' \"/usr/share/tightvnc\"\;
setconf vncserver '$colorPath' \"/usr/share/tightvnc\"\;
setconf vncserver '$vncClasses' \"/usr/share/tightvnc\"\;
setconf vncserver '$fontPath' \"/usr/share/fonts/misc/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/Type1/\"\;
xmkmf
make World
cd Xvnc
./configure
sed 's|PROTO_DEFINES =|PROTO_DEFINES = -D_XOPEN_SOURCE=500L|' \
-i programs/Xserver/os/Makefile lib/font/fc/Makefile
setconf programs/Xserver/os/Makefile PROTO_DEFINES "-D_XOPEN_SOURCE=500L"
setconf lib/font/fc/Makefile PROTO_DEFINES "-D_XOPEN_SOURCE=500L"
make
}
package() {
cd $srcdir/vnc_unixsrc
mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/man/man1
./vncinstall $pkgdir/usr/bin $pkgdir/usr/share/man
cd "$srcdir/vnc_unixsrc"
# install java classes
mkdir -p $pkgdir/usr/share/vnc/classes
install -Dm644 $srcdir/vnc_unixsrc/classes/* \
$pkgdir/usr/share/vnc/classes
mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1"
./vncinstall "$pkgdir/usr/bin" "$pkgdir/usr/share/man"
mkdir -p "$pkgdir/usr/share/$pkgname"
install -Dm644 "$srcdir/vnc_unixsrc/classes/"* \
"$pkgdir/usr/share/$pkgname"
install -Dm644 "$srcdir/rgb.txt" "$pkgdir/usr/share/$pkgname/rgb.txt"
}
# vim:set ts=2 sw=2 et:

View file

@ -1,13 +0,0 @@
diff -urN vnc_unixsrc/vncserver vnc_unixsrc.fixed/vncserver
--- vnc_unixsrc/vncserver 2009-02-11 23:27:18.000000000 -0500
+++ vnc_unixsrc.fixed/vncserver 2009-04-23 21:46:46.000000000 -0400
@@ -34,7 +34,8 @@
$desktopName = "X";
$vncClasses = "/usr/local/vnc/classes";
$vncUserDir = "$ENV{HOME}/.vnc";
-$fontPath = "unix/:7100";
+$fontPath = "/usr/share/fonts/misc/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/Type1/";
+$colorPath = "/usr/share/X11/rgb";
$authType = "-rfbauth $vncUserDir/passwd";
# Read configuration from the system-wide and user files if present.