mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-kirkwood esata sheevaplug fix SD write-protect always on
This commit is contained in:
parent
2ca1da7e7e
commit
caf60198b2
3 changed files with 50 additions and 47 deletions
|
@ -9,7 +9,7 @@ pkgname=('linux-kirkwood' 'linux-headers-kirkwood')
|
|||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.9.4
|
||||
pkgver=${_basekernel}
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
cryptover=1.6
|
||||
bfqver=v6r1
|
||||
arch=('arm')
|
||||
|
@ -32,7 +32,7 @@ source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.bz2
|
|||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/$(echo $_basekernel |cut -c 1-3).0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-$(echo $_basekernel |cut -c 1-3).0.patch")
|
||||
|
||||
md5sums=('06e3f307db4ccf7e31775e2903bb973a'
|
||||
'a47687b9b52ec74bf833851b918fa8b5'
|
||||
'1cf669d8e55b2a25590f37e8106723f8'
|
||||
'f5d3635da03cb45904bedd69b47133de'
|
||||
'd699018dcf0cd8850743daa605c7ab66'
|
||||
'73e81c21600fe1bab1baffa537bb3dbe'
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
diff -ruN a/arch/arm/boot/dts/kirkwood-ts219.dtsi b/arch/arm/boot/dts/kirkwood-ts219.dtsi
|
||||
--- a/arch/arm/boot/dts/kirkwood-ts219.dtsi 2013-05-11 08:19:28.000000000 -0600
|
||||
--- a/arch/arm/boot/dts/kirkwood-ts219.dtsi 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/boot/dts/kirkwood-ts219.dtsi 1969-12-31 17:00:00.000000000 -0700
|
||||
@@ -1,78 +0,0 @@
|
||||
-/include/ "kirkwood.dtsi"
|
||||
|
@ -81,8 +81,8 @@ diff -ruN a/arch/arm/boot/dts/kirkwood-ts219.dtsi b/arch/arm/boot/dts/kirkwood-t
|
|||
- };
|
||||
-};
|
||||
diff -ruN a/arch/arm/mach-kirkwood/common.h b/arch/arm/mach-kirkwood/common.h
|
||||
--- a/arch/arm/mach-kirkwood/common.h 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/common.h 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/arch/arm/mach-kirkwood/common.h 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/common.h 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -77,12 +77,6 @@
|
||||
static inline void dnskw_init(void) {};
|
||||
#endif
|
||||
|
@ -110,8 +110,8 @@ diff -ruN a/arch/arm/mach-kirkwood/common.h b/arch/arm/mach-kirkwood/common.h
|
|||
void lsxl_init(void);
|
||||
#else
|
||||
diff -ruN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/dockstar-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -28,6 +28,10 @@
|
||||
.offset = 0,
|
||||
.size = SZ_1M
|
||||
|
@ -157,7 +157,7 @@ diff -ruN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/doc
|
|||
|
||||
diff -ruN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/goflexhome-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/goflexhome-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,124 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/goflexhome-setup.c
|
||||
|
@ -285,7 +285,7 @@ diff -ruN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/g
|
|||
+
|
||||
diff -ruN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/goflexnet-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,177 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
|
||||
|
@ -465,8 +465,8 @@ diff -ruN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/go
|
|||
+MACHINE_END
|
||||
+
|
||||
diff -ruN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/guruplug-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -59,22 +59,24 @@
|
||||
|
||||
static struct gpio_led guruplug_led_pins[] = {
|
||||
|
@ -498,7 +498,7 @@ diff -ruN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/gur
|
|||
},
|
||||
diff -ruN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/iconnect-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/iconnect-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/iconnect-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/iconnect-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,204 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/iconnect-setup.c
|
||||
|
@ -706,7 +706,7 @@ diff -ruN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/ico
|
|||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/mach-kirkwood/ionics-stratus-setup.c b/arch/arm/mach-kirkwood/ionics-stratus-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/ionics-stratus-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/ionics-stratus-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/ionics-stratus-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,137 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/ionics-stratus-setup.c
|
||||
|
@ -846,8 +846,8 @@ diff -ruN a/arch/arm/mach-kirkwood/ionics-stratus-setup.c b/arch/arm/mach-kirkwo
|
|||
+ .restart = kirkwood_restart,
|
||||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
||||
--- a/arch/arm/mach-kirkwood/Kconfig 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/arch/arm/mach-kirkwood/Kconfig 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -72,12 +72,6 @@
|
||||
Say 'Y' here if you want your kernel to support the
|
||||
Marvell DreamPlug (Flattened Device Tree).
|
||||
|
@ -971,8 +971,8 @@ diff -ruN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
|||
|
||||
endif
|
||||
diff -ruN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
|
||||
--- a/arch/arm/mach-kirkwood/Makefile 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Makefile 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/arch/arm/mach-kirkwood/Makefile 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Makefile 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -8,6 +8,14 @@
|
||||
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
|
||||
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
|
||||
|
@ -1017,7 +1017,7 @@ diff -ruN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
|
|||
obj-$(CONFIG_MACH_TOPKICK_DT) += board-usi_topkick.o
|
||||
diff -ruN a/arch/arm/mach-kirkwood/nas6210-setup.c b/arch/arm/mach-kirkwood/nas6210-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/nas6210-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/nas6210-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/nas6210-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,186 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/nas6210-setup.c
|
||||
|
@ -1207,7 +1207,7 @@ diff -ruN a/arch/arm/mach-kirkwood/nas6210-setup.c b/arch/arm/mach-kirkwood/nas6
|
|||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/mach-kirkwood/nsa310-setup.c b/arch/arm/mach-kirkwood/nsa310-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/nsa310-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/nsa310-setup.c 2013-05-17 23:37:56.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/nsa310-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,359 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/nsa310-setup.c
|
||||
|
@ -1570,7 +1570,7 @@ diff -ruN a/arch/arm/mach-kirkwood/nsa310-setup.c b/arch/arm/mach-kirkwood/nsa31
|
|||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/mach-kirkwood/nsa320-setup.c b/arch/arm/mach-kirkwood/nsa320-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/nsa320-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/nsa320-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/nsa320-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,305 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/nsa320-setup.c
|
||||
|
@ -1879,7 +1879,7 @@ diff -ruN a/arch/arm/mach-kirkwood/nsa320-setup.c b/arch/arm/mach-kirkwood/nsa32
|
|||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/mach-kirkwood/pogo_e02-setup.c b/arch/arm/mach-kirkwood/pogo_e02-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/pogo_e02-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/pogo_e02-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/pogo_e02-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,115 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/pogo_e02-setup.c
|
||||
|
@ -1998,7 +1998,7 @@ diff -ruN a/arch/arm/mach-kirkwood/pogo_e02-setup.c b/arch/arm/mach-kirkwood/pog
|
|||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/pogoplugv4-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/pogoplugv4-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/pogoplugv4-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/pogoplugv4-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,195 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/pogoplugv4-setup.c
|
||||
|
@ -2196,8 +2196,8 @@ diff -ruN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/p
|
|||
+ .restart = kirkwood_restart,
|
||||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/sheevaplug-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2013-05-30 22:46:22.000000000 -0600
|
||||
@@ -43,7 +43,7 @@
|
||||
.phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
||||
};
|
||||
|
@ -2207,15 +2207,17 @@ diff -ruN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/s
|
|||
.n_ports = 2,
|
||||
};
|
||||
|
||||
@@ -51,7 +51,7 @@
|
||||
@@ -51,8 +51,8 @@
|
||||
/* unfortunately the CD signal has not been connected */
|
||||
};
|
||||
|
||||
-static struct mvsdio_platform_data sheeva_esata_mvsdio_data = {
|
||||
- .gpio_write_protect = 44, /* MPP44 used as SD write protect */
|
||||
+static struct mvsdio_platform_data esata_sheevaplug_mvsdio_data = {
|
||||
.gpio_write_protect = 44, /* MPP44 used as SD write protect */
|
||||
+ .gpio_write_protect = -1, /* (disable - does not work on 3.9+) MPP44 used as SD write protect */
|
||||
.gpio_card_detect = 47, /* MPP47 used as SD card detect */
|
||||
};
|
||||
|
||||
@@ -64,7 +64,13 @@
|
||||
.active_low = 1,
|
||||
},
|
||||
|
@ -2244,7 +2246,8 @@ diff -ruN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/s
|
|||
-static unsigned int sheeva_esata_mpp_config[] __initdata = {
|
||||
+static unsigned int esata_sheevaplug_mpp_config[] __initdata = {
|
||||
MPP29_GPIO, /* USB Power Enable */
|
||||
MPP44_GPIO, /* SD Write Protect */
|
||||
- MPP44_GPIO, /* SD Write Protect */
|
||||
+ //MPP44_GPIO, /* SD Write Protect */
|
||||
MPP47_GPIO, /* SD Card Detect */
|
||||
- MPP49_GPIO, /* LED Green */
|
||||
+ MPP46_GPIO, /* LED Red */
|
||||
|
@ -2278,7 +2281,7 @@ diff -ruN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/s
|
|||
|
||||
diff -ruN a/arch/arm/mach-kirkwood/topkick-setup.c b/arch/arm/mach-kirkwood/topkick-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/topkick-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/topkick-setup.c 2013-05-17 23:35:46.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/topkick-setup.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,165 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/topkick-setup.c
|
||||
|
@ -2446,8 +2449,8 @@ diff -ruN a/arch/arm/mach-kirkwood/topkick-setup.c b/arch/arm/mach-kirkwood/topk
|
|||
+ .restart = kirkwood_restart,
|
||||
+MACHINE_END
|
||||
diff -ruN a/arch/arm/plat-orion/common.c b/arch/arm/plat-orion/common.c
|
||||
--- a/arch/arm/plat-orion/common.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/arch/arm/plat-orion/common.c 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/arch/arm/plat-orion/common.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/arch/arm/plat-orion/common.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -253,7 +253,9 @@
|
||||
/*****************************************************************************
|
||||
* GE00
|
||||
|
@ -2460,8 +2463,8 @@ diff -ruN a/arch/arm/plat-orion/common.c b/arch/arm/plat-orion/common.c
|
|||
static struct resource orion_ge00_shared_resources[] = {
|
||||
{
|
||||
diff -ruN a/drivers/ata/sata_mv.c b/drivers/ata/sata_mv.c
|
||||
--- a/drivers/ata/sata_mv.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/drivers/ata/sata_mv.c 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/drivers/ata/sata_mv.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/drivers/ata/sata_mv.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -71,6 +71,7 @@
|
||||
#include <scsi/scsi_cmnd.h>
|
||||
#include <scsi/scsi_device.h>
|
||||
|
@ -2480,8 +2483,8 @@ diff -ruN a/drivers/ata/sata_mv.c b/drivers/ata/sata_mv.c
|
|||
int using_ncq = ((pp->pp_flags & MV_PP_FLAG_NCQ_EN) != 0);
|
||||
if (want_ncq != using_ncq)
|
||||
diff -ruN a/drivers/hwmon/Kconfig b/drivers/hwmon/Kconfig
|
||||
--- a/drivers/hwmon/Kconfig 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/drivers/hwmon/Kconfig 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/drivers/hwmon/Kconfig 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/drivers/hwmon/Kconfig 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -1462,6 +1462,19 @@
|
||||
help
|
||||
Support for the A/D converter on MC13783 and MC13892 PMIC.
|
||||
|
@ -2503,8 +2506,8 @@ diff -ruN a/drivers/hwmon/Kconfig b/drivers/hwmon/Kconfig
|
|||
|
||||
comment "ACPI drivers"
|
||||
diff -ruN a/drivers/hwmon/Makefile b/drivers/hwmon/Makefile
|
||||
--- a/drivers/hwmon/Makefile 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/drivers/hwmon/Makefile 2013-05-17 23:35:46.000000000 -0600
|
||||
--- a/drivers/hwmon/Makefile 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/drivers/hwmon/Makefile 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -102,6 +102,7 @@
|
||||
obj-$(CONFIG_SENSORS_MAX6650) += max6650.o
|
||||
obj-$(CONFIG_SENSORS_MAX6697) += max6697.o
|
||||
|
@ -2515,7 +2518,7 @@ diff -ruN a/drivers/hwmon/Makefile b/drivers/hwmon/Makefile
|
|||
obj-$(CONFIG_SENSORS_PC87360) += pc87360.o
|
||||
diff -ruN a/drivers/hwmon/nsa3xx-hwmon.c b/drivers/hwmon/nsa3xx-hwmon.c
|
||||
--- a/drivers/hwmon/nsa3xx-hwmon.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/drivers/hwmon/nsa3xx-hwmon.c 2013-05-17 23:35:47.000000000 -0600
|
||||
+++ b/drivers/hwmon/nsa3xx-hwmon.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,251 @@
|
||||
+/*
|
||||
+ * drivers/hwmon/nsa3xx-hwmon.c
|
||||
|
@ -2769,8 +2772,8 @@ diff -ruN a/drivers/hwmon/nsa3xx-hwmon.c b/drivers/hwmon/nsa3xx-hwmon.c
|
|||
+MODULE_LICENSE("GPL");
|
||||
+MODULE_ALIAS("platform:nsa3xx-hwmon");
|
||||
diff -ruN a/drivers/leds/Kconfig b/drivers/leds/Kconfig
|
||||
--- a/drivers/leds/Kconfig 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/drivers/leds/Kconfig 2013-05-17 23:35:47.000000000 -0600
|
||||
--- a/drivers/leds/Kconfig 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/drivers/leds/Kconfig 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -506,7 +506,6 @@
|
||||
|
||||
config LEDS_TRIGGER_IDE_DISK
|
||||
|
@ -2780,8 +2783,8 @@ diff -ruN a/drivers/leds/Kconfig b/drivers/leds/Kconfig
|
|||
help
|
||||
This allows LEDs to be controlled by IDE disk activity.
|
||||
diff -ruN a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
|
||||
--- a/drivers/mmc/core/core.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/drivers/mmc/core/core.c 2013-05-17 23:35:47.000000000 -0600
|
||||
--- a/drivers/mmc/core/core.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/drivers/mmc/core/core.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -785,7 +785,7 @@
|
||||
*/
|
||||
limit_us = 3000000;
|
||||
|
@ -2792,8 +2795,8 @@ diff -ruN a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
|
|||
/*
|
||||
* SDHC cards always use these fixed values.
|
||||
diff -ruN a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
|
||||
--- a/drivers/mmc/core/sd.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/drivers/mmc/core/sd.c 2013-05-17 23:35:47.000000000 -0600
|
||||
--- a/drivers/mmc/core/sd.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/drivers/mmc/core/sd.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -355,6 +355,15 @@
|
||||
return -ENOMEM;
|
||||
}
|
||||
|
@ -2811,8 +2814,8 @@ diff -ruN a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
|
|||
if (err)
|
||||
goto out;
|
||||
diff -ruN a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||
--- a/drivers/mmc/host/mvsdio.c 2013-05-11 08:19:28.000000000 -0600
|
||||
+++ b/drivers/mmc/host/mvsdio.c 2013-05-17 23:35:47.000000000 -0600
|
||||
--- a/drivers/mmc/host/mvsdio.c 2013-05-24 12:45:59.000000000 -0600
|
||||
+++ b/drivers/mmc/host/mvsdio.c 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <linux/of_irq.h>
|
||||
#include <linux/mmc/host.h>
|
||||
|
@ -2831,7 +2834,7 @@ diff -ruN a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
|||
|
||||
diff -ruN a/include/linux/nsa3xx-hwmon.h b/include/linux/nsa3xx-hwmon.h
|
||||
--- a/include/linux/nsa3xx-hwmon.h 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/include/linux/nsa3xx-hwmon.h 2013-05-17 23:35:47.000000000 -0600
|
||||
+++ b/include/linux/nsa3xx-hwmon.h 2013-05-30 22:44:14.000000000 -0600
|
||||
@@ -0,0 +1,21 @@
|
||||
+/*
|
||||
+ * include/linux/nsa3xx.hwmon.h
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-kirkwood
|
||||
KERNEL_VERSION=3.9.1-1-ARCH
|
||||
KERNEL_VERSION=3.9.4-2-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
Loading…
Reference in a new issue