mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/gitea to 1.9.0-1
This commit is contained in:
parent
733729daaf
commit
cb00bdb7d3
4 changed files with 20 additions and 78 deletions
|
@ -7,14 +7,14 @@
|
|||
# - don't check repo signature until author puts his keys on keyservers
|
||||
|
||||
pkgname=gitea
|
||||
pkgver=1.8.3
|
||||
pkgver=1.9.0
|
||||
pkgrel=1
|
||||
pkgdesc="Painless self-hosted Git service. Community managed fork of Gogs."
|
||||
arch=(x86_64)
|
||||
url="https://gitea.io"
|
||||
license=(MIT)
|
||||
depends=(git)
|
||||
makedepends=(go-pie go-bindata dep)
|
||||
makedepends=(go-pie)
|
||||
optdepends=(
|
||||
'mariadb: MariaDB support'
|
||||
'memcached: MemCached support'
|
||||
|
@ -25,46 +25,36 @@ optdepends=(
|
|||
'sqlite: SQLite support'
|
||||
)
|
||||
backup=('etc/gitea/app.ini')
|
||||
_tag=2b76566c63f0d3d820016259a21aca4cb94bc78b # git rev-parse v${pkgver}
|
||||
_tag=3121f8d226ecf2df940c417008d1cf10070067e9 # git rev-parse v${pkgver}
|
||||
source=("git+https://github.com/go-gitea/gitea.git#tag=${_tag}"
|
||||
gitea.tmpfiles
|
||||
gitea.service
|
||||
gitea.sysusers
|
||||
gitea-arch-defaults.patch
|
||||
gitea-ldflags.patch)
|
||||
gitea-arch-defaults.patch)
|
||||
sha256sums=('SKIP'
|
||||
'1521fd7edc3830c695698ffe9835709f1408040b5ec989f07410972c894fa8ba'
|
||||
'7789b3f6699b9e111fa080226047cdc765e55ff49a3f72aac989c11c06c3e7e0'
|
||||
'2abc51ccd0086bb996194bb7fb241a3f26d84f518417c872b66a3db8970da7e4'
|
||||
'ab0183aeee92d127819b033cbe0b9eab2e1072fb67a0a20e838d911138799b70'
|
||||
'2dd05c2ec8d5b17332525fe176e40df9893aa632f48525f9d5df98e05027aebf')
|
||||
'5eb47d104acd2e4f8c83bfc27c77b98fcfabcab492ffb2c91675062ecd1706ad')
|
||||
validpgpkeys=(8C4033A23895237CB27D52D9D9B5613BEB813F99 # Matti Ranta <matti@mdranta.net> old RSA2048, retrieved from https://github.com/techknowlogick.gpg
|
||||
B56E3C7437A49E136862F5DE9D8A57ADAA232E95 # Matti Ranta <matti@mdranta.net> new RSA4096, retrieved from https://github.com/techknowlogick.gpg
|
||||
ED810FD31FBE67F406ED71BDD4F1E9B6493ED946 # Jonas Franz <info@jonasfranz.software>
|
||||
9C5BCD799B3CDB124147A748E0DDFEC24C48784C) # Lauris Bukšis-Haberkorns <lauris@nix.lv>
|
||||
install=gitea.install
|
||||
|
||||
prepare() {
|
||||
mkdir -p gopath/src/code.gitea.io
|
||||
ln -rTsf ${pkgname} gopath/src/code.gitea.io/gitea
|
||||
export GOPATH="${srcdir}"/gopath
|
||||
|
||||
cd ${pkgname}
|
||||
# Change some defaults for ArchLinux
|
||||
patch -Np1 -i ../gitea-arch-defaults.patch
|
||||
# Fix LDFLAGS not being respected by Go
|
||||
patch -Np1 -i ../gitea-ldflags.patch
|
||||
|
||||
cd $GOPATH/src/code.gitea.io/gitea
|
||||
dep ensure
|
||||
# Fetch dependency using go mod
|
||||
make vendor
|
||||
}
|
||||
|
||||
build() {
|
||||
export GOPATH="${srcdir}"/gopath
|
||||
cd ${pkgname}
|
||||
export GOGC=50
|
||||
cd gopath/src/code.gitea.io/gitea
|
||||
make generate
|
||||
EXTRA_GOFLAGS="-gcflags all=-trimpath=${GOPATH} -asmflags all=-trimpath=${GOPATH}" \
|
||||
EXTRA_GOFLAGS="-gcflags all=-trimpath=${PWD} -asmflags all=-trimpath=${PWD}" \
|
||||
LDFLAGS="-linkmode external -extldflags \"${LDFLAGS}\""
|
||||
make GOFLAGS="-v" TAGS="bindata sqlite pam" build
|
||||
}
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/custom/conf/app.ini.sample
|
||||
+++ b/custom/conf/app.ini.sample
|
||||
@@ -7,12 +7,12 @@
|
||||
@@ -8,12 +8,12 @@
|
||||
; App name that shows in every page title
|
||||
APP_NAME = Gitea: Git with a cup of tea
|
||||
; Change it if you run locally
|
||||
|
@ -9,14 +9,14 @@
|
|||
; Either "dev", "prod" or "test", default is "dev"
|
||||
-RUN_MODE = dev
|
||||
+RUN_MODE = prod
|
||||
|
||||
|
||||
[repository]
|
||||
-ROOT =
|
||||
+ROOT = /var/lib/gitea/repos
|
||||
SCRIPT_TYPE = bash
|
||||
; Default ANSI charset
|
||||
ANSI_CHARSET =
|
||||
@@ -247,7 +247,7 @@ SQLITE_TIMEOUT = 500
|
||||
@@ -270,7 +270,7 @@ SQLITE_TIMEOUT = 500
|
||||
; For iterate buffer, default is 50
|
||||
ITERATE_BUFFER_SIZE = 50
|
||||
; Show the database generated SQL
|
||||
|
@ -25,9 +25,9 @@
|
|||
; Maximum number of DB Connect retries
|
||||
DB_RETRIES = 10
|
||||
; Backoff time per DB retry (time.Duration)
|
||||
@@ -510,10 +510,10 @@ MAX_FILES = 5
|
||||
@@ -545,10 +545,10 @@ MAX_FILES = 5
|
||||
FORMAT =
|
||||
|
||||
|
||||
[log]
|
||||
-ROOT_PATH =
|
||||
+ROOT_PATH = /var/log/gitea/
|
||||
|
@ -37,13 +37,14 @@
|
|||
+MODE = console, file
|
||||
; Buffer length of the channel, keep it as it is if you don't know what it is.
|
||||
BUFFER_LEN = 10000
|
||||
; Either "Trace", "Debug", "Info", "Warn", "Error", "Critical", default is "Trace"
|
||||
@@ -522,7 +522,7 @@ LEVEL = Trace
|
||||
|
||||
REDIRECT_MACARON_LOG = false
|
||||
@@ -573,7 +573,7 @@ LEVEL = Trace
|
||||
|
||||
; For "console" mode only
|
||||
[log.console]
|
||||
-LEVEL =
|
||||
+LEVEL = Info
|
||||
|
||||
STDERR = false
|
||||
|
||||
; For "file" mode only
|
||||
[log.file]
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -36,6 +36,7 @@ else
|
||||
GITEA_VERSION := $(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')
|
||||
endif
|
||||
|
||||
+EXTLDFLAGS := ${LDFLAGS}
|
||||
LDFLAGS := -X "main.Version=$(GITEA_VERSION)" -X "main.Tags=$(TAGS)"
|
||||
|
||||
PACKAGES ?= $(filter-out code.gitea.io/gitea/integrations/migration-test,$(filter-out code.gitea.io/gitea/integrations,$(shell $(GO) list ./... | grep -v /vendor/)))
|
||||
@@ -312,7 +313,7 @@ install: $(wildcard *.go)
|
||||
build: $(EXECUTABLE)
|
||||
|
||||
$(EXECUTABLE): $(SOURCES)
|
||||
- $(GO) build $(GOFLAGS) $(EXTRA_GOFLAGS) -tags '$(TAGS)' -ldflags '-s -w $(LDFLAGS)' -o $@
|
||||
+ $(GO) build $(GOFLAGS) $(EXTRA_GOFLAGS) -tags '$(TAGS)' -ldflags '-linkmode external -extldflags "$(EXTLDFLAGS)" -s -w $(LDFLAGS)' -o $@
|
||||
|
||||
.PHONY: release
|
||||
release: release-dirs release-windows release-linux release-darwin release-copy release-compress release-check
|
|
@ -1,30 +0,0 @@
|
|||
post_upgrade() {
|
||||
if [ $(vercmp $2 1.6.1-1) -lt 0 ] ; then
|
||||
cat << EOF
|
||||
|
||||
gitea now uses its own user/group instead of the git ones.
|
||||
Ownership of /var/lib/gitea tree has been changed accordingly.
|
||||
You need to update your /etc/gitea/app.ini file to change the
|
||||
RUN_USER variable at the top.
|
||||
|
||||
Next step is fixing the SSH configuration. If you have:
|
||||
AllowUsers git
|
||||
in /etc/ssh/sshd_config, you need to change that to gitea.
|
||||
Then restart sshd.service.
|
||||
You will need to tell all your users that they have to change
|
||||
git@ to gitea@ in their repos clones using git remote set-url.
|
||||
|
||||
If you use a PostgreSQL DB upon Unix socket, you need to fix
|
||||
your [database] configuration and switch USER to gitea.
|
||||
Then, you need to change it also in /var/lib/data/pg_hba.conf.
|
||||
Finally, as postgres user, run psql and inside it type:
|
||||
ALTER USER git RENAME TO gitea;
|
||||
\q
|
||||
Then restart postgresql.service.
|
||||
|
||||
In all cases, you then need to reload systemd units and
|
||||
restart gitea.service.
|
||||
|
||||
EOF
|
||||
fi
|
||||
}
|
Loading…
Reference in a new issue