mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
deleted community/powerdns-recursor
This commit is contained in:
parent
590319c21e
commit
cb54e8797b
3 changed files with 0 additions and 90 deletions
|
@ -1,52 +0,0 @@
|
|||
# $Id: PKGBUILD 100035 2013-10-31 11:20:48Z arodseth $
|
||||
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Jan Steffens <heftig@archlinux.org>
|
||||
|
||||
# Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - fix for aeskey.c on ARM (http://wiki.powerdns.com/trac/changeset/3162/)
|
||||
|
||||
pkgname=powerdns-recursor
|
||||
pkgver=3.5.3
|
||||
pkgrel=2.1
|
||||
pkgdesc='Resolving DNS server'
|
||||
url='https://www.powerdns.com/'
|
||||
license=('GPL')
|
||||
arch=('x86_64' 'i686')
|
||||
depends=('gcc-libs' 'lua51')
|
||||
makedepends=('boost')
|
||||
replaces=('pdns-recursor')
|
||||
provides=('pdns-recursor')
|
||||
conflicts=('pdns-recursor')
|
||||
backup=('etc/powerdns/recursor.conf')
|
||||
source=("http://downloads.powerdns.com/releases/pdns-recursor-$pkgver.tar.bz2"
|
||||
'pdns-recursor.service'
|
||||
'arm.patch')
|
||||
sha256sums=('192c0b47a1cfcdccaa88d70fd33766a4c381f4223f966416f15e169df5d58eaa'
|
||||
'd4f545e85dffa86bf23c89ff0f352c74ec3524dfc53871f129656299222e4fba'
|
||||
'ff51af1648d6049f58887ca4f84fa41955ab5df8156d8a00b4b3b148e2bd789f')
|
||||
|
||||
prepare() {
|
||||
cd "pdns-recursor-$pkgver"
|
||||
|
||||
patch -p5 -i "$srcdir/arm.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
make -C "pdns-recursor-$pkgver" -j1 LUA=1 \
|
||||
LUA_CPPFLAGS_CONFIG="$(pkg-config --cflags lua5.1)" \
|
||||
LUA_LIBS_CONFIG="$(pkg-config --libs lua5.1)"
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "pdns-recursor-$pkgver"
|
||||
|
||||
make SBINDIR="/usr/bin" DESTDIR="$pkgdir" install
|
||||
mv "$pkgdir/etc/powerdns/recursor.conf-dist" \
|
||||
"$pkgdir/etc/powerdns/recursor.conf"
|
||||
rm -r "$pkgdir/etc/init.d"
|
||||
install -Dm644 "$srcdir/pdns-recursor.service" \
|
||||
"$pkgdir/usr/lib/systemd/system/pdns-recursor.service"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,28 +0,0 @@
|
|||
Index: trunk/pdns/pdns/aes/aeskey.c
|
||||
===================================================================
|
||||
--- a/trunk/pdns/pdns/aes/aeskey.c
|
||||
+++ b/trunk/pdns/pdns/aes/aeskey.c
|
||||
@@ -489,4 +489,5 @@
|
||||
}
|
||||
|
||||
+#if 0
|
||||
AES_RETURN aes_decrypt_key256(const unsigned char *key, aes_decrypt_ctx cx[1])
|
||||
{ uint_32t ss[9];
|
||||
@@ -537,4 +538,5 @@
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
+#endif
|
||||
|
||||
#endif
|
||||
@@ -542,4 +544,5 @@
|
||||
#if defined( AES_VAR )
|
||||
|
||||
+#if 0
|
||||
AES_RETURN aes_decrypt_key(const unsigned char *key, int key_len, aes_decrypt_ctx cx[1])
|
||||
{
|
||||
@@ -552,4 +555,5 @@
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
|
||||
#endif
|
|
@ -1,10 +0,0 @@
|
|||
[Unit]
|
||||
Description=PowerDNS resolving DNS server
|
||||
After=network.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/bin/pdns_recursor --daemon
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
Loading…
Reference in a new issue