mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/pacman to 4.1.2-6.1
Moved synchronizing filesystem to libalpm transaction function that handles adding and removing packages. "synchronizing filesystem" message moved to the debug messages. Fixes #975
This commit is contained in:
parent
2f572ccfcb
commit
cb5ba97b6c
2 changed files with 17 additions and 33 deletions
|
@ -1,6 +1,6 @@
|
|||
From f727cd2ebcc84d6fe2e84c16b42a969d5abf6ff2 Mon Sep 17 00:00:00 2001
|
||||
From f1f7a14e173822fb075576c69f8bd4476f5263da Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 21 Apr 2014 21:39:09 -0600
|
||||
Date: Sat, 13 Sep 2014 18:58:16 -0600
|
||||
Subject: [PATCH] Sychronize filesystem
|
||||
|
||||
Since many problems arise from improper flushing of the filesystem,
|
||||
|
@ -10,39 +10,23 @@ consistent filesystem state after package operations.
|
|||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
src/pacman/remove.c | 4 ++++
|
||||
src/pacman/sync.c | 3 +++
|
||||
2 files changed, 7 insertions(+)
|
||||
lib/libalpm/trans.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/pacman/remove.c b/src/pacman/remove.c
|
||||
index 933e6f7..37e6b97 100644
|
||||
--- a/src/pacman/remove.c
|
||||
+++ b/src/pacman/remove.c
|
||||
@@ -177,6 +177,10 @@ cleanup:
|
||||
if(trans_release() == -1) {
|
||||
retval = 1;
|
||||
}
|
||||
+
|
||||
+ printf(_("synchronizing filesystem...\n"));
|
||||
diff --git a/lib/libalpm/trans.c b/lib/libalpm/trans.c
|
||||
index 8d4e0e7..886f87b 100644
|
||||
--- a/lib/libalpm/trans.c
|
||||
+++ b/lib/libalpm/trans.c
|
||||
@@ -175,6 +175,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
|
||||
|
||||
trans->state = STATE_COMMITED;
|
||||
|
||||
+ _alpm_log(handle, ALPM_LOG_DEBUG, "synchronizing filesystem\n");
|
||||
+ sync();
|
||||
+
|
||||
return retval;
|
||||
}
|
||||
|
||||
diff --git a/src/pacman/sync.c b/src/pacman/sync.c
|
||||
index bf19d57..ffffdfe 100644
|
||||
--- a/src/pacman/sync.c
|
||||
+++ b/src/pacman/sync.c
|
||||
@@ -879,6 +879,9 @@ cleanup:
|
||||
retval = 1;
|
||||
}
|
||||
|
||||
+ printf(_("synchronizing filesystem...\n"));
|
||||
+ sync();
|
||||
+
|
||||
return retval;
|
||||
return 0;
|
||||
}
|
||||
|
||||
--
|
||||
1.9.0
|
||||
2.1.0
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@
|
|||
|
||||
pkgname=pacman
|
||||
pkgver=4.1.2
|
||||
pkgrel=6
|
||||
pkgrel=6.1
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.archlinux.org/pacman/"
|
||||
|
@ -32,7 +32,7 @@ source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
|
|||
makepkg.conf)
|
||||
md5sums=('063c8b0ff6bdf903dc235445525627cd'
|
||||
'SKIP'
|
||||
'068daa5366ca61eae46294c676caac23'
|
||||
'f7f7bd5bdd5f7973955f3af8bbceae61'
|
||||
'5c491b27bae54d93d6ba972ce0fccfa7'
|
||||
'1f8d6efc76a395956fdae71927698666')
|
||||
|
||||
|
|
Loading…
Reference in a new issue