alarm/uboot-odroid to 2016.11-1

This commit is contained in:
Kevin Mihelich 2016-12-03 03:00:51 +00:00
parent 9e22b22e35
commit cb663cae13
3 changed files with 29 additions and 27 deletions

View file

@ -1,25 +1,27 @@
From def7823985d4a7b7670c1ed6eea8a28482ae4642 Mon Sep 17 00:00:00 2001 From 85fbfc993ffc43536839e537612a12c407638a88 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 22 Aug 2014 17:51:41 -0600 Date: Fri, 22 Aug 2014 17:51:41 -0600
Subject: [PATCH 1/2] arch linux arm modifications Subject: [PATCH 1/2] arch linux arm modifications
--- ---
include/configs/odroid.h | 173 ++++++++++++++++++----------------------------- configs/odroid_defconfig | 1 +
1 file changed, 64 insertions(+), 109 deletions(-) include/configs/odroid.h | 172 +++++++++++++++++------------------------------
2 files changed, 64 insertions(+), 109 deletions(-)
diff --git a/configs/odroid_defconfig b/configs/odroid_defconfig
index f3ddc74..94a01e0 100644
--- a/configs/odroid_defconfig
+++ b/configs/odroid_defconfig
@@ -51,3 +51,4 @@ CONFIG_G_DNL_MANUFACTURER="Samsung"
CONFIG_G_DNL_VENDOR_NUM=0x04e8
CONFIG_G_DNL_PRODUCT_NUM=0x6601
CONFIG_ERRNO_STR=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
diff --git a/include/configs/odroid.h b/include/configs/odroid.h diff --git a/include/configs/odroid.h b/include/configs/odroid.h
index 12b7dc5..306ff07 100644 index 2828f07..4c0ff07 100644
--- a/include/configs/odroid.h --- a/include/configs/odroid.h
+++ b/include/configs/odroid.h +++ b/include/configs/odroid.h
@@ -14,6 +14,7 @@ @@ -35,6 +35,7 @@
#include <configs/exynos4-common.h>
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
#define CONFIG_SYS_L2CACHE_OFF
#ifndef CONFIG_SYS_L2CACHE_OFF
#define CONFIG_SYS_L2_PL310
@@ -35,6 +36,7 @@
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_SDRAM_BASE + 0x5E00000) #define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_SDRAM_BASE + 0x5E00000)
#define CONFIG_SYS_LOAD_ADDR (CONFIG_SYS_SDRAM_BASE + 0x3E00000) #define CONFIG_SYS_LOAD_ADDR (CONFIG_SYS_SDRAM_BASE + 0x3E00000)
#define CONFIG_SYS_TEXT_BASE 0x43e00000 #define CONFIG_SYS_TEXT_BASE 0x43e00000
@ -27,9 +29,9 @@ index 12b7dc5..306ff07 100644
#include <linux/sizes.h> #include <linux/sizes.h>
@@ -46,10 +48,6 @@ @@ -44,10 +45,6 @@
#define CONFIG_SYS_CONSOLE_INFO_QUIET
#define CONFIG_SYS_CONSOLE_IS_IN_ENV /* Console configuration */
-#define CONFIG_BOOTARGS "Please use defined boot" -#define CONFIG_BOOTARGS "Please use defined boot"
-#define CONFIG_BOOTCOMMAND "run autoboot" -#define CONFIG_BOOTCOMMAND "run autoboot"
@ -38,7 +40,7 @@ index 12b7dc5..306ff07 100644
#define CONFIG_SYS_INIT_SP_ADDR (CONFIG_SYS_LOAD_ADDR \ #define CONFIG_SYS_INIT_SP_ADDR (CONFIG_SYS_LOAD_ADDR \
- GENERATED_GBL_DATA_SIZE) - GENERATED_GBL_DATA_SIZE)
@@ -61,34 +59,7 @@ @@ -59,34 +56,7 @@
#define CONFIG_ENV_OFFSET (SZ_1K * 1280) /* 1.25 MiB offset */ #define CONFIG_ENV_OFFSET (SZ_1K * 1280) /* 1.25 MiB offset */
#define CONFIG_ENV_OVERWRITE #define CONFIG_ENV_OVERWRITE
@ -74,7 +76,7 @@ index 12b7dc5..306ff07 100644
/* /*
* Bootable media layout: * Bootable media layout:
@@ -98,85 +69,69 @@ @@ -96,85 +66,69 @@
* UBOOT 63 62 * UBOOT 63 62
* TZSW 2111 2110 * TZSW 2111 2110
* ENV 2560 2560(part user) * ENV 2560 2560(part user)
@ -222,5 +224,5 @@ index 12b7dc5..306ff07 100644
/* I2C */ /* I2C */
#define CONFIG_SYS_I2C_S3C24X0 #define CONFIG_SYS_I2C_S3C24X0
-- --
2.8.3 2.10.2

View file

@ -1,4 +1,4 @@
From fb927d726489ef96f4af524870e74d32ee846140 Mon Sep 17 00:00:00 2001 From cbb4f92059b85bb4a438458df6675e24173700d6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 6 Feb 2015 05:40:56 -0700 Date: Fri, 6 Feb 2015 05:40:56 -0700
Subject: [PATCH 2/2] odroid-x support Subject: [PATCH 2/2] odroid-x support
@ -22,10 +22,10 @@ index b4cb332..d025d06 100644
return board_type[gd->board_type]; return board_type[gd->board_type];
} }
diff --git a/include/configs/odroid.h b/include/configs/odroid.h diff --git a/include/configs/odroid.h b/include/configs/odroid.h
index 306ff07..460c796 100644 index 4c0ff07..803f666 100644
--- a/include/configs/odroid.h --- a/include/configs/odroid.h
+++ b/include/configs/odroid.h +++ b/include/configs/odroid.h
@@ -23,7 +23,7 @@ @@ -22,7 +22,7 @@
#define CONFIG_MACH_TYPE 4289 #define CONFIG_MACH_TYPE 4289
@ -35,5 +35,5 @@ index 306ff07..460c796 100644
#define SDRAM_BANK_SIZE (256 << 20) /* 256 MB */ #define SDRAM_BANK_SIZE (256 << 20) /* 256 MB */
#define PHYS_SDRAM_1 CONFIG_SYS_SDRAM_BASE #define PHYS_SDRAM_1 CONFIG_SYS_SDRAM_BASE
-- --
2.8.3 2.10.2

View file

@ -5,7 +5,7 @@ buildarch=4
pkgbase=uboot-odroid pkgbase=uboot-odroid
pkgname=('uboot-odroid' 'uboot-odroid-x') pkgname=('uboot-odroid' 'uboot-odroid-x')
pkgver=2016.09 pkgver=2016.11
pkgrel=1 pkgrel=1
arch=('armv7h') arch=('armv7h')
url='http://www.denx.de/wiki/U-Boot/WebHome' url='http://www.denx.de/wiki/U-Boot/WebHome'
@ -22,13 +22,13 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
'0001-arch-linux-arm-modifications.patch' '0001-arch-linux-arm-modifications.patch'
'0002-odroid-x-support.patch' '0002-odroid-x-support.patch'
'uEnv.txt') 'uEnv.txt')
md5sums=('2e69dda70eb28f8042d2f9fbeb1feaa1' md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
'3ab6d3cc2061bc2590d60320254017c6' '3ab6d3cc2061bc2590d60320254017c6'
'841502de02bd42f2898e36c89c260b0f' '841502de02bd42f2898e36c89c260b0f'
'c38faafa02a6a1ae834457f378c82113' 'c38faafa02a6a1ae834457f378c82113'
'17909ae93a0ae7b4c155234040105035' '17909ae93a0ae7b4c155234040105035'
'afe3b7a5b224e257b2ce7f5af03daa8d' '322bea8a6c09c3ce05bb818e6b06a368'
'f4f8c8b6217e6646b9659de642264a3f' '0ed88109d0537e0decbccf9b98eea68b'
'fb5c9ea3108afa298087549f0453b00f') 'fb5c9ea3108afa298087549f0453b00f')
prepare() { prepare() {