mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/webkitgtk to 2.0.3-1
This commit is contained in:
parent
8cfd2e7d72
commit
cba36a0a42
3 changed files with 8 additions and 66 deletions
|
@ -5,30 +5,22 @@
|
|||
# - re-enabled --disable-silent-rules, needed for v5 and v6 to build
|
||||
|
||||
pkgname=webkitgtk
|
||||
pkgver=2.0.2
|
||||
pkgrel=3
|
||||
pkgver=2.0.3
|
||||
pkgrel=1
|
||||
pkgdesc="GTK+ Web content engine library"
|
||||
arch=(i686 x86_64)
|
||||
url="http://webkitgtk.org/"
|
||||
license=(custom)
|
||||
depends=(libxt libxslt sqlite libsoup enchant libgl geoclue gtk3 gst-plugins-base-libs libsecret libwebp
|
||||
harfbuzz-icu)
|
||||
depends=(libxt libxslt sqlite libsoup enchant libgl geoclue gtk3 gst-plugins-base-libs
|
||||
libsecret libwebp harfbuzz-icu)
|
||||
makedepends=(gtk2 gperf gobject-introspection python mesa ruby gtk-doc)
|
||||
optdepends=('gtk2: Webkit2 plugin support')
|
||||
conflicts=(webkitgtk3 libwebkit3)
|
||||
optdepends=('gtk2: Netscape plugin support')
|
||||
provides=("webkitgtk3=${pkgver}" "libwebkit3=${pkgver}")
|
||||
conflicts=(webkitgtk3 libwebkit3)
|
||||
replaces=(webkitgtk3 libwebkit3)
|
||||
options=(!libtool !emptydirs)
|
||||
source=(http://webkitgtk.org/releases/$pkgname-${pkgver}.tar.xz
|
||||
changeset_150963.diff)
|
||||
sha256sums=('c3685032545eb4c23f3f56826817783a6963ad59bd7bbf806705059b3d8caeb2'
|
||||
'8d2542600cba876b714cdf6be478d847b6672bff2856e6e6d0582b1566fe5764')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -Np2 -i ../changeset_150963.diff
|
||||
autoreconf -fi -I Source/autotools
|
||||
}
|
||||
source=(http://webkitgtk.org/releases/$pkgname-${pkgver}.tar.xz)
|
||||
sha256sums=('9bf8a32afbf087c4fc2c652b193a52c44b180735ba9c7c8db88137904d458e1b')
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
2013-05-30 Alberto Garcia <agarcia@igalia.com>
|
||||
|
||||
[GTK] Needs to check for harfbuzz-icu
|
||||
https://bugs.webkit.org/show_bug.cgi?id=116978
|
||||
|
||||
Reviewed by Xan Lopez.
|
||||
|
||||
HarfBuzz 0.9.18 splits harbuzz-icu into a separate library so we
|
||||
also need to check for it in order to get the necessary flags for
|
||||
the compiler and the linker.
|
||||
|
||||
We keep this conditional for now since we still want to support
|
||||
earlier versions of HarfBuzz.
|
||||
|
||||
Index: /trunk/Source/autotools/FindDependencies.m4
|
||||
===================================================================
|
||||
--- /trunk/Source/autotools/FindDependencies.m4 (revision 150962)
|
||||
+++ /trunk/Source/autotools/FindDependencies.m4 (revision 150963)
|
||||
@@ -376,4 +376,11 @@
|
||||
[cairo-ft fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz >= harfbuzz_required_version])
|
||||
fi
|
||||
+# HarfBuzz 0.9.18 splits harbuzz-icu into a separate library.
|
||||
+# Since we support earlier HarfBuzz versions we keep this conditional for now.
|
||||
+if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
|
||||
+ PKG_CHECK_MODULES(HARFBUZZ_ICU, harfbuzz-icu >= $harfbuzz_required_version)
|
||||
+ FREETYPE_CFLAGS+=" $HARFBUZZ_ICU_CFLAGS"
|
||||
+ FREETYPE_LIBS+=" $HARFBUZZ_ICU_LIBS"
|
||||
+fi
|
||||
AC_SUBST([FREETYPE_CFLAGS])
|
||||
AC_SUBST([FREETYPE_LIBS])
|
|
@ -1,20 +0,0 @@
|
|||
diff --git a/Tools/gtk/generate-feature-defines-files b/Tools/gtk/generate-feature-defines-files
|
||||
index 1a92bf50a05831655308cb62646eb05a6db4b63c..f5b2c7e61eab12bf0eb25b0f9c595f2fd83ebbe9 100755
|
||||
--- a/Tools/gtk/generate-feature-defines-files
|
||||
+++ b/Tools/gtk/generate-feature-defines-files
|
||||
@@ -32,13 +32,13 @@ def write_file_if_contents_changed(filename, contents):
|
||||
|
||||
def write_feature_defines_header(feature_defines):
|
||||
contents = ''
|
||||
- for (feature, value) in feature_defines.iteritems():
|
||||
+ for (feature, value) in feature_defines.items():
|
||||
contents += '#define {0} {1}\n'.format(feature, value)
|
||||
write_file_if_contents_changed("WebKitFeatures.h", contents)
|
||||
|
||||
def write_flattened_feature_defines_file(feature_defines):
|
||||
contents = ''
|
||||
- for (feature, value) in feature_defines.iteritems():
|
||||
+ for (feature, value) in feature_defines.items():
|
||||
contents += '{0}={1}\n'.format(feature, value)
|
||||
write_file_if_contents_changed("WebKitFeatures.txt", contents)
|
||||
|
Loading…
Reference in a new issue