mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/thunderbird to 31.0-1
This commit is contained in:
parent
128c7e2f2f
commit
cba9f8d5b2
3 changed files with 27 additions and 50 deletions
|
@ -13,14 +13,14 @@
|
|||
buildarch=20
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=24.6.0
|
||||
pkgver=31.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone Mail/News reader"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL')
|
||||
url="http://www.mozilla.org/thunderbird/"
|
||||
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'nss' 'sqlite' 'startup-notification')
|
||||
makedepends=('unzip' 'zip' 'pkg-config' 'python2' 'wireless_tools' 'yasm' 'mesa' 'autoconf2.13')
|
||||
makedepends=('unzip' 'zip' 'python2' 'wireless_tools' 'yasm' 'mesa' 'libpulse')
|
||||
optdepends=('libcanberra: for sound support')
|
||||
install=thunderbird.install
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.bz2{,.asc}
|
||||
|
@ -30,16 +30,16 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/sou
|
|||
vendor.js
|
||||
no-neon.patch)
|
||||
options=(!emptydirs)
|
||||
sha256sums=('ae9a7cbc8dc195bd9f4b7b4edcd33599fa08c5388a0690f77221e6c5566629ea'
|
||||
sha256sums=('571f8cca980f077ae81999aea69a78153422a75e9e6c07ab74ec6659fe0d6ef4'
|
||||
'SKIP'
|
||||
'84adca3cc1ed19cd4fce8c5cdb21923f8266246595b53e5a469d0c4cf57680f2'
|
||||
'8311aaf51f651670ba50d914167b8cb12046e5f429be7d11e4402e359427ee2a'
|
||||
'd506b771e765e09e2e039b975e25befade8eec97e8950813a32463604955ab4e'
|
||||
'929a7ceca0e90d0635a2099b7df24033e865fb5b5b8c5824468c4561c21c377d'
|
||||
'9049ab3f9600a1592a54c41a166c76e046c393e1cfe7c4e769155b7317d197ee'
|
||||
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
|
||||
'e9c75dbc86d96efec6f8bb4fea949fafe20d72bfefacc427decbd7fab801bd00')
|
||||
|
||||
prepare() {
|
||||
cd comm-esr24
|
||||
cd comm-esr31
|
||||
patch -Np1 -i "$srcdir/thunderbird-install-dir.patch"
|
||||
|
||||
patch -Np0 -i ../no-neon.patch
|
||||
|
@ -52,7 +52,7 @@ prepare() {
|
|||
}
|
||||
|
||||
build() {
|
||||
cd comm-esr24
|
||||
cd comm-esr31
|
||||
|
||||
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/thunderbird -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
export PYTHON="/usr/bin/python2"
|
||||
|
@ -61,7 +61,7 @@ build() {
|
|||
}
|
||||
|
||||
package() {
|
||||
cd comm-esr24
|
||||
cd comm-esr31
|
||||
make -j1 -f client.mk DESTDIR="$pkgdir" install
|
||||
|
||||
install -Dm644 "$srcdir"/vendor.js "$pkgdir/usr/lib/thunderbird/defaults/preferences/vendor.js"
|
||||
|
@ -79,5 +79,5 @@ package() {
|
|||
ln -sf /usr/share/hyphen "$pkgdir/usr/lib/thunderbird/hyphenation"
|
||||
|
||||
# We don't want the development stuff
|
||||
rm -r "$pkgdir"/usr/{include,lib/thunderbird-devel,share/idl}
|
||||
rm -r "$pkgdir"/usr/{include,lib/thunderbird-devel-*,share/idl}
|
||||
}
|
||||
|
|
|
@ -41,6 +41,7 @@ ac_add_options --disable-updater
|
|||
ac_add_options --disable-tests
|
||||
ac_add_options --disable-mochitest
|
||||
ac_add_options --disable-installer
|
||||
ac_add_options --disable-debug-symbols
|
||||
|
||||
# Optimization
|
||||
ac_add_options --enable-optimize
|
||||
|
|
|
@ -1,47 +1,23 @@
|
|||
diff -upr comm-release.orig/config/baseconfig.mk comm-release/config/baseconfig.mk
|
||||
--- comm-release.orig/config/baseconfig.mk 2012-11-21 03:19:15.000000000 +0200
|
||||
+++ comm-release/config/baseconfig.mk 2012-11-21 03:20:35.000000000 +0200
|
||||
@@ -1,9 +1,9 @@
|
||||
INCLUDED_AUTOCONF_MK = 1
|
||||
|
||||
-includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
diff -upr comm-esr31.orig/config/baseconfig.mk comm-esr31/config/baseconfig.mk
|
||||
--- comm-esr31.orig/config/baseconfig.mk 2014-07-22 09:44:23.000000000 +0300
|
||||
+++ comm-esr31/config/baseconfig.mk 2014-07-22 09:46:30.000000000 +0300
|
||||
@@ -1,6 +1,6 @@
|
||||
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
+includedir := $(includedir)/$(MOZ_APP_NAME)
|
||||
+idldir = $(datadir)/idl/$(MOZ_APP_NAME)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
|
||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
MOZILLA_SRCDIR = $(topsrcdir)/mozilla
|
||||
MOZDEPTH = $(DEPTH)/mozilla
|
||||
DIST = $(MOZDEPTH)/dist
|
||||
diff -upr comm-release.orig/mozilla/config/baseconfig.mk comm-release/mozilla/config/baseconfig.mk
|
||||
--- comm-release.orig/mozilla/config/baseconfig.mk 2012-11-21 03:19:16.000000000 +0200
|
||||
+++ comm-release/mozilla/config/baseconfig.mk 2012-11-21 03:19:20.000000000 +0200
|
||||
@@ -1,9 +1,9 @@
|
||||
INCLUDED_AUTOCONF_MK = 1
|
||||
|
||||
-includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
diff -upr comm-esr31.orig/mozilla/config/baseconfig.mk comm-esr31/mozilla/config/baseconfig.mk
|
||||
--- comm-esr31.orig/mozilla/config/baseconfig.mk 2014-07-22 09:44:22.000000000 +0300
|
||||
+++ comm-esr31/mozilla/config/baseconfig.mk 2014-07-22 09:46:45.000000000 +0300
|
||||
@@ -4,7 +4,7 @@
|
||||
# whether a normal build is happening or whether the check is running.
|
||||
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
+includedir := $(includedir)/$(MOZ_APP_NAME)
|
||||
+idldir = $(datadir)/idl/$(MOZ_APP_NAME)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
|
||||
DIST = $(DEPTH)/dist
|
||||
|
||||
# We do magic with OBJ_SUFFIX in config.mk, the following ensures we don't
|
||||
diff -upr comm-release.orig/mozilla/js/src/config/baseconfig.mk comm-release/mozilla/js/src/config/baseconfig.mk
|
||||
--- comm-release.orig/mozilla/js/src/config/baseconfig.mk 2012-11-21 03:19:15.000000000 +0200
|
||||
+++ comm-release/mozilla/js/src/config/baseconfig.mk 2012-11-21 03:19:20.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
INCLUDED_AUTOCONF_MK = 1
|
||||
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
|
||||
|
||||
ifneq (,$(filter /%,$(TOP_DIST)))
|
||||
DIST = $(TOP_DIST)
|
||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
ifndef TOP_DIST
|
||||
TOP_DIST = dist
|
||||
|
|
Loading…
Reference in a new issue