mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/vlc: fix
This commit is contained in:
parent
3d624e8af7
commit
cbf7901883
2 changed files with 2 additions and 71 deletions
|
@ -1,65 +0,0 @@
|
|||
From: Janne Grunau <janne-vlc@jannau.net>
|
||||
Date: Mon, 19 Feb 2018 00:47:53 +0100
|
||||
Subject: arm: make the assembler functions compatible with non ELF/gas
|
||||
platforms
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Allow assembling arm neon functions for IOS and arm windows.
|
||||
|
||||
Signed-off-by: Martin Storsjö <martin@martin.st>
|
||||
(cherry picked from commit ec4d9649d1c03fe8f578db38b41dccdf5e11b005)
|
||||
Signed-off-by: Thomas Guillem <thomas@gllm.fr>
|
||||
|
||||
[Add modules/arm_neon/asm.S missing from orig tarball.]
|
||||
---
|
||||
modules/arm_neon/asm.S | 39 +++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 39 insertions(+)
|
||||
create mode 100644 modules/arm_neon/asm.S
|
||||
|
||||
diff --git a/modules/arm_neon/asm.S b/modules/arm_neon/asm.S
|
||||
new file mode 100644
|
||||
index 0000000..728391e
|
||||
--- /dev/null
|
||||
+++ b/modules/arm_neon/asm.S
|
||||
@@ -0,0 +1,39 @@
|
||||
+/*
|
||||
+ * Copyright (c) 2018 Janne Grunau <janne-libav@jannau.net>
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or
|
||||
+ * modify it under the terms of the GNU Lesser General Public
|
||||
+ * License as published by the Free Software Foundation; either
|
||||
+ * version 2.1 of the License, or (at your option) any later version.
|
||||
+ *
|
||||
+ * This program is distributed in the hope that it will be useful,
|
||||
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ * Lesser General Public License for more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU Lesser General Public
|
||||
+ * License along with this program; if not, write to the Free Software
|
||||
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
+ */
|
||||
+
|
||||
+#ifdef __APPLE__
|
||||
+# define EXTERN_ASM _
|
||||
+#else
|
||||
+# define EXTERN_ASM
|
||||
+#endif
|
||||
+
|
||||
+#if defined(__APPLE__) || defined(_WIN32)
|
||||
+# define HAVE_AS_ARCH_DIRECTIVE 0
|
||||
+# define HAVE_AS_FPU_DIRECTIVE 0
|
||||
+#else
|
||||
+# define HAVE_AS_ARCH_DIRECTIVE 1
|
||||
+# define HAVE_AS_FPU_DIRECTIVE 1
|
||||
+#endif
|
||||
+
|
||||
+.macro function name
|
||||
+ .globl EXTERN_ASM\name
|
||||
+#ifdef __ELF__
|
||||
+ .type EXTERN_ASM\name, %function
|
||||
+#endif
|
||||
+EXTERN_ASM\name:
|
||||
+.endm
|
|
@ -5,7 +5,6 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - enable gles2
|
||||
# - patch for missing ARM assembly file
|
||||
|
||||
pkgname=vlc
|
||||
pkgver=3.0.2
|
||||
|
@ -96,13 +95,11 @@ replaces=('vlc-plugin')
|
|||
options=('!emptydirs')
|
||||
source=(https://download.videolan.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz{,.asc}
|
||||
update-vlc-plugin-cache.hook
|
||||
lua53_compat.patch
|
||||
0001-arm-make-the-assembler-functions-compatible-with-non.patch)
|
||||
lua53_compat.patch)
|
||||
sha512sums=('907a999dfa00fbc378e46689b2c32a09ea324b47a92b2183f2a1ade2c2c1ec205517580000a3c615d17b15d6885ee0ac51894944b90077968cb30ff58745497f'
|
||||
'SKIP'
|
||||
'80357bae69e32b353d3784932d854e294906798e14faffb87c3383c3b6f6bdc57cbabb9c6e3f3c1adf0f8ddbb24153e72104c963cf1934970c2983c96daef9df'
|
||||
'33cda373aa1fb3ee19a78748e2687f2b93c8662c9fda62ecd122a2e649df8edaceb54dda3991bc38c80737945a143a9e65baa2743a483bb737bb94cd590dc25f'
|
||||
'85ab0a39e989dc09402dbaa807ffb392ab9b66caa0689ac0352bb01897ee664eb238aa8b390a3b41c1259a650ea1b859dcacc3104679cc65b7f2d0f283539e54')
|
||||
'33cda373aa1fb3ee19a78748e2687f2b93c8662c9fda62ecd122a2e649df8edaceb54dda3991bc38c80737945a143a9e65baa2743a483bb737bb94cd590dc25f')
|
||||
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
|
||||
|
||||
prepare() {
|
||||
|
@ -112,7 +109,6 @@ prepare() {
|
|||
patch -Np1 < "${srcdir}/lua53_compat.patch"
|
||||
sed 's|whoami|echo builduser|g' -i configure
|
||||
sed 's|hostname -f|echo arch|g' -i configure
|
||||
patch -p1 -i ../0001-arm-make-the-assembler-functions-compatible-with-non.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue