mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/gstreamer to 1.20.5-1
This commit is contained in:
parent
96a42331c2
commit
cbf7e73115
3 changed files with 14 additions and 12 deletions
|
@ -20,7 +20,7 @@ Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/30
|
|||
3 files changed, 25 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 03df4ab157df..5b714eb5ee8f 100644
|
||||
index bf8415d0aee8..0f0c601d96f0 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -126,7 +126,19 @@ elif build_system == 'darwin'
|
||||
|
|
|
@ -11,7 +11,7 @@ Subject: [PATCH] HACK: meson: Disable broken tests
|
|||
4 files changed, 4 deletions(-)
|
||||
|
||||
diff --git a/subprojects/gst-editing-services/meson.build b/subprojects/gst-editing-services/meson.build
|
||||
index 2efa61a0355f..0fe8276d5903 100644
|
||||
index 63ca7e6d0631..f98f1789b9d8 100644
|
||||
--- a/subprojects/gst-editing-services/meson.build
|
||||
+++ b/subprojects/gst-editing-services/meson.build
|
||||
@@ -273,7 +273,6 @@ subdir('plugins')
|
||||
|
@ -23,7 +23,7 @@ index 2efa61a0355f..0fe8276d5903 100644
|
|||
subdir('examples')
|
||||
endif
|
||||
diff --git a/subprojects/gst-python/meson.build b/subprojects/gst-python/meson.build
|
||||
index 2f4c544f7079..5e0aef606e10 100644
|
||||
index 40e58eded847..a0405c792a1b 100644
|
||||
--- a/subprojects/gst-python/meson.build
|
||||
+++ b/subprojects/gst-python/meson.build
|
||||
@@ -104,5 +104,4 @@ if not get_option('plugin').disabled()
|
||||
|
@ -45,7 +45,7 @@ index 229af32f8117..b9372c125d77 100644
|
|||
'gst/sessionpool',
|
||||
'gst/stream',
|
||||
diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
|
||||
index 491765105820..42641a22878a 100644
|
||||
index 322bcac96ad2..194500e3e6c4 100644
|
||||
--- a/subprojects/gstreamer-vaapi/meson.build
|
||||
+++ b/subprojects/gstreamer-vaapi/meson.build
|
||||
@@ -202,7 +202,6 @@ plugins = []
|
||||
|
|
|
@ -29,8 +29,8 @@ pkgname=(
|
|||
gst-python
|
||||
gstreamer-docs
|
||||
)
|
||||
pkgver=1.20.4
|
||||
pkgrel=3
|
||||
pkgver=1.20.5
|
||||
pkgrel=1
|
||||
pkgdesc="Multimedia graph framework"
|
||||
url="https://gstreamer.freedesktop.org/"
|
||||
arch=(x86_64)
|
||||
|
@ -75,7 +75,7 @@ makedepends=(
|
|||
)
|
||||
checkdepends=(xorg-server-xvfb)
|
||||
options=(debug)
|
||||
_commit=642730bd67d3c23ac68bd328fbddd191a7a43f25 # tags/1.20.4^0
|
||||
_commit=f7806a854aad960eae3288db4a67a574f92428fe # tags/1.20.5^0
|
||||
source=(
|
||||
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git#commit=$_commit"
|
||||
"https://gstreamer.freedesktop.org/src/gstreamer-docs/gstreamer-docs-${pkgver%%+*}.tar.xz"{,.asc}
|
||||
|
@ -84,10 +84,10 @@ source=(
|
|||
0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
|
||||
)
|
||||
sha256sums=('SKIP'
|
||||
'9a40511387c5b14fa8ed4555bda1bb9dd336b4b8a00e18cc97929b4dd930a79a'
|
||||
'b3177d9320e2a1d872b85adf1a29cd4fad995adb4a41a478372419bdd8c87a95'
|
||||
'SKIP'
|
||||
'54115800d579864db41ba9b3f62745696a9e012ca5c7afa990ee6943f0912365'
|
||||
'5cd72310f9f4230ca6bba6a2b972eb783296ab622a2586683cd8623b6907d3ff'
|
||||
'c2b2fb2ebbb36527f5a43178597367485d95fe58268be043f8a9ebe962147bd9'
|
||||
'2b44fe7562d876d41878c9b513f9d36fbac43fa1c42db3ad2df309ced644de87'
|
||||
'79d3038a0ba0c3958ffa8b5aec8431336b372906c07c0c878c3767bec0acb46f')
|
||||
validpgpkeys=(D637032E45B8C6585B9456565D2EEE6F6F349D7C) # Tim Müller <tim@gstreamer-foundation.org>
|
||||
|
||||
|
@ -166,6 +166,7 @@ build() {
|
|||
)
|
||||
|
||||
arch-meson gstreamer build "${meson_options[@]}"
|
||||
meson configure build # Print config
|
||||
meson compile -C build
|
||||
}
|
||||
|
||||
|
@ -175,7 +176,7 @@ check() (
|
|||
|
||||
# Flaky due to timeouts
|
||||
xvfb-run -s '-nolisten local' \
|
||||
meson test -C build --print-errorlogs || :
|
||||
meson test -C build --print-errorlogs
|
||||
)
|
||||
|
||||
_install() {
|
||||
|
@ -724,6 +725,7 @@ package_gstreamer-docs() {
|
|||
license=(GPL3 LGPL custom:BSD custom:CC-BY-SA-4.0 custom:MIT custom:OPL)
|
||||
|
||||
# make sure there are no files left to install
|
||||
find root -depth ! -type d
|
||||
find root -depth -print0 | xargs -0 rmdir
|
||||
|
||||
cd gstreamer-docs-${pkgver%%+*}
|
||||
|
@ -734,4 +736,4 @@ package_gstreamer-docs() {
|
|||
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING LICENSE*
|
||||
}
|
||||
|
||||
# vim:set sw=2 et:
|
||||
# vim:set sw=2 sts=-1 et:
|
||||
|
|
Loading…
Reference in a new issue