mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/glibc to 2.33-5
This commit is contained in:
parent
5eecee6675
commit
cbfe362ef2
4 changed files with 487 additions and 3 deletions
|
@ -0,0 +1,308 @@
|
|||
From a64afc225240b2b27129ccfb0516d7c958b98040 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Wed, 21 Apr 2021 11:50:43 +0200
|
||||
Subject: [PATCH 364/576] nptl_db: Support different libpthread/ld.so load
|
||||
orders (bug 27744)
|
||||
|
||||
libthread_db is loaded once GDB encounters libpthread, and at this
|
||||
point, ld.so may not have been processed by GDB yet. As a result,
|
||||
_rtld_global cannot be accessed by regular means from libthread_db.
|
||||
To make this work until GDB can be fixed, acess _rtld_global through
|
||||
a pointer stored in libpthread.
|
||||
|
||||
The new test does not reproduce bug 27744 with
|
||||
--disable-hardcoded-path-in-tests, but is still a valid smoke test.
|
||||
With --enable-hardcoded-path-in-tests, it is necessary to avoid
|
||||
add-symbol-file because this can tickle a GDB bug.
|
||||
|
||||
Fixes commit 1daccf403b1bd86370eb94edca794dc106d02039 ("nptl: Move
|
||||
stack list variables into _rtld_global").
|
||||
|
||||
Tested-by: Emil Velikov <emil.velikov@collabora.com>
|
||||
---
|
||||
nptl/Makefile | 19 +++-
|
||||
nptl/pthread_create.c | 8 ++
|
||||
nptl/tst-pthread-gdb-attach-static.c | 1 +
|
||||
nptl/tst-pthread-gdb-attach.c | 143 +++++++++++++++++++++++++++
|
||||
nptl_db/structs.def | 3 +-
|
||||
nptl_db/td_init.c | 15 +--
|
||||
nptl_db/thread_dbP.h | 2 +
|
||||
7 files changed, 180 insertions(+), 11 deletions(-)
|
||||
create mode 100644 nptl/tst-pthread-gdb-attach-static.c
|
||||
create mode 100644 nptl/tst-pthread-gdb-attach.c
|
||||
|
||||
diff --git a/nptl/Makefile b/nptl/Makefile
|
||||
index 8fe92d43fa..e665d37e52 100644
|
||||
--- a/nptl/Makefile
|
||||
+++ b/nptl/Makefile
|
||||
@@ -313,7 +313,8 @@ tests = tst-attr2 tst-attr3 tst-default-attr \
|
||||
tst-thread-affinity-sched \
|
||||
tst-pthread-defaultattr-free \
|
||||
tst-pthread-attr-sigmask \
|
||||
- tst-pthread-timedlock-lockloop
|
||||
+ tst-pthread-timedlock-lockloop \
|
||||
+ tst-pthread-gdb-attach tst-pthread-gdb-attach-static
|
||||
|
||||
tests-container = tst-pthread-getattr
|
||||
|
||||
@@ -359,6 +360,19 @@ CPPFLAGS-test-cond-printers.c := $(CFLAGS-printers-tests)
|
||||
CPPFLAGS-test-rwlockattr-printers.c := $(CFLAGS-printers-tests)
|
||||
CPPFLAGS-test-rwlock-printers.c := $(CFLAGS-printers-tests)
|
||||
|
||||
+# Reuse the CFLAGS setting for the GDB attaching test. It needs
|
||||
+# debugging information.
|
||||
+CFLAGS-tst-pthread-gdb-attach.c := $(CFLAGS-printers-tests)
|
||||
+CPPFLAGS-tst-pthread-gdb-attach.c := $(CFLAGS-printers-tests)
|
||||
+ifeq ($(build-shared)$(build-hardcoded-path-in-tests),yesno)
|
||||
+CPPFLAGS-tst-pthread-gdb-attach.c += -DDO_ADD_SYMBOL_FILE=1
|
||||
+else
|
||||
+CPPFLAGS-tst-pthread-gdb-attach.c += -DDO_ADD_SYMBOL_FILE=0
|
||||
+endif
|
||||
+CFLAGS-tst-pthread-gdb-attach-static.c := $(CFLAGS-printers-tests)
|
||||
+CPPFLAGS-tst-pthread-gdb-attach-static.c := \
|
||||
+ $(CFLAGS-printers-tests) -DDO_ADD_SYMBOL_FILE=0
|
||||
+
|
||||
ifeq ($(build-shared),yes)
|
||||
tests-printers-libs := $(shared-thread-library)
|
||||
else
|
||||
@@ -430,7 +444,8 @@ link-libc-static := $(common-objpfx)libc.a $(static-gnulib) \
|
||||
tests-static += tst-stackguard1-static \
|
||||
tst-cancel24-static \
|
||||
tst-mutex8-static tst-mutexpi8-static tst-sem11-static \
|
||||
- tst-sem12-static tst-cond11-static
|
||||
+ tst-sem12-static tst-cond11-static \
|
||||
+ tst-pthread-gdb-attach-static
|
||||
|
||||
tests += tst-cancel24-static
|
||||
|
||||
diff --git a/nptl/pthread_create.c b/nptl/pthread_create.c
|
||||
index 6c645aff48..f13d8e44a4 100644
|
||||
--- a/nptl/pthread_create.c
|
||||
+++ b/nptl/pthread_create.c
|
||||
@@ -51,6 +51,14 @@ static td_thr_events_t __nptl_threads_events __attribute_used__;
|
||||
/* Pointer to descriptor with the last event. */
|
||||
static struct pthread *__nptl_last_event __attribute_used__;
|
||||
|
||||
+#ifdef SHARED
|
||||
+/* This variable is used to access _rtld_global from libthread_db. If
|
||||
+ GDB loads libpthread before ld.so, it is not possible to resolve
|
||||
+ _rtld_global directly during libpthread initialization. */
|
||||
+static struct rtld_global *__nptl_rtld_global __attribute_used__
|
||||
+ = &_rtld_global;
|
||||
+#endif
|
||||
+
|
||||
/* Number of threads running. */
|
||||
unsigned int __nptl_nthreads = 1;
|
||||
|
||||
diff --git a/nptl/tst-pthread-gdb-attach-static.c b/nptl/tst-pthread-gdb-attach-static.c
|
||||
new file mode 100644
|
||||
index 0000000000..e159632cac
|
||||
--- /dev/null
|
||||
+++ b/nptl/tst-pthread-gdb-attach-static.c
|
||||
@@ -0,0 +1 @@
|
||||
+#include "tst-pthread-gdb-attach.c"
|
||||
diff --git a/nptl/tst-pthread-gdb-attach.c b/nptl/tst-pthread-gdb-attach.c
|
||||
new file mode 100644
|
||||
index 0000000000..0603ad844d
|
||||
--- /dev/null
|
||||
+++ b/nptl/tst-pthread-gdb-attach.c
|
||||
@@ -0,0 +1,143 @@
|
||||
+/* Smoke testing GDB process attach with thread-local variable access.
|
||||
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
||||
+ This file is part of the GNU C Library.
|
||||
+
|
||||
+ The GNU C Library is free software; you can redistribute it and/or
|
||||
+ modify it under the terms of the GNU Lesser General Public
|
||||
+ License as published by the Free Software Foundation; either
|
||||
+ version 2.1 of the License, or (at your option) any later version.
|
||||
+
|
||||
+ The GNU C Library is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ Lesser General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU Lesser General Public
|
||||
+ License along with the GNU C Library; if not, see
|
||||
+ <https://www.gnu.org/licenses/>. */
|
||||
+
|
||||
+/* This test runs GDB against a forked copy of itself, to check
|
||||
+ whether libthread_db can be loaded, and that access to thread-local
|
||||
+ variables works. */
|
||||
+
|
||||
+#include <errno.h>
|
||||
+#include <stdlib.h>
|
||||
+#include <support/check.h>
|
||||
+#include <support/support.h>
|
||||
+#include <support/temp_file.h>
|
||||
+#include <support/test-driver.h>
|
||||
+#include <support/xstdio.h>
|
||||
+#include <support/xthread.h>
|
||||
+#include <support/xunistd.h>
|
||||
+#include <unistd.h>
|
||||
+
|
||||
+/* Starts out as zero, changed to 1 or 2 by the debugger, depending on
|
||||
+ the thread. */
|
||||
+__thread volatile int altered_by_debugger;
|
||||
+
|
||||
+/* Writes the GDB script to run the test to PATH. */
|
||||
+static void
|
||||
+write_gdbscript (const char *path, int tested_pid)
|
||||
+{
|
||||
+ FILE *fp = xfopen (path, "w");
|
||||
+ fprintf (fp,
|
||||
+ "set trace-commands on\n"
|
||||
+ "set debug libthread-db 1\n"
|
||||
+#if DO_ADD_SYMBOL_FILE
|
||||
+ /* Do not do this unconditionally to work around a GDB
|
||||
+ assertion failure: ../../gdb/symtab.c:6404:
|
||||
+ internal-error: CORE_ADDR get_msymbol_address(objfile*,
|
||||
+ const minimal_symbol*): Assertion `(objf->flags &
|
||||
+ OBJF_MAINLINE) == 0' failed. */
|
||||
+ "add-symbol-file %1$s/nptl/tst-pthread-gdb-attach\n"
|
||||
+#endif
|
||||
+ "set auto-load safe-path %1$s/nptl_db\n"
|
||||
+ "set libthread-db-search-path %1$s/nptl_db\n"
|
||||
+ "attach %2$d\n",
|
||||
+ support_objdir_root, tested_pid);
|
||||
+ fputs ("break debugger_inspection_point\n"
|
||||
+ "continue\n"
|
||||
+ "thread 1\n"
|
||||
+ "print altered_by_debugger\n"
|
||||
+ "print altered_by_debugger = 1\n"
|
||||
+ "thread 2\n"
|
||||
+ "print altered_by_debugger\n"
|
||||
+ "print altered_by_debugger = 2\n"
|
||||
+ "continue\n",
|
||||
+ fp);
|
||||
+ xfclose (fp);
|
||||
+}
|
||||
+
|
||||
+/* The test sets a breakpoint on this function and alters the
|
||||
+ altered_by_debugger thread-local variable. */
|
||||
+void __attribute__ ((weak))
|
||||
+debugger_inspection_point (void)
|
||||
+{
|
||||
+}
|
||||
+
|
||||
+/* Thread function for the test thread in the subprocess. */
|
||||
+static void *
|
||||
+subprocess_thread (void *closure)
|
||||
+{
|
||||
+ /* Wait until altered_by_debugger changes the value away from 0. */
|
||||
+ while (altered_by_debugger == 0)
|
||||
+ {
|
||||
+ usleep (100 * 1000);
|
||||
+ debugger_inspection_point ();
|
||||
+ }
|
||||
+
|
||||
+ TEST_COMPARE (altered_by_debugger, 2);
|
||||
+ return NULL;
|
||||
+}
|
||||
+
|
||||
+/* This function implements the subprocess under test. It creates a
|
||||
+ second thread, waiting for its value to change to 2, and checks
|
||||
+ that the main thread also changed its value to 1. */
|
||||
+static void
|
||||
+in_subprocess (void)
|
||||
+{
|
||||
+ pthread_t thr = xpthread_create (NULL, subprocess_thread, NULL);
|
||||
+ TEST_VERIFY (xpthread_join (thr) == NULL);
|
||||
+ TEST_COMPARE (altered_by_debugger, 1);
|
||||
+ _exit (0);
|
||||
+}
|
||||
+
|
||||
+static int
|
||||
+do_test (void)
|
||||
+{
|
||||
+ pid_t tested_pid = xfork ();
|
||||
+ if (tested_pid == 0)
|
||||
+ in_subprocess ();
|
||||
+ char *tested_pid_string = xasprintf ("%d", tested_pid);
|
||||
+
|
||||
+ char *gdbscript;
|
||||
+ xclose (create_temp_file ("tst-pthread-gdb-attach-", &gdbscript));
|
||||
+ write_gdbscript (gdbscript, tested_pid);
|
||||
+
|
||||
+ pid_t gdb_pid = xfork ();
|
||||
+ if (gdb_pid == 0)
|
||||
+ {
|
||||
+ clearenv ();
|
||||
+ xdup2 (STDOUT_FILENO, STDERR_FILENO);
|
||||
+ execlp ("gdb", "gdb", "-nx", "-batch", "-x", gdbscript, NULL);
|
||||
+ if (errno == ENOENT)
|
||||
+ _exit (EXIT_UNSUPPORTED);
|
||||
+ else
|
||||
+ _exit (1);
|
||||
+ }
|
||||
+
|
||||
+ int status;
|
||||
+ TEST_COMPARE (xwaitpid (gdb_pid, &status, 0), gdb_pid);
|
||||
+ if (WIFEXITED (status) && WEXITSTATUS (status) == EXIT_UNSUPPORTED)
|
||||
+ /* gdb is not installed. */
|
||||
+ return EXIT_UNSUPPORTED;
|
||||
+ TEST_COMPARE (status, 0);
|
||||
+ TEST_COMPARE (xwaitpid (tested_pid, &status, 0), tested_pid);
|
||||
+ TEST_COMPARE (status, 0);
|
||||
+
|
||||
+ free (tested_pid_string);
|
||||
+ free (gdbscript);
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+#include <support/test-driver.c>
|
||||
diff --git a/nptl_db/structs.def b/nptl_db/structs.def
|
||||
index 999a9fc35a..8a613dd2f5 100644
|
||||
--- a/nptl_db/structs.def
|
||||
+++ b/nptl_db/structs.def
|
||||
@@ -100,8 +100,7 @@ DB_STRUCT_FIELD (pthread, dtvp)
|
||||
#endif
|
||||
|
||||
#if !(IS_IN (libpthread) && !defined SHARED)
|
||||
-DB_STRUCT (rtld_global)
|
||||
-DB_RTLD_VARIABLE (_rtld_global)
|
||||
+DB_VARIABLE (__nptl_rtld_global)
|
||||
#endif
|
||||
DB_RTLD_GLOBAL_FIELD (dl_tls_dtv_slotinfo_list)
|
||||
DB_RTLD_GLOBAL_FIELD (dl_stack_user)
|
||||
diff --git a/nptl_db/td_init.c b/nptl_db/td_init.c
|
||||
index 1d15681228..06b5adc5c2 100644
|
||||
--- a/nptl_db/td_init.c
|
||||
+++ b/nptl_db/td_init.c
|
||||
@@ -33,13 +33,14 @@ td_init (void)
|
||||
bool
|
||||
__td_ta_rtld_global (td_thragent_t *ta)
|
||||
{
|
||||
- if (ta->ta_addr__rtld_global == 0
|
||||
- && td_mod_lookup (ta->ph, LD_SO, SYM__rtld_global,
|
||||
- &ta->ta_addr__rtld_global) != PS_OK)
|
||||
+ if (ta->ta_addr__rtld_global == 0)
|
||||
{
|
||||
- ta->ta_addr__rtld_global = (void*)-1;
|
||||
- return false;
|
||||
+ psaddr_t rtldglobalp;
|
||||
+ if (DB_GET_VALUE (rtldglobalp, ta, __nptl_rtld_global, 0) == TD_OK)
|
||||
+ ta->ta_addr__rtld_global = rtldglobalp;
|
||||
+ else
|
||||
+ ta->ta_addr__rtld_global = (void *) -1;
|
||||
}
|
||||
- else
|
||||
- return ta->ta_addr__rtld_global != (void*)-1;
|
||||
+
|
||||
+ return ta->ta_addr__rtld_global != (void *)-1;
|
||||
}
|
||||
diff --git a/nptl_db/thread_dbP.h b/nptl_db/thread_dbP.h
|
||||
index 580a70c471..712fa3aeb6 100644
|
||||
--- a/nptl_db/thread_dbP.h
|
||||
+++ b/nptl_db/thread_dbP.h
|
||||
@@ -108,6 +108,8 @@ struct td_thragent
|
||||
# undef DB_SYMBOL
|
||||
# undef DB_VARIABLE
|
||||
|
||||
+ psaddr_t ta_addr__rtld_global;
|
||||
+
|
||||
/* The method of locating a thread's th_unique value. */
|
||||
enum
|
||||
{
|
||||
--
|
||||
2.31.1
|
||||
|
|
@ -0,0 +1,135 @@
|
|||
From f553dc066071a4465321fbc122bed8a75afd996b Mon Sep 17 00:00:00 2001
|
||||
From: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Thu, 22 Apr 2021 11:07:43 +0200
|
||||
Subject: [PATCH 405/576] nptl: Check for compatible GDB in
|
||||
nptl/tst-pthread-gdb-attach
|
||||
|
||||
Also do not clear the subprocess environment, in case running
|
||||
GDB needs certain environment variables.
|
||||
---
|
||||
nptl/tst-pthread-gdb-attach.c | 78 ++++++++++++++++++++++++++++++++++-
|
||||
1 file changed, 76 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/nptl/tst-pthread-gdb-attach.c b/nptl/tst-pthread-gdb-attach.c
|
||||
index 0603ad844d..901a120034 100644
|
||||
--- a/nptl/tst-pthread-gdb-attach.c
|
||||
+++ b/nptl/tst-pthread-gdb-attach.c
|
||||
@@ -20,8 +20,12 @@
|
||||
whether libthread_db can be loaded, and that access to thread-local
|
||||
variables works. */
|
||||
|
||||
+#include <elf.h>
|
||||
#include <errno.h>
|
||||
+#include <fcntl.h>
|
||||
+#include <stdbool.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <support/check.h>
|
||||
#include <support/support.h>
|
||||
#include <support/temp_file.h>
|
||||
@@ -35,6 +39,49 @@
|
||||
the thread. */
|
||||
__thread volatile int altered_by_debugger;
|
||||
|
||||
+/* Common prefix between 32-bit and 64-bit ELF. */
|
||||
+struct elf_prefix
|
||||
+{
|
||||
+ unsigned char e_ident[EI_NIDENT];
|
||||
+ uint16_t e_type;
|
||||
+ uint16_t e_machine;
|
||||
+ uint32_t e_version;
|
||||
+};
|
||||
+_Static_assert (sizeof (struct elf_prefix) == EI_NIDENT + 8,
|
||||
+ "padding in struct elf_prefix");
|
||||
+
|
||||
+/* Reads the ELF header from PATH. Returns true if the header can be
|
||||
+ read, false if the file is too short. */
|
||||
+static bool
|
||||
+read_elf_header (const char *path, struct elf_prefix *elf)
|
||||
+{
|
||||
+ int fd = xopen (path, O_RDONLY, 0);
|
||||
+ bool result = read (fd, elf, sizeof (*elf)) == sizeof (*elf);
|
||||
+ xclose (fd);
|
||||
+ return result;
|
||||
+}
|
||||
+
|
||||
+/* Searches for "gdb" alongside the path variable. See execvpe. */
|
||||
+static char *
|
||||
+find_gdb (void)
|
||||
+{
|
||||
+ const char *path = getenv ("PATH");
|
||||
+ if (path == NULL)
|
||||
+ return NULL;
|
||||
+ while (true)
|
||||
+ {
|
||||
+ const char *colon = strchrnul (path, ':');
|
||||
+ char *candidate = xasprintf ("%.*s/gdb", (int) (colon - path), path);
|
||||
+ if (access (candidate, X_OK) == 0)
|
||||
+ return candidate;
|
||||
+ free (candidate);
|
||||
+ if (*colon == '\0')
|
||||
+ break;
|
||||
+ path = colon + 1;
|
||||
+ }
|
||||
+ return NULL;
|
||||
+}
|
||||
+
|
||||
/* Writes the GDB script to run the test to PATH. */
|
||||
static void
|
||||
write_gdbscript (const char *path, int tested_pid)
|
||||
@@ -105,6 +152,33 @@ in_subprocess (void)
|
||||
static int
|
||||
do_test (void)
|
||||
{
|
||||
+ char *gdb_path = find_gdb ();
|
||||
+ if (gdb_path == NULL)
|
||||
+ FAIL_UNSUPPORTED ("gdb command not found in PATH: %s", getenv ("PATH"));
|
||||
+
|
||||
+ /* Check that libthread_db is compatible with the gdb architecture
|
||||
+ because gdb loads it via dlopen. */
|
||||
+ {
|
||||
+ char *threaddb_path = xasprintf ("%s/nptl_db/libthread_db.so",
|
||||
+ support_objdir_root);
|
||||
+ struct elf_prefix elf_threaddb;
|
||||
+ TEST_VERIFY_EXIT (read_elf_header (threaddb_path, &elf_threaddb));
|
||||
+ struct elf_prefix elf_gdb;
|
||||
+ /* If the ELF header cannot be read or "gdb" is not an ELF file,
|
||||
+ assume this is a wrapper script that can run. */
|
||||
+ if (read_elf_header (gdb_path, &elf_gdb)
|
||||
+ && memcmp (&elf_gdb, ELFMAG, SELFMAG) == 0)
|
||||
+ {
|
||||
+ if (elf_gdb.e_ident[EI_CLASS] != elf_threaddb.e_ident[EI_CLASS])
|
||||
+ FAIL_UNSUPPORTED ("GDB at %s has wrong class", gdb_path);
|
||||
+ if (elf_gdb.e_ident[EI_DATA] != elf_threaddb.e_ident[EI_DATA])
|
||||
+ FAIL_UNSUPPORTED ("GDB at %s has wrong data", gdb_path);
|
||||
+ if (elf_gdb.e_machine != elf_threaddb.e_machine)
|
||||
+ FAIL_UNSUPPORTED ("GDB at %s has wrong machine", gdb_path);
|
||||
+ }
|
||||
+ free (threaddb_path);
|
||||
+ }
|
||||
+
|
||||
pid_t tested_pid = xfork ();
|
||||
if (tested_pid == 0)
|
||||
in_subprocess ();
|
||||
@@ -117,9 +191,8 @@ do_test (void)
|
||||
pid_t gdb_pid = xfork ();
|
||||
if (gdb_pid == 0)
|
||||
{
|
||||
- clearenv ();
|
||||
xdup2 (STDOUT_FILENO, STDERR_FILENO);
|
||||
- execlp ("gdb", "gdb", "-nx", "-batch", "-x", gdbscript, NULL);
|
||||
+ execl (gdb_path, "gdb", "-nx", "-batch", "-x", gdbscript, NULL);
|
||||
if (errno == ENOENT)
|
||||
_exit (EXIT_UNSUPPORTED);
|
||||
else
|
||||
@@ -137,6 +210,7 @@ do_test (void)
|
||||
|
||||
free (tested_pid_string);
|
||||
free (gdbscript);
|
||||
+ free (gdb_path);
|
||||
return 0;
|
||||
}
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
|
@ -0,0 +1,26 @@
|
|||
From 6f3e54d404cfe1ba7d1444e6dfcfd77b102d9287 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Thu, 22 Apr 2021 19:53:15 +0200
|
||||
Subject: [PATCH 409/576] nptl: Do not build nptl/tst-pthread-gdb-attach as PIE
|
||||
|
||||
---
|
||||
nptl/Makefile | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/nptl/Makefile b/nptl/Makefile
|
||||
index a3d1ef8d66..294bb2faa4 100644
|
||||
--- a/nptl/Makefile
|
||||
+++ b/nptl/Makefile
|
||||
@@ -377,6 +377,9 @@ endif
|
||||
CFLAGS-tst-pthread-gdb-attach-static.c := $(CFLAGS-printers-tests)
|
||||
CPPFLAGS-tst-pthread-gdb-attach-static.c := \
|
||||
$(CFLAGS-printers-tests) -DDO_ADD_SYMBOL_FILE=0
|
||||
+# As of version 9.2, GDB cannot attach properly to PIE programs that
|
||||
+# were launched with an explicit ld.so invocation.
|
||||
+tst-pthread-gdb-attach-no-pie = yes
|
||||
|
||||
ifeq ($(build-shared),yes)
|
||||
tests-printers-libs := $(shared-thread-library)
|
||||
--
|
||||
2.31.1
|
||||
|
|
@ -15,7 +15,7 @@ noautobuild=1
|
|||
|
||||
pkgname=glibc
|
||||
pkgver=2.33
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
arch=(x86_64)
|
||||
url='https://www.gnu.org/software/libc'
|
||||
license=(GPL LGPL)
|
||||
|
@ -28,7 +28,10 @@ source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
|
|||
locale.gen.txt
|
||||
locale-gen
|
||||
sdt.h sdt-config.h
|
||||
bz27343.patch)
|
||||
bz27343.patch
|
||||
0001-nptl_db-Support-different-libpthread-ld.so-load-orde.patch
|
||||
0002-nptl-Check-for-compatible-GDB-in-nptl-tst-pthread-gd.patch
|
||||
0003-nptl-Do-not-build-nptl-tst-pthread-gdb-attach-as-PIE.patch)
|
||||
validpgpkeys=(7273542B39962DF7B299931416792B4EA25340F8 # Carlos O'Donell
|
||||
BC7C7372637EC10C57D7AA6579C43DFBF1CF2187) # Siddhesh Poyarekar
|
||||
md5sums=('390bbd889c7e8e8a7041564cb6b27cca'
|
||||
|
@ -37,7 +40,10 @@ md5sums=('390bbd889c7e8e8a7041564cb6b27cca'
|
|||
'476e9113489f93b348b21e144b6a8fcf'
|
||||
'91fec3b7e75510ae2ac42533aa2e695e'
|
||||
'680df504c683640b02ed4a805797c0b2'
|
||||
'cfe57018d06bf748b8ca1779980fef33')
|
||||
'cfe57018d06bf748b8ca1779980fef33'
|
||||
'78f041fc66fee4ee372f13b00a99ff72'
|
||||
'9e418efa189c20053e887398df2253cf'
|
||||
'7a09f1693613897add1791e7aead19c9')
|
||||
|
||||
prepare() {
|
||||
mkdir -p glibc-build
|
||||
|
@ -47,6 +53,15 @@ prepare() {
|
|||
|
||||
# commit c3479fb7939898ec22c655c383454d6e8b982a67
|
||||
patch -p1 -i "$srcdir"/bz27343.patch
|
||||
|
||||
# nptl_db: Support different libpthread/ld.so load orders (bug 27744)
|
||||
patch -p1 -i "$srcdir"/0001-nptl_db-Support-different-libpthread-ld.so-load-orde.patch
|
||||
|
||||
# nptl: Check for compatible GDB in nptl/tst-pthread-gdb-attach
|
||||
patch -p1 -i "$srcdir"/0002-nptl-Check-for-compatible-GDB-in-nptl-tst-pthread-gd.patch
|
||||
|
||||
# nptl: Do not build nptl/tst-pthread-gdb-attach as PIE
|
||||
patch -p1 -i "$srcdir"/0003-nptl-Do-not-build-nptl-tst-pthread-gdb-attach-as-PIE.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue