community/linux-tools to 3.16-1

This commit is contained in:
Kevin Mihelich 2014-08-05 01:19:48 +00:00
parent 1ce951fd17
commit cc0f5de8eb
3 changed files with 19 additions and 22 deletions

View file

@ -1,13 +0,0 @@
diff --git a/tools/power/acpi/tools/acpidump/acpidump.c b/tools/power/acpi/tools/acpidump/acpidump.c
index a84553a..df453cc 100644
--- a/tools/power/acpi/tools/acpidump/acpidump.c
+++ b/tools/power/acpi/tools/acpidump/acpidump.c
@@ -49,8 +49,6 @@ typedef int s32;
typedef unsigned char u8;
typedef unsigned short u16;
typedef unsigned int u32;
-typedef unsigned long long u64;
-typedef long long s64;
#endif
#include <sys/mman.h>

View file

@ -0,0 +1,13 @@
# Copyright 2014 Sébastien Luttringer
--- a/tools/thermal/tmon/Makefile
+++ b/tools/thermal/tmon/Makefile
@@ -21,7 +21,7 @@ OBJS = tmon.o tui.o sysfs.o pid.o
OBJS +=
tmon: $(OBJS) Makefile tmon.h
- $(CC) ${CFLAGS} $(LDFLAGS) $(OBJS) -o $(TARGET) -lm -lpanel -lncursesw -ltinfo -lpthread
+ $(CC) ${CFLAGS} $(LDFLAGS) $(OBJS) -o $(TARGET) -lm -lpanel -lncursesw -lpthread
valgrind: tmon
sudo valgrind -v --track-origins=yes --tool=memcheck --leak-check=yes --show-reachable=yes --num-callers=20 --track-fds=yes ./$(TARGET) 1> /dev/null

View file

@ -16,7 +16,7 @@ pkgname=(
'tmon'
'usbip'
)
pkgver=3.15
pkgver=3.16
pkgrel=1
license=('GPL2')
arch=('i686' 'x86_64')
@ -35,17 +35,16 @@ makedepends+=('glib2' 'sysfsutils' 'udev')
makedepends+=('ncurses')
groups=("$pkgbase")
source=("http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$pkgver.tar.xz"
"http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.7.xz"
#"http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.7.xz"
'cpupower.default'
'cpupower.systemd'
'cpupower.service'
'usbipd.service'
'01-fix-perf-python.patch'
'02-archlinux-paths.patch'
'03-fix-acpidump-compile-error.patch')
'03-fix-tmon-ltinfo.patch')
# http://www.kernel.org/pub/linux/kernel/v3.x/sha256sums.asc
sha256sums=('c3927e87be4040fa8aca1b58663dc0776aaf00485604ff88a623be2f3fb07794'
'25f0767908e736a2388fe36810712ee3faa6c86c5255516496d5942ba1ffb451'
sha256sums=('4813ad7927a7d92e5339a873ab16201b242b2748934f12cb5df9ba2cfe1d77a0'
'6d54f1dcd4d9441644a7ef4445f6633158e666fddaa6f06bb6656ab2ff4509d4'
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
'fbf6e0ce6eb0ef15703fe212958de6ca46e62188900b5e9f9272ed3cc9cfd54e'
@ -53,16 +52,14 @@ sha256sums=('c3927e87be4040fa8aca1b58663dc0776aaf00485604ff88a623be2f3fb07794'
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
'fce128f5e0abfa6916d5cb881456d892d1b163b9639166a4c6c1d53e4dc5086a'
'eb866a589a26b1979ffb2fe08be09417e277a4befac34bdb279a6bb3a27b0570'
'c791c9eb95e9db28b5a6530232885def9de941d0cbeb9e8b3b999f0567de3199')
'7547815bb761d49d198b85f95011535713c2ed4a004f249a9cf6ba985af8c4ed')
prepare() {
cd linux-$pkgver
#patch -N -p1 -i "$srcdir/patch-$pkgver.7"
patch -N -p1 -i "$srcdir/01-fix-perf-python.patch"
patch -N -p1 -i "$srcdir/02-archlinux-paths.patch"
# the following patch is a fix for compile error in 3.15
# in the 3.16 acpidump code has been reimplemented and patch is not needed.
patch -N -p1 -i "$srcdir/03-fix-acpidump-compile-error.patch"
patch -N -p1 -i "$srcdir/03-fix-tmon-ltinfo.patch"
}
build() {