mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox to 48.0-1
This commit is contained in:
parent
7b6d591d45
commit
cc18a41641
3 changed files with 18 additions and 92 deletions
|
@ -7,10 +7,11 @@
|
|||
# - patch to remove NEON/SIMD checks from configure
|
||||
|
||||
highmem=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=47.0.1
|
||||
pkgrel=1.1
|
||||
pkgver=48.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
|
@ -30,23 +31,21 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
|
|||
vendor.js
|
||||
firefox-symbolic.svg
|
||||
firefox-gtk3-20.patch
|
||||
mozilla-1245076.patch
|
||||
mozilla-1245076-1.patch
|
||||
no-libnotify.patch
|
||||
no-neon.patch
|
||||
mozilla-1253216.patch)
|
||||
sha256sums=('5ac36c3481dde80ef2e36237badef6cb8ec5fe7e3b5ac1728839477de0cc034c'
|
||||
'039c7c5162ec19a5814c97e33f577e3074358484782181941e9629732456bc54'
|
||||
mozilla-1253216.patch
|
||||
mozilla-build-arm.patch)
|
||||
sha256sums=('f474113a1ee75a01d43e270bf438ba78b9f7f2e397a66652b43603235fa76e21'
|
||||
'5b5de230903b8e5e29e3f3c95d2814218335407ae01e022924d0a2c41d804390'
|
||||
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
|
||||
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
|
||||
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
|
||||
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
|
||||
'd5e1b9a702dc693184494899fc4cd57ac206e1fd5415a8e5520b8ff3b822e734'
|
||||
'05574c7d0f259da161bcd0e2e8bc9a19401e620ff29439da935d349eebb60efa'
|
||||
'6e7cba25c52b246da183b8309e7b56208bd991d1a7adb40063c5702a6f3722ea'
|
||||
'c984c8bda3c173349d98f3fa71ec8ff8e8b74e6ca20a3f39f33596dbb4c4d1e8'
|
||||
'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
|
||||
'c1cceeb8875eee7c61289e82c6c6b0f338c045152f3a5e1a8d87bad67548397f'
|
||||
'1e7ef08acd46aeacc8cd8b2c89012983fb2c8c18648e0f3e9371b0c76caedbde')
|
||||
'fbb6011501a74a8ea6d01c041870fcefb7ef2859c134aedc676e5f6452833f65'
|
||||
'56eecee8162c138c442773d66483886f1242c8dd2b16eed5711ae5e63d9b0e3a')
|
||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -74,10 +73,6 @@ prepare() {
|
|||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1234158
|
||||
patch -Np1 -i ../firefox-gtk3-20.patch
|
||||
|
||||
# GCC 6
|
||||
patch -Np1 -i ../mozilla-1245076.patch
|
||||
patch -Np1 -i ../mozilla-1245076-1.patch
|
||||
|
||||
# Notifications with libnotify are broken
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1236150
|
||||
patch -Np1 -i ../no-libnotify.patch
|
||||
|
@ -95,13 +90,17 @@ prepare() {
|
|||
ln -s /usr/bin/python2 "$srcdir/path/python"
|
||||
|
||||
[[ $CARCH != "aarch64" ]] && echo "ac_add_options --disable-ion" >> .mozconfig \
|
||||
&& echo "ac_add_options --disable-elf-hack" >> .mozconfig \
|
||||
&& echo "ac_add_options --disable-yarr-jit" >> .mozconfig
|
||||
&& echo "ac_add_options --disable-elf-hack" >> .mozconfig
|
||||
[[ $CARCH == "aarch64" ]] && echo "ac_add_options --disable-gold" >> .mozconfig \
|
||||
&& echo 'ac_add_options --disable-jemalloc' >> .mozconfig \
|
||||
&& echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
|
||||
patch -p1 -i ../no-neon.patch
|
||||
patch -p2 -i ../mozilla-1253216.patch
|
||||
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
# patch -p1 -i ../no-neon.patch
|
||||
patch -p1 -i ../mozilla-1253216.patch
|
||||
patch -p1 -i ../mozilla-build-arm.patch
|
||||
echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
|
||||
echo "ac_add_options --with-float-abi=hard" >> .mozconfig
|
||||
echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -114,7 +113,6 @@ build() {
|
|||
LDFLAGS+=" -Wl,-z,now"
|
||||
|
||||
# GCC 6
|
||||
CFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
|
||||
CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
|
||||
|
||||
export PATH="$srcdir/path:$PATH"
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
diff --git a/config/gcc-stl-wrapper.template.h b/config/gcc-stl-wrapper.template.h
|
||||
--- a/config/gcc-stl-wrapper.template.h
|
||||
+++ b/config/gcc-stl-wrapper.template.h
|
||||
@@ -12,33 +12,39 @@
|
||||
// compiling ObjC.
|
||||
#if defined(__EXCEPTIONS) && __EXCEPTIONS && !(__OBJC__ && __GNUC__ && XP_IOS)
|
||||
# error "STL code can only be used with -fno-exceptions"
|
||||
#endif
|
||||
|
||||
// Silence "warning: #include_next is a GCC extension"
|
||||
#pragma GCC system_header
|
||||
|
||||
+#ifndef moz_dont_include_mozalloc_for_cstdlib
|
||||
+# define moz_dont_include_mozalloc_for_cstdlib
|
||||
+#endif
|
||||
+#ifndef moz_dont_include_mozalloc_for_${HEADER}
|
||||
// mozalloc.h wants <new>; break the cycle by always explicitly
|
||||
// including <new> here. NB: this is a tad sneaky. Sez the gcc docs:
|
||||
//
|
||||
// `#include_next' does not distinguish between <file> and "file"
|
||||
// inclusion, nor does it check that the file you specify has the
|
||||
// same name as the current file. It simply looks for the file
|
||||
// named, starting with the directory in the search path after the
|
||||
// one where the current file was found.
|
||||
-#include_next <new>
|
||||
+# include_next <new>
|
||||
|
||||
// See if we're in code that can use mozalloc. NB: this duplicates
|
||||
// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
|
||||
// can't build with that being included before base/basictypes.h.
|
||||
-#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
|
||||
-# include "mozilla/mozalloc.h"
|
||||
-#else
|
||||
-# error "STL code can only be used with infallible ::operator new()"
|
||||
+# if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
|
||||
+# include "mozilla/mozalloc.h"
|
||||
+# else
|
||||
+# error "STL code can only be used with infallible ::operator new()"
|
||||
+# endif
|
||||
+
|
||||
#endif
|
||||
|
||||
#if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)
|
||||
// Enable checked iterators and other goodies
|
||||
//
|
||||
// FIXME/bug 551254: gcc's debug STL implementation requires -frtti.
|
||||
// Figure out how to resolve this with -fno-rtti. Maybe build with
|
||||
// -frtti in DEBUG builds?
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
diff --git a/gfx/graphite2/src/Collider.cpp b/gfx/graphite2/src/Collider.cpp
|
||||
--- a/gfx/graphite2/src/Collider.cpp
|
||||
+++ b/gfx/graphite2/src/Collider.cpp
|
||||
@@ -21,17 +21,17 @@
|
||||
|
||||
Alternatively, the contents of this file may be used under the terms of the
|
||||
Mozilla Public License (http://mozilla.org/MPL) or the GNU General Public
|
||||
License, as published by the Free Software Foundation, either version 2
|
||||
of the License or (at your option) any later version.
|
||||
*/
|
||||
#include <algorithm>
|
||||
#include <limits>
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
#include <string>
|
||||
#include <functional>
|
||||
#include "inc/Collider.h"
|
||||
#include "inc/Segment.h"
|
||||
#include "inc/Slot.h"
|
||||
#include "inc/GlyphCache.h"
|
||||
#include "inc/Sparse.h"
|
||||
|
||||
|
Loading…
Reference in a new issue