extra/thunderbird to 68.8.0-1

This commit is contained in:
Kevin Mihelich 2020-05-09 15:38:34 +00:00
parent 421de37070
commit cc44304835
2 changed files with 4 additions and 79 deletions

View file

@ -13,26 +13,24 @@ buildarch=12
highmem=1 highmem=1
pkgname=thunderbird pkgname=thunderbird
pkgver=68.7.0 pkgver=68.8.0
pkgrel=2 pkgrel=1
pkgdesc='Standalone mail and news reader from mozilla.org' pkgdesc='Standalone mail and news reader from mozilla.org'
url='https://www.mozilla.org/thunderbird/' url='https://www.mozilla.org/thunderbird/'
arch=(x86_64) arch=(x86_64)
license=(MPL GPL LGPL) license=(MPL GPL LGPL)
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
nss hunspell sqlite ttf-font icu) # libvpx nss hunspell sqlite ttf-font icu) # libvpx
makedepends=(unzip zip diffutils python python2 yasm nasm mesa imake libpulse inetutils xorg-server-xvfb makedepends=(unzip zip diffutils python python2 yasm nasm mesa imake libpulse inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm gtk2 cbindgen nodejs) autoconf2.13 rust clang llvm gtk2 cbindgen nodejs)
optdepends=('libcanberra: sound support') optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags) options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc} source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc}
rust-1.43.patch
$pkgname.desktop $pkgname.desktop
arm.patch arm.patch
Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch) Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch)
sha512sums=('fae763030b7a54930291a10f298b7fa4ffc400849082f576556b9040d095f1007ae686daf1241dff8b73bac35c14acf21c156a18a3e16d62a7719c6cc34e4d1f' sha512sums=('1af899913454e97ba3b08a090f775c0ce65ae6d8c1d31171017f09355a0bb126516d4770b4a4a0e774419497c404fa70dcfcafdf767c9caba0bf1d658c0d9350'
'SKIP' 'SKIP'
'8833130802e2bfb34036444d6855c96a5b819f90c9835decd816bbf50dc507a71b2c343fd53d3fec0d79df791bb56436b06f2430abbeb70c726574a57c385d54'
'a0061fcb2a7f66061e336a8d95948592f56f4752e56467f14ba63846720ebf845cce7511d1a2637e3b80d5a1ffdaa2fb783fa37195103425ef65222d45372012' 'a0061fcb2a7f66061e336a8d95948592f56f4752e56467f14ba63846720ebf845cce7511d1a2637e3b80d5a1ffdaa2fb783fa37195103425ef65222d45372012'
'c25883c4860e511a99d9fbfba5b824145c0862729101721605725f609ca2a41848b741dd100eff390f57031dc5f14af3ea30133de30f75cb20197c420ae20972' 'c25883c4860e511a99d9fbfba5b824145c0862729101721605725f609ca2a41848b741dd100eff390f57031dc5f14af3ea30133de30f75cb20197c420ae20972'
'8ca4f72f1fc0a7fc128f05112d8f77be5350826010069ee3b787989131f02b82d014a4781e97ebe5694852c4bb5e87bb5313e562cfb7cb2afb6f904124027e13') '8ca4f72f1fc0a7fc128f05112d8f77be5350826010069ee3b787989131f02b82d014a4781e97ebe5694852c4bb5e87bb5313e562cfb7cb2afb6f904124027e13')
@ -53,8 +51,6 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() { prepare() {
cd $pkgname-$pkgver cd $pkgname-$pkgver
patch -Np1 -i ../rust-1.43.patch
echo -n "$_google_api_key" >google-api-key echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key echo -n "$_mozilla_api_key" >mozilla-api-key

View file

@ -1,71 +0,0 @@
# HG changeset patch
# User Emilio Cobos Álvarez <emilio@crisal.io>
# Date 1568322567 0
# Node ID 773adf85740c7f5f295f9e17bba1d8a95888ee32
# Parent a1824d4c404b8926930c2fbde5c9a14c7bd05763
Bug 1580963 - Cherry-pick some servo changes from a rustc upgrade.
This cherry-picks from Servo commit 98e4a53b724.
Differential Revision: https://phabricator.services.mozilla.com/D45738
diff --git a/servo/components/style/stylesheets/viewport_rule.rs b/servo/components/style/stylesheets/viewport_rule.rs
--- a/servo/components/style/stylesheets/viewport_rule.rs
+++ b/servo/components/style/stylesheets/viewport_rule.rs
@@ -286,38 +286,47 @@ impl<'a, 'b, 'i> DeclarationParser<'i> f
fn parse_value<'t>(
&mut self,
name: CowRcStr<'i>,
input: &mut Parser<'i, 't>,
) -> Result<Vec<ViewportDescriptorDeclaration>, ParseError<'i>> {
macro_rules! declaration {
($declaration:ident($parse:expr)) => {
- declaration!($declaration(value: try!($parse(input)),
- important: input.try(parse_important).is_ok()))
+ declaration!($declaration {
+ value: $parse(input)?,
+ important: input.try(parse_important).is_ok(),
+ })
};
- ($declaration:ident(value: $value:expr, important: $important:expr)) => {
+ ($declaration:ident { value: $value:expr, important: $important:expr, }) => {
ViewportDescriptorDeclaration::new(
self.context.stylesheet_origin,
ViewportDescriptor::$declaration($value),
- $important)
- }
+ $important,
+ )
+ };
}
macro_rules! ok {
($declaration:ident($parse:expr)) => {
Ok(vec![declaration!($declaration($parse))])
};
(shorthand -> [$min:ident, $max:ident]) => {{
let shorthand = parse_shorthand(self.context, input)?;
let important = input.try(parse_important).is_ok();
Ok(vec![
- declaration!($min(value: shorthand.0, important: important)),
- declaration!($max(value: shorthand.1, important: important)),
+ declaration!($min {
+ value: shorthand.0,
+ important: important,
+ }),
+ declaration!($max {
+ value: shorthand.1,
+ important: important,
+ }),
])
}};
}
match_ignore_ascii_case! { &*name,
"min-width" => ok!(MinWidth(|i| ViewportLength::parse(self.context, i))),
"max-width" => ok!(MaxWidth(|i| ViewportLength::parse(self.context, i))),
"width" => ok!(shorthand -> [MinWidth, MaxWidth]),