extra/firefox to 50.0-1

This commit is contained in:
Kevin Mihelich 2016-11-16 01:01:40 +00:00
parent 16af992b9d
commit cc5812593b
4 changed files with 48 additions and 3 deletions

View file

@ -9,7 +9,7 @@
highmem=1
pkgname=firefox
pkgver=49.0.2
pkgver=50.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=('i686' 'x86_64')
@ -28,16 +28,20 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
mozconfig
firefox.desktop
firefox-install-dir.patch
rust-i686.patch
vendor.js
firefox-symbolic.svg
fix-wifi-scanner.diff
mozilla-1253216.patch
mozilla-build-arm.patch)
sha256sums=('67abe9202958c36bf60454c91065953aa8f6ede83ea1c0e9cdb870c3fc3d56d0'
sha256sums=('5da027350aee148dc62cc1ca897db30510be87ca8eab5e67a7adc7a2479b8616'
'640e529734e4e021b99f2e28205d62b915b0884e487bca1b7d81a7d3164676ab'
'75c526e9669b91b4fe5dcea650a1e8419220abb2e9564184f0d984c71eae82e8'
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
'93c5df00f409988bbfa890ac175103476ead3af68f7501973ee70bd11dc472f8'
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
'fbb6011501a74a8ea6d01c041870fcefb7ef2859c134aedc676e5f6452833f65'
'56eecee8162c138c442773d66483886f1242c8dd2b16eed5711ae5e63d9b0e3a')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
@ -62,6 +66,12 @@ prepare() {
cp ../mozconfig .mozconfig
patch -Np1 -i ../firefox-install-dir.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -Np1 -i ../fix-wifi-scanner.diff
# Build with the rust targets we actually ship
patch -Np1 -i ../rust-i686.patch
echo -n "$_google_api_key" >google-api-key
echo "ac_add_options --with-google-api-keyfile=\"$PWD/google-api-key\"" >>.mozconfig

View file

@ -0,0 +1,16 @@
netwerk/wifi/nsWifiScannerDBus.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git c/netwerk/wifi/nsWifiScannerDBus.cpp i/netwerk/wifi/nsWifiScannerDBus.cpp
index 182553e18fa6e104..6fa0a0b023d3e45f 100644
--- c/netwerk/wifi/nsWifiScannerDBus.cpp
+++ i/netwerk/wifi/nsWifiScannerDBus.cpp
@@ -62,7 +62,7 @@ nsWifiScannerDBus::SendMessage(const char* aInterface,
return NS_ERROR_FAILURE;
}
} else if (!strcmp(aFuncCall, "GetAll")) {
- const char* param = "";
+ const char* param = "org.freedesktop.NetworkManager.AccessPoint";
if (!dbus_message_iter_append_basic(&argsIter, DBUS_TYPE_STRING, &param)) {
return NS_ERROR_FAILURE;
}

View file

@ -0,0 +1,16 @@
build/moz.configure/rust.configure | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
index cd86b24153debb1b..44911715e25d95e3 100644
--- c/build/moz.configure/rust.configure
+++ i/build/moz.configure/rust.configure
@@ -81,7 +81,7 @@ def rust_target(rust_compiler, rustc, target, cross_compiling):
# OpenBSD
('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
# Linux
- ('x86', 'Linux'): 'i586-unknown-linux-gnu',
+ ('x86', 'Linux'): 'i686-unknown-linux-gnu',
# Linux
('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
# OS X and iOS

View file

@ -7,3 +7,6 @@ pref("browser.shell.checkDefaultBrowser", false);
// Don't disable our bundled extensions in the application directory
pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);
// Opt all of us into e10s, instead of just 50%
pref("browser.tabs.remote.autostart", true);