mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-raspberrypi-latest to 3.17.1-1
This commit is contained in:
parent
1804a1a40b
commit
cc5cab4a07
3 changed files with 61 additions and 43 deletions
|
@ -0,0 +1,38 @@
|
|||
From 0daf37ef3f4ad76f3e56f888b48111c1b6c9119d Mon Sep 17 00:00:00 2001
|
||||
From: Arianna Avanzini <avanzini.arianna@gmail.com>
|
||||
Date: Sun, 17 Aug 2014 07:07:24 -0500
|
||||
Subject: [PATCH] block: Switch from BFQ-v7r6 for 3.16.0 to BFQ-v7r6 for
|
||||
3.17.0-rc1
|
||||
|
||||
---
|
||||
block/bfq-cgroup.c | 2 +-
|
||||
block/bfq.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/block/bfq-cgroup.c b/block/bfq-cgroup.c
|
||||
index f742806..eb140eb 100644
|
||||
--- a/block/bfq-cgroup.c
|
||||
+++ b/block/bfq-cgroup.c
|
||||
@@ -871,7 +871,7 @@ struct cgroup_subsys bfqio_cgrp_subsys = {
|
||||
.can_attach = bfqio_can_attach,
|
||||
.attach = bfqio_attach,
|
||||
.css_free = bfqio_destroy,
|
||||
- .base_cftypes = bfqio_files,
|
||||
+ .legacy_cftypes = bfqio_files,
|
||||
};
|
||||
#else
|
||||
static inline void bfq_init_entity(struct bfq_entity *entity,
|
||||
diff --git a/block/bfq.h b/block/bfq.h
|
||||
index ebbd040..34b37bf 100644
|
||||
--- a/block/bfq.h
|
||||
+++ b/block/bfq.h
|
||||
@@ -1,5 +1,5 @@
|
||||
/*
|
||||
- * BFQ-v7r5 for 3.16.0: data structures and common functions prototypes.
|
||||
+ * BFQ-v7r5 for 3.17.0-rc1: data structures and common functions prototypes.
|
||||
*
|
||||
* Based on ideas and code from CFQ:
|
||||
* Copyright (C) 2003 Jens Axboe <axboe@kernel.dk>
|
||||
--
|
||||
2.0.4
|
||||
|
|
@ -5,11 +5,11 @@
|
|||
buildarch=18
|
||||
|
||||
pkgbase=linux-raspberrypi-latest
|
||||
_commit=ba27be53aa6ef038d3e4bdb6c6da83225b28cb3d
|
||||
_commit=58eb5023f30411060f3e905df7b91f3efe9c437c
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Raspberry Pi"
|
||||
pkgver=3.16.3
|
||||
pkgver=3.17.1
|
||||
pkgrel=1
|
||||
bfqver=v7r5
|
||||
|
||||
|
@ -23,23 +23,28 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
|
|||
'args-uncompressed.txt'
|
||||
'boot-uncompressed.txt'
|
||||
'imagetool-uncompressed.py'
|
||||
'disable-8192cu.patch'
|
||||
# "git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
|
||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver:0:4}"
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch")
|
||||
# "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
|
||||
# "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
|
||||
# "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch")
|
||||
########REMOVE WHEN BFQ for 3.17 is released
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/3.16.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-3.16.patch"
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/3.16.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-3.16.patch"
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/3.16.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-3.16.0.patch"
|
||||
'0001-block-Switch-from-BFQ-v7r6-for-3.16.0-to-BFQ-v7r6-for-3.17.0-rc1.patch')
|
||||
#######EVOMER##########
|
||||
|
||||
md5sums=('3ac005c164c62ae472447c8f8534c1f8'
|
||||
md5sums=('4052cef8799c86cd570bb182d14bd031'
|
||||
'cd888ec2d86d0ffb3c771e1b0689d3ca'
|
||||
'9335d1263fd426215db69841a380ea26'
|
||||
'a00e424e2fbb8c5a5f77ba2c4871bed4'
|
||||
'2f82dbe5752af65ff409d737caf11954'
|
||||
'8e91bb5369dabec81bcd28b8d6484898'
|
||||
'SKIP'
|
||||
'27b45e15c3f9855792808498af21f664'
|
||||
'812c18775a53e337f1b2c7cd9078bff1'
|
||||
'e903ed2c79546d2f0ec41e7e631c62f7')
|
||||
'e903ed2c79546d2f0ec41e7e631c62f7'
|
||||
'90a1fe58e60b17e0e5647a38776e8f43')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -49,9 +54,6 @@ msg "Patches:"
|
|||
cp ${srcdir}/boot-uncompressed.txt arch/arm/boot/
|
||||
cp ${srcdir}/imagetool-uncompressed.py arch/arm/boot/
|
||||
|
||||
msg2 "Disable out of tree RTL8192 driver and enable rtlwifi"
|
||||
patch -Np1 -i "${srcdir}/disable-8192cu.patch"
|
||||
|
||||
msg2 "AUFS patches"
|
||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||
cp -ru "${srcdir}/aufs3-standalone/fs" .
|
||||
|
@ -64,9 +66,15 @@ msg "Patches:"
|
|||
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
|
||||
|
||||
msg2 "Add BFQ patches"
|
||||
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
|
||||
patch -Np1 -i "${srcdir}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
|
||||
patch -Np1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
|
||||
# patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
|
||||
# patch -Np1 -i "${srcdir}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
|
||||
# patch -Np1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
|
||||
##REMOVE WHEN BFQ for 3.17 is out
|
||||
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-3.16.patch"
|
||||
patch -Np1 -i "${srcdir}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-3.16.patch"
|
||||
patch -Np1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-3.16.0.patch"
|
||||
patch -Np1 -i "${srcdir}/0001-block-Switch-from-BFQ-v7r6-for-3.16.0-to-BFQ-v7r6-for-3.17.0-rc1.patch"
|
||||
##EVOMER###
|
||||
|
||||
msg "Prepare to build"
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
diff -ruN a/drivers/net/wireless/Kconfig b/drivers/net/wireless/Kconfig
|
||||
--- a/drivers/net/wireless/Kconfig 2014-02-09 06:44:02.000000000 -0700
|
||||
+++ b/drivers/net/wireless/Kconfig 2014-02-11 00:01:47.240805953 -0700
|
||||
@@ -276,8 +276,8 @@
|
||||
source "drivers/net/wireless/orinoco/Kconfig"
|
||||
source "drivers/net/wireless/p54/Kconfig"
|
||||
source "drivers/net/wireless/rt2x00/Kconfig"
|
||||
-#source "drivers/net/wireless/rtlwifi/Kconfig"
|
||||
-source "drivers/net/wireless/rtl8192cu/Kconfig"
|
||||
+source "drivers/net/wireless/rtlwifi/Kconfig"
|
||||
+#source "drivers/net/wireless/rtl8192cu/Kconfig"
|
||||
source "drivers/net/wireless/ti/Kconfig"
|
||||
source "drivers/net/wireless/zd1211rw/Kconfig"
|
||||
source "drivers/net/wireless/mwifiex/Kconfig"
|
||||
diff -ruN a/drivers/net/wireless/Makefile b/drivers/net/wireless/Makefile
|
||||
--- a/drivers/net/wireless/Makefile 2014-02-09 06:44:02.000000000 -0700
|
||||
+++ b/drivers/net/wireless/Makefile 2014-02-11 00:02:20.192099059 -0700
|
||||
@@ -24,8 +24,8 @@
|
||||
obj-$(CONFIG_ZD1211RW) += zd1211rw/
|
||||
obj-$(CONFIG_RTL8180) += rtl818x/
|
||||
obj-$(CONFIG_RTL8187) += rtl818x/
|
||||
-#obj-$(CONFIG_RTLWIFI) += rtlwifi/
|
||||
-obj-$(CONFIG_RTL8192CU) += rtl8192cu/
|
||||
+obj-$(CONFIG_RTLWIFI) += rtlwifi/
|
||||
+#obj-$(CONFIG_RTL8192CU) += rtl8192cu/
|
||||
|
||||
# 16-bit wireless PCMCIA client drivers
|
||||
obj-$(CONFIG_PCMCIA_RAYCS) += ray_cs.o
|
Loading…
Reference in a new issue