mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/ocaml fix
This commit is contained in:
parent
1937623afe
commit
cc78da06f3
2 changed files with 3 additions and 32 deletions
|
@ -1,8 +1,7 @@
|
||||||
# $Id$
|
# $Id$
|
||||||
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# remove when bumped upstream
|
||||||
# - patch to fix ARM build
|
|
||||||
|
|
||||||
pkgbase='ocaml'
|
pkgbase='ocaml'
|
||||||
pkgname=('ocaml' 'ocaml-compiler-libs')
|
pkgname=('ocaml' 'ocaml-compiler-libs')
|
||||||
|
@ -15,17 +14,10 @@ url="http://caml.inria.fr/"
|
||||||
depends=('gdbm')
|
depends=('gdbm')
|
||||||
makedepends=('tk>=8.6.0' 'ncurses>=5.6-7' 'libx11')
|
makedepends=('tk>=8.6.0' 'ncurses>=5.6-7' 'libx11')
|
||||||
optdepends=('ncurses: advanced ncurses features' 'tk: advanced tk features')
|
optdepends=('ncurses: advanced ncurses features' 'tk: advanced tk features')
|
||||||
source=(http://caml.inria.fr/distrib/ocaml-${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
|
source=(http://caml.inria.fr/distrib/ocaml-${pkgver%.*}/${pkgname}-${pkgver}.tar.xz)
|
||||||
arm.patch)
|
sha1sums=('1878ba4338e4fad5b057428e182fba806c545d57')
|
||||||
sha1sums=('1878ba4338e4fad5b057428e182fba806c545d57'
|
|
||||||
'113e296557473dbd26b87c4e652af5207c8cf072')
|
|
||||||
options=('!makeflags' '!emptydirs' 'staticlibs')
|
options=('!makeflags' '!emptydirs' 'staticlibs')
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
||||||
patch -p1 -i ../arm.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||||
./configure -prefix /usr -x11include /usr/include
|
./configure -prefix /usr -x11include /usr/include
|
||||||
|
|
|
@ -1,21 +0,0 @@
|
||||||
diff -urN a/asmcomp/CSEgen.ml b/asmcomp/CSEgen.ml
|
|
||||||
--- a/asmcomp/CSEgen.ml 2016-11-04 10:08:24.000000000 -0600
|
|
||||||
+++ b/asmcomp/CSEgen.ml 2016-11-15 12:07:58.685253738 -0700
|
|
||||||
@@ -252,7 +252,8 @@
|
|
||||||
(* Perform CSE on the given instruction [i] and its successors.
|
|
||||||
[n] is the value numbering current at the beginning of [i]. *)
|
|
||||||
|
|
||||||
-method private cse n i =
|
|
||||||
+method private cse n i = i
|
|
||||||
+(*
|
|
||||||
match i.desc with
|
|
||||||
| Iend | Ireturn | Iop(Itailcall_ind _) | Iop(Itailcall_imm _)
|
|
||||||
| Iexit _ | Iraise _ ->
|
|
||||||
@@ -357,6 +358,7 @@
|
|
||||||
{i with desc = Itrywith(self#cse n body,
|
|
||||||
self#cse empty_numbering handler);
|
|
||||||
next = self#cse empty_numbering i.next}
|
|
||||||
+*)
|
|
||||||
|
|
||||||
method fundecl f =
|
|
||||||
{f with fun_body = self#cse empty_numbering f.fun_body}
|
|
Loading…
Reference in a new issue