mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/mplayer-vaapi to 35014-1
This commit is contained in:
parent
de0d7c7a22
commit
cd4c180e47
5 changed files with 24 additions and 53 deletions
|
@ -1,16 +1,14 @@
|
|||
# $Id: PKGBUILD 70637 2012-05-13 16:56:17Z foutrelis $
|
||||
# $Id: PKGBUILD 73508 2012-07-08 19:34:25Z foutrelis $
|
||||
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Hugo Doria <hugo@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove --enable-runtime-cpudetection from configure
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=mplayer-vaapi
|
||||
pkgver=34578
|
||||
pkgrel=5
|
||||
pkgver=35014
|
||||
pkgrel=1
|
||||
pkgdesc="A movie player, compiled with vaapi support"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://gitorious.org/vaapi/mplayer"
|
||||
|
@ -19,30 +17,26 @@ depends=('libxxf86dga' 'libxxf86vm' 'libmad' 'libcdio' 'libxinerama' 'sdl'
|
|||
'lame' 'fontconfig' 'libtheora' 'xvidcore' 'libmng' 'libxss' 'mesa'
|
||||
'smbclient' 'aalib' 'jack' 'libcaca' 'x264' 'faac' 'faad2'
|
||||
'lirc-utils' 'ttf-dejavu' 'libxvmc' 'enca' 'opencore-amr' 'libdca'
|
||||
'a52dec' 'schroedinger' 'mpg123' 'libvpx' 'libpulse' 'fribidi' 'faad2'
|
||||
'libva' 'libass' 'desktop-file-utils')
|
||||
'a52dec' 'schroedinger' 'mpg123' 'libvpx' 'libpulse' 'fribidi'
|
||||
'libbluray' 'libva' 'libass' 'desktop-file-utils')
|
||||
makedepends=('unzip' 'live-media' 'yasm' 'ladspa' 'git')
|
||||
provides=("mplayer=$pkgver")
|
||||
conflicts=('mplayer')
|
||||
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
|
||||
source=(http://pkgbuild.com/~foutrelis/mplayer-vaapi-$pkgver.tar.xz
|
||||
tweak-desktop-file.patch
|
||||
mplayer.png
|
||||
live-media.patch)
|
||||
tweak-desktop-file.patch)
|
||||
options=('!buildflags' '!emptydirs')
|
||||
install=mplayer-vaapi.install
|
||||
sha256sums=('cc35a057c8a64d2cdec2dc0a037811ef0f91dd03cd3d07465c7272a08665a37d'
|
||||
'5b39f0a61969bf330c4434cb17975101be93c27334f65e154e4a93033033e795'
|
||||
'061739a8cc267748ad58f168034cc39785d949a5262772535e1b347c7842af48'
|
||||
'9c1400f27dd2ea54c125c66ed1af0eab19761b1b2ae808fa491cd3732fd8a685')
|
||||
sha256sums=('db19a938e7de46aad567b6d7d8866ec6cb3919a29d60236609a83ebf4e1bb5f0'
|
||||
'5a09fb462729a4e573568f9e8c1f57dbe7f69c0b68cfa4f6d70b3e52c450d93b')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/mplayer-vaapi-$pkgver"
|
||||
|
||||
patch -d etc -Np0 -i "$srcdir/tweak-desktop-file.patch"
|
||||
patch -Np0 -i "$srcdir/live-media.patch"
|
||||
|
||||
./configure --prefix=/usr \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--disable-gui \
|
||||
--disable-arts \
|
||||
--disable-liblzo \
|
||||
|
@ -55,6 +49,8 @@ build() {
|
|||
--disable-mga \
|
||||
--disable-ass-internal \
|
||||
--enable-xvmc \
|
||||
--enable-radio \
|
||||
--enable-radio-capture \
|
||||
--disable-vdpau \
|
||||
--enable-vaapi \
|
||||
--language=all \
|
||||
|
@ -68,13 +64,13 @@ build() {
|
|||
package() {
|
||||
cd "$srcdir/mplayer-vaapi-$pkgver"
|
||||
|
||||
make -j1 DESTDIR="$pkgdir" install-mplayer install-mplayer-man
|
||||
make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
|
||||
install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"
|
||||
install -Dm644 etc/mplayer.desktop "$pkgdir/usr/share/applications/mplayer.desktop"
|
||||
install -d "$pkgdir/usr/share/mplayer/"
|
||||
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf "$pkgdir/usr/share/mplayer/subfont.ttf"
|
||||
rm -rf "$pkgdir/usr/share/mplayer/font"
|
||||
install -Dm644 "$srcdir/mplayer.png" "$pkgdir/usr/share/pixmaps/mplayer.png"
|
||||
install -Dm644 etc/mplayer256x256.png "$pkgdir/usr/share/pixmaps/mplayer.png"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Index: libmpdemux/demux_rtp.cpp
|
||||
===================================================================
|
||||
--- libmpdemux/demux_rtp.cpp (revision 34798)
|
||||
+++ libmpdemux/demux_rtp.cpp (working copy)
|
||||
@@ -19,6 +19,8 @@
|
||||
* 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
*/
|
||||
|
||||
+#define RTSPCLIENT_SYNCHRONOUS_INTERFACE 1
|
||||
+
|
||||
extern "C" {
|
||||
// on MinGW, we must include windows.h before the things it conflicts
|
||||
#ifdef __MINGW32__ // with. they are each protected from
|
|
@ -1,9 +1,11 @@
|
|||
post_install() {
|
||||
update-desktop-database -q
|
||||
update-desktop-database -q
|
||||
}
|
||||
post_upgrade() {
|
||||
post_install
|
||||
post_install
|
||||
}
|
||||
post_remove() {
|
||||
post_install
|
||||
post_install
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
Binary file not shown.
Before Width: | Height: | Size: 1.9 KiB |
|
@ -1,19 +1,6 @@
|
|||
--- mplayer.desktop.orig 2012-05-13 19:25:26.000000000 +0300
|
||||
+++ mplayer.desktop 2012-05-13 19:32:19.000000000 +0300
|
||||
@@ -7,12 +7,6 @@ GenericName[de]=Medienwiedergabe
|
||||
GenericName[fr]=Lecteur multimédia
|
||||
GenericName[it]=Lettore multimediale
|
||||
GenericName[ja]=メディアプレーヤー
|
||||
-X-GNOME-FullName=MPlayer Media Player
|
||||
-X-GNOME-FullName[ca]=MPlayer Reproductor multimèdia
|
||||
-X-GNOME-FullName[de]=MPlayer Medienwiedergabe
|
||||
-X-GNOME-FullName[fr]=MPlayer Lecteur multimédia
|
||||
-X-GNOME-FullName[it]=MPlayer Lettore multimediale
|
||||
-X-GNOME-FullName[ja]=MPlayer メディアプレーヤー
|
||||
Comment=Play movies and songs
|
||||
Comment[ca]=Reproduïu vídeos i cançons
|
||||
Comment[de]=Filme und Musik wiedergeben
|
||||
@@ -20,8 +14,9 @@ Comment[fr]=Lit les films et musiques
|
||||
--- mplayer.desktop.orig 2012-07-08 22:18:27.000000000 +0300
|
||||
+++ mplayer.desktop 2012-07-08 22:19:08.000000000 +0300
|
||||
@@ -23,8 +23,9 @@ Comment[fr]=Lit les films et musiques
|
||||
Comment[it]=Riproduce filmati e musica
|
||||
Comment[ja]=動画や音声のファイルを再生します
|
||||
Icon=mplayer
|
||||
|
@ -24,5 +11,4 @@
|
|||
Terminal=false
|
||||
+NoDisplay=true
|
||||
Categories=GTK;AudioVideo;Audio;Video;Player;TV;
|
||||
-MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-theora;video/x-matroska;video/3gpp;application/x-flash-video;
|
||||
+MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;video/3gpp;application/x-flash-video;
|
||||
MimeType=application/mxf;application/x-netshow-channel;application/ogg;application/ram;application/vnd.rn-realmedia;application/x-shockwave-flash;application/smil;audio/ac3;audio/x-adpcm;audio/x-aiff;audio/AMR;audio/AMR-WB;audio/x-ape;audio/basic;audio/flac;audio/x-flac;audio/x-flac+ogg;audio/x-m4b;audio/x-matroska;audio/mp2;audio/mp4;audio/mpeg;audio/x-mpegurl;audio/x-ms-asx;audio/x-ms-wma;audio/x-musepack;audio/ogg;audio/vnd.rn-realaudio;audio/x-scpls;audio/x-voc;audio/x-vorbis+ogg;audio/x-wav;audio/x-wavpack;video/3gpp;video/3gpp2;video/dv;video/x-flic;video/x-flv;video/x-matroska;video/mp2t;video/mp4;video/mpeg;video/x-ms-asf;video/x-ms-wmv;video/x-msvideo;video/x-nsv;video/ogg;video/x-ogm+ogg;video/quicktime;video/vnd.rn-realvideo;video/x-theora+ogg;video/webm;
|
||||
|
|
Loading…
Reference in a new issue