community/supercollider to 3.11.0-2

This commit is contained in:
Kevin Mihelich 2020-03-21 21:37:20 +00:00
parent ad26daa896
commit cd622ec32e
2 changed files with 8 additions and 21 deletions

View file

@ -8,7 +8,7 @@
_name=SuperCollider
pkgname=supercollider
pkgver=3.11.0
pkgrel=1
pkgrel=2
pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
arch=('x86_64')
url="https://supercollider.github.io"
@ -24,10 +24,10 @@ optdepends=('emacs: emacs interface'
'sc3-plugins: additional extension plugins for scsynth')
provides=("libscsynth.so" "sclang=${pkgver}" "scsynth=${pkgver}")
source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pkgver}/${_name}-${pkgver}-Source-linux.tar.bz2"
"${pkgname}-3.11.0-devendor_ableton_link.patch")
"${pkgname}-3.11.0-use_system_link.patch")
install="${pkgname}.install"
sha512sums=('8c93395231caf3617c3dae07e7c94e2253e24ab1a822b64904d5bc67f62fb12e9837ed0cd7210fbbe10cb5a7ff277e80e5f2ec85d6b51026c920851d4fda59a4'
'f42f2eb9c61b20b6313f9351e0528c397718bccafd094095d7d1d810eee55efd7b47126be8ef3ba56d6e752dbd270d11111f188c4a88282405af489993b3051d')
'2b0ed3a7a0022d9a23beb42a39e6327f28b8c59b6fe976771442df572477f509c1ca3882cdb41c2b277fb4d4b0f07e8bd88a6c4017c522c5e4ff89ce32c9b4cd')
prepare() {
@ -35,8 +35,8 @@ prepare() {
cd "${pkgname}-${pkgver}"
# devendoring Ableton Link:
# https://github.com/supercollider/supercollider/issues/4818
# https://github.com/supercollider/supercollider/issues/4818
patch -Np1 -i "../${pkgname}-3.11.0-devendor_ableton_link.patch"
# https://github.com/supercollider/supercollider/pull/4836
patch -Np1 -i "../${pkgname}-3.11.0-use_system_link.patch"
# removing macOS hidden files (due to release tarball issues):
# https://github.com/supercollider/supercollider/issues/4545
find . -type f -iname "*\._*" -delete

View file

@ -11,29 +11,16 @@ index 30d9c8d1a..5e1e9cb89 100644
option(SYSTEM_YAMLCPP "Use yaml-cpp library from system" OFF)
diff --git c/lang/CMakeLists.txt w/lang/CMakeLists.txt
index 9b5095d11..5374fb29f 100644
index 9b5095d11..29c7898db 100644
--- c/lang/CMakeLists.txt
+++ w/lang/CMakeLists.txt
@@ -252,7 +252,25 @@ endif()
@@ -252,7 +252,12 @@ endif()
if (SC_ABLETON_LINK)
message(STATUS "Compiling with Ableton Link support")
- include(../external_libraries/link/AbletonLinkConfig.cmake)
+ if(SYSTEM_ABLETON_LINK)
+ find_path(ABLETON_LINK_INCLUDE ableton Link.hpp)
+ add_library(Ableton::Link IMPORTED INTERFACE)
+ set_property(TARGET Ableton::Link APPEND PROPERTY
+ INTERFACE_INCLUDE_DIRECTORIES
+ ${ABLETON_LINK_INCLUDE}/ableton
+ )
+ set_property(TARGET Ableton::Link APPEND PROPERTY
+ INTERFACE_COMPILE_DEFINITIONS
+ LINK_PLATFORM_LINUX=1
+ )
+ set_property(TARGET Ableton::Link APPEND PROPERTY
+ INTERFACE_SOURCES
+ ${ABLETON_LINK_INCLUDE}/ableton/Link.hpp
+ )
+ find_package(AbletonLink HINTS /usr/lib/cmake/ableton-link /usr/lib/cmake/link /usr/share/ableton-link)
+ else()
+ include(../external_libraries/link/AbletonLinkConfig.cmake)
+ endif()