diff --git a/core/tcp_wrappers/PKGBUILD b/core/tcp_wrappers/PKGBUILD
index cca535728..9ea38b7b9 100755
--- a/core/tcp_wrappers/PKGBUILD
+++ b/core/tcp_wrappers/PKGBUILD
@@ -1,8 +1,11 @@
-# $Id: PKGBUILD 67074 2010-02-02 22:47:03Z tpowa $
 # Maintainer: judd <jvinet@zeroflux.org>
+
+# Plugbox changes: Add "sshd: ALL" to hosts.allow
+# NOTE: hosts.allow is only backed up if the user has made any changes...
+
 pkgname=tcp_wrappers
 pkgver=7.6
-pkgrel=11
+pkgrel=13
 pkgdesc="Monitors and Controls incoming TCP connections"
 arch=(i686 x86_64)
 url="ftp://ftp.porcupine.org/pub/security/index.html"
@@ -27,8 +30,8 @@ source=(ftp://ftp.porcupine.org/pub/security/${pkgname}_$pkgver.tar.gz
         11_inet6_fixes.patch
         tcp-wrappers-7.6-ipv6-1.14.patch)
 md5sums=('e6fa25f71226d090f34de3f6b122fb5a'
-         '18fda096b93199ed866edd935061c48c'
-         'a0ee30f6aeaca241c4d44f7c177eca6b'
+         '3d1d035ff0addf3faf0dee5995d246a1'
+         'e4743ca604a1749c7312f9283b4bb0d1'
          '4a8f40f9a69f0848df92b232072e8561'
          '1a6d7b11abb1fd69ace775d02a1c72cf'
          '99345104130b91cb151af9d87eee1449'
@@ -46,17 +49,18 @@ md5sums=('e6fa25f71226d090f34de3f6b122fb5a'
 build() {
   cd $srcdir/${pkgname}_$pkgver
   # add gentoo / fedora / redhat patches
-  patch -Np1 -i ../shared_lib_plus_plus-1.patch || return 1
-  patch -Np1 -i ../01_all_redhat-bug11881.patch || return 1
-  patch -Np0 -i ../02_all_redhat-bug17795.patch || return 1
-  patch -Np0 -i ../03_all_wildcard.patch || return 1
-  patch -Np1 -i ../04_all_fixgethostbyname.patch || return 1
-  patch -Np1 -i ../07_all_sig.patch || return 1
-  patch -Np1 -i ../09_all_gcc-3.4.patch || return 1
-  patch -Np1 -i ../10_all_more-headers.patch || return 1
-  patch -Np2 -i ../tcp-wrappers-7.6-ipv6-1.14.patch || return 1
+  patch -Np1 -i ../shared_lib_plus_plus-1.patch 
+  patch -Np1 -i ../01_all_redhat-bug11881.patch
+  patch -Np0 -i ../02_all_redhat-bug17795.patch
+  patch -Np0 -i ../03_all_wildcard.patch
+  patch -Np1 -i ../04_all_fixgethostbyname.patch
+  patch -Np1 -i ../07_all_sig.patch
+  patch -Np1 -i ../09_all_gcc-3.4.patch
+  patch -Np1 -i ../10_all_more-headers.patch
+  patch -Np0 -i ../11_inet6_fixes.patch
+  patch -Np2 -i ../tcp-wrappers-7.6-ipv6-1.14.patch
 
-  make REAL_DAEMON_DIR=/usr/sbin STYLE=-DPROCESS_OPTIONS linux || return 1
+  make REAL_DAEMON_DIR=/usr/sbin STYLE=-DPROCESS_OPTIONS linux
   # dumb makefile
   mkdir -p $pkgdir/usr/{include,lib,sbin}
   mkdir -p $pkgdir/usr/share/man/man{3,5,8}
diff --git a/core/tcp_wrappers/hosts.allow b/core/tcp_wrappers/hosts.allow
index cacffa0fc..d21d49f81 100644
--- a/core/tcp_wrappers/hosts.allow
+++ b/core/tcp_wrappers/hosts.allow
@@ -1,5 +1,7 @@
 #
 # /etc/hosts.allow
 #
+
 sshd: ALL
+
 # End of file
diff --git a/core/tcp_wrappers/hosts.deny b/core/tcp_wrappers/hosts.deny
index efcce18ea..cbb00b29d 100755
--- a/core/tcp_wrappers/hosts.deny
+++ b/core/tcp_wrappers/hosts.deny
@@ -2,6 +2,6 @@
 # /etc/hosts.deny
 #
 
-ALL: ALL: DENY
+ALL: ALL
 
 # End of file
diff --git a/core/tcp_wrappers/tcp_wrappers-7.6-13-arm.pkg.tar.xz b/core/tcp_wrappers/tcp_wrappers-7.6-13-arm.pkg.tar.xz
new file mode 120000
index 000000000..2fe9f02f5
--- /dev/null
+++ b/core/tcp_wrappers/tcp_wrappers-7.6-13-arm.pkg.tar.xz
@@ -0,0 +1 @@
+/build/packages/extra/tcp_wrappers-7.6-13-arm.pkg.tar.xz
\ No newline at end of file