mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-webengine: fix
This commit is contained in:
parent
98533dd538
commit
ce06c42f37
2 changed files with 80 additions and 14 deletions
72
extra/qt5-webengine/0001-ARM-toolchain-fixes.patch
Normal file
72
extra/qt5-webengine/0001-ARM-toolchain-fixes.patch
Normal file
|
@ -0,0 +1,72 @@
|
|||
From 581e99bdd47340b9b3d41cffd51d8ac03422def6 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 8 Jun 2017 20:41:08 -0600
|
||||
Subject: [PATCH] ARM toolchain fixes
|
||||
|
||||
---
|
||||
chromium/build/toolchain/linux/BUILD.gn | 20 +++++++++++++++++++-
|
||||
chromium/tools/gn/args.cc | 3 +++
|
||||
2 files changed, 22 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
|
||||
index 548722d393..8a24c50f79 100644
|
||||
--- a/chromium/build/toolchain/linux/BUILD.gn
|
||||
+++ b/chromium/build/toolchain/linux/BUILD.gn
|
||||
@@ -22,7 +22,7 @@ clang_toolchain("clang_arm64") {
|
||||
}
|
||||
|
||||
gcc_toolchain("arm") {
|
||||
- toolprefix = "arm-linux-gnueabihf-"
|
||||
+ toolprefix = ""
|
||||
|
||||
cc = "${toolprefix}gcc"
|
||||
cxx = "${toolprefix}g++"
|
||||
@@ -39,6 +39,24 @@ gcc_toolchain("arm") {
|
||||
}
|
||||
}
|
||||
|
||||
+gcc_toolchain("arm64") {
|
||||
+ toolprefix = ""
|
||||
+
|
||||
+ cc = "${toolprefix}gcc"
|
||||
+ cxx = "${toolprefix}g++"
|
||||
+
|
||||
+ ar = "${toolprefix}ar"
|
||||
+ ld = cxx
|
||||
+ readelf = "${toolprefix}readelf"
|
||||
+ nm = "${toolprefix}nm"
|
||||
+
|
||||
+ toolchain_args = {
|
||||
+ current_cpu = "arm64"
|
||||
+ current_os = "linux"
|
||||
+ is_clang = false
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
clang_toolchain("clang_x86") {
|
||||
toolchain_args = {
|
||||
current_cpu = "x86"
|
||||
diff --git a/chromium/tools/gn/args.cc b/chromium/tools/gn/args.cc
|
||||
index 7285d7a538..54703e1760 100644
|
||||
--- a/chromium/tools/gn/args.cc
|
||||
+++ b/chromium/tools/gn/args.cc
|
||||
@@ -266,6 +266,7 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
|
||||
static const char kX86[] = "x86";
|
||||
static const char kX64[] = "x64";
|
||||
static const char kArm[] = "arm";
|
||||
+ static const char kArm64[] = "arm64";
|
||||
static const char kMips[] = "mipsel";
|
||||
static const char kS390X[] = "s390x";
|
||||
static const char kPPC64[] = "ppc64";
|
||||
@@ -280,6 +281,8 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
|
||||
arch = kX64;
|
||||
else if (os_arch.substr(0, 3) == "arm")
|
||||
arch = kArm;
|
||||
+ else if (os_arch == "aarch64")
|
||||
+ arch = kArm64;
|
||||
else if (os_arch == "mips")
|
||||
arch = kMips;
|
||||
else if (os_arch == "s390x")
|
||||
--
|
||||
2.12.0
|
||||
|
|
@ -3,8 +3,7 @@
|
|||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to disable neon
|
||||
# - patch to use system ffmpeg
|
||||
# - patch for chromium GN
|
||||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
|
@ -23,18 +22,10 @@ depends=('qt5-webchannel' 'qt5-location' 'libxcomposite' 'libxrandr' 'pciutils'
|
|||
makedepends=('python2' 'git' 'gperf' 'jsoncpp' 'ninja')
|
||||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
|
||||
sha256sums=('6e7fb2be161c6db4d988a4f5b329672f'
|
||||
'2a1610b34204102938a24154a52e5571'
|
||||
'123d4d0d7db7473649ff2b5650330cc4'
|
||||
'9d225d1bf83ea45dbf6556d30d35fcb8'
|
||||
'3762cbdbc6a752e4d876e048e5e16de6'
|
||||
'951ac7549fff82f9d1d11e9bf50556ba'
|
||||
'd5da5608285ad764f37fe196f9afe5a1'
|
||||
'c7b5acd58319d23d769c19f42323e8ec'
|
||||
'663f8454990de96fad4c8c78bcd6f819'
|
||||
'849ab18980b0523405f0282c83b4a54c'
|
||||
'9f79b14f7c5ff603c1fcd87f37a8904f')
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
'0001-ARM-toolchain-fixes.patch')
|
||||
sha256sums=('2ed4a579b0fc89c586ed84f131f8c64f6fb70f3126711138ce68f1290ac2b820'
|
||||
'897c5960db849211f525039d386e21692cad8a5ba056f3e22440146225c20df8')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
@ -42,6 +33,9 @@ prepare() {
|
|||
# Hack to force using python2
|
||||
mkdir -p bin
|
||||
ln -s /usr/bin/python2 bin/python
|
||||
|
||||
cd ${_pkgfqn}/src/3rdparty
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue