mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-armv7-rc to 4.11.rc8-1
This commit is contained in:
parent
a57074339f
commit
ce305cb385
11 changed files with 41 additions and 135 deletions
|
@ -1,7 +1,7 @@
|
||||||
From de9032f005aa8829fde0fcedcaa43cfcfedb5d04 Mon Sep 17 00:00:00 2001
|
From e043ee82e371ded84d2940af53f0f3b0e549236d Mon Sep 17 00:00:00 2001
|
||||||
From: Willy Tarreau <w@xxxxxx>
|
From: Willy Tarreau <w@xxxxxx>
|
||||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||||
Subject: [PATCH 01/10] ARM: atags: add support for Marvell's u-boot
|
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
|
||||||
|
|
||||||
Marvell uses a specific atag in its u-boot which includes among other
|
Marvell uses a specific atag in its u-boot which includes among other
|
||||||
information the MAC addresses for up to 4 network interfaces.
|
information the MAC addresses for up to 4 network interfaces.
|
||||||
|
@ -47,5 +47,5 @@ index 979ff4016404..d1d0c1950fa4 100644
|
||||||
};
|
};
|
||||||
|
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
From 29d9ca25c3908dc7e7c46ad13e5ec1637115ed89 Mon Sep 17 00:00:00 2001
|
From 9192225b0bee8ed45131f4c311ee2eb41d3f5327 Mon Sep 17 00:00:00 2001
|
||||||
From: Willy Tarreau <w@xxxxxx>
|
From: Willy Tarreau <w@xxxxxx>
|
||||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||||
Subject: [PATCH 02/10] ARM: atags/fdt: retrieve MAC addresses from Marvell
|
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||||
boot loader
|
loader
|
||||||
|
|
||||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||||
addresses are extracted there and assigned to node aliases eth0..3
|
addresses are extracted there and assigned to node aliases eth0..3
|
||||||
|
@ -43,5 +43,5 @@ index 9448aa0c6686..ac7b6ae6c00f 100644
|
||||||
}
|
}
|
||||||
|
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From d3f5ada94549b2c868f1114afbadccf1c2bdd398 Mon Sep 17 00:00:00 2001
|
From e028a068903ac27bff5161f13deca6012e8ee885 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||||
Subject: [PATCH 03/10] SMILE Plug device tree file
|
Subject: [PATCH 3/9] SMILE Plug device tree file
|
||||||
|
|
||||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||||
dts with the LED definitions.
|
dts with the LED definitions.
|
||||||
|
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
|
||||||
+ };
|
+ };
|
||||||
+};
|
+};
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 325d600ab7e1bb99a417feeaa0383864cd366b0f Mon Sep 17 00:00:00 2001
|
From 0a8ba03a102df867bb031e84c7fcf531f240cc96 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||||
Subject: [PATCH 04/10] fix mvsdio eMMC timing
|
Subject: [PATCH 4/9] fix mvsdio eMMC timing
|
||||||
|
|
||||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||||
of the Mirabox and SMILE Plug to work.
|
of the Mirabox and SMILE Plug to work.
|
||||||
|
@ -34,5 +34,5 @@ index 42296e55b9de..e5ce6d27ec82 100644
|
||||||
host->clock = ios->clock;
|
host->clock = ios->clock;
|
||||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,15 +1,14 @@
|
||||||
From 540085c262f04c98cda177f8737bb3ece9f45c6b Mon Sep 17 00:00:00 2001
|
From 7c54d4049580474d6860f2f9d8cd53513ec48289 Mon Sep 17 00:00:00 2001
|
||||||
From: popcornmix <popcornmix@gmail.com>
|
From: popcornmix <popcornmix@gmail.com>
|
||||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||||
Subject: [PATCH 05/10] net/smsc95xx: Allow mac address to be set as a
|
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
parameter
|
|
||||||
|
|
||||||
---
|
---
|
||||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||||
1 file changed, 56 insertions(+)
|
1 file changed, 56 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||||
index 831aa33d078a..03625547d794 100644
|
index 5f19fb0f025d..89579abc1959 100644
|
||||||
--- a/drivers/net/usb/smsc95xx.c
|
--- a/drivers/net/usb/smsc95xx.c
|
||||||
+++ b/drivers/net/usb/smsc95xx.c
|
+++ b/drivers/net/usb/smsc95xx.c
|
||||||
@@ -60,6 +60,7 @@
|
@@ -60,6 +60,7 @@
|
||||||
|
@ -92,5 +91,5 @@ index 831aa33d078a..03625547d794 100644
|
||||||
|
|
||||||
/* maybe the boot loader passed the MAC address in devicetree */
|
/* maybe the boot loader passed the MAC address in devicetree */
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From f0d7c18c7df13acfb6baf13286bbacc31cf79189 Mon Sep 17 00:00:00 2001
|
From 7b10094b018ea22ae0e933098a961987b326252a Mon Sep 17 00:00:00 2001
|
||||||
From: dobatog <dobatog@gmail.com>
|
From: dobatog <dobatog@gmail.com>
|
||||||
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
||||||
Subject: [PATCH 06/10] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
Subject: [PATCH 6/9] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||||
related to input routing signals.
|
related to input routing signals.
|
||||||
|
|
||||||
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
||||||
|
@ -45,5 +45,5 @@ index 410cae0f2060..0bb8e2602d8e 100644
|
||||||
/* input mux */
|
/* input mux */
|
||||||
{"Capture Source", "Line", "Line Input"},
|
{"Capture Source", "Line", "Line Input"},
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From ca22ac1e40493dee37d975fc8968578b55f27ab2 Mon Sep 17 00:00:00 2001
|
From c9e324cee27e70fac2dd77adffd33445eae9ced5 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
||||||
Subject: [PATCH 07/10] set default cubietruck led triggers
|
Subject: [PATCH 7/9] set default cubietruck led triggers
|
||||||
|
|
||||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
---
|
---
|
||||||
|
@ -29,5 +29,5 @@ index f019aa3fe96d..76053e03cc7a 100644
|
||||||
};
|
};
|
||||||
|
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From b62ef1608fd8c829fb116ef3daf4d2951f0c7edf Mon Sep 17 00:00:00 2001
|
From 45353496c9a480c745fda93f552e6e0ffb417d51 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Thu, 11 Aug 2016 00:42:37 -0600
|
Date: Thu, 11 Aug 2016 00:42:37 -0600
|
||||||
Subject: [PATCH 08/10] exynos4412-odroid: set higher minimum buck2 regulator
|
Subject: [PATCH 8/9] exynos4412-odroid: set higher minimum buck2 regulator
|
||||||
voltage
|
voltage
|
||||||
|
|
||||||
Set a higher minimum voltage to help reboot issue.
|
Set a higher minimum voltage to help reboot issue.
|
||||||
|
@ -26,5 +26,5 @@ index 78f118cb73d4..169bd8fdaf41 100644
|
||||||
regulator-always-on;
|
regulator-always-on;
|
||||||
regulator-boot-on;
|
regulator-boot-on;
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 87fc831a0def820d8ea754d8c27acf52ceeac541 Mon Sep 17 00:00:00 2001
|
From f0527d9a7d142e36dedeea473c996bd53eef00a1 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sat, 25 Feb 2017 19:39:51 -0700
|
Date: Sat, 25 Feb 2017 19:39:51 -0700
|
||||||
Subject: [PATCH 09/10] disable USB3 port on ODROID-XU
|
Subject: [PATCH 9/9] disable USB3 port on ODROID-XU
|
||||||
|
|
||||||
Ports report over-current condition and are non-operable.
|
Ports report over-current condition and are non-operable.
|
||||||
|
|
||||||
|
@ -23,5 +23,5 @@ index c4de1353e5df..f80fa58995c5 100644
|
||||||
|
|
||||||
&usbdrd_dwc3_1 {
|
&usbdrd_dwc3_1 {
|
||||||
--
|
--
|
||||||
2.12.1
|
2.12.2
|
||||||
|
|
||||||
|
|
|
@ -1,90 +0,0 @@
|
||||||
From 335b9a8aa72f06c033d5d0284e140e3cae4f3efa Mon Sep 17 00:00:00 2001
|
|
||||||
From: Douglas Anderson <dianders@chromium.org>
|
|
||||||
Date: Tue, 11 Apr 2017 15:55:43 -0700
|
|
||||||
Subject: [PATCH 10/10] mmc: dw_mmc: Don't allow Runtime PM for SDIO cards
|
|
||||||
|
|
||||||
According to the SDIO standard interrupts are normally signalled in a
|
|
||||||
very complicated way. They require the card clock to be running and
|
|
||||||
require the controller to be paying close attention to the signals
|
|
||||||
coming from the card. This simply can't happen with the clock stopped
|
|
||||||
or with the controller in a low power mode.
|
|
||||||
|
|
||||||
To that end, we'll disable runtime_pm when we detect that an SDIO card
|
|
||||||
was inserted. This is much like with what we do with the special
|
|
||||||
"SDMMC_CLKEN_LOW_PWR" bit that dw_mmc supports.
|
|
||||||
|
|
||||||
NOTE: we specifically do this Runtime PM disabling at card init time
|
|
||||||
rather than in the enable_sdio_irq() callback. This is _different_
|
|
||||||
than how SDHCI does it. Why do we do it differently?
|
|
||||||
|
|
||||||
- Unlike SDHCI, dw_mmc uses the standard sdio_irq code in Linux (AKA
|
|
||||||
dw_mmc doesn't set MMC_CAP2_SDIO_IRQ_NOTHREAD).
|
|
||||||
- Because we use the standard sdio_irq code:
|
|
||||||
- We see a constant stream of enable_sdio_irq(0) and
|
|
||||||
enable_sdio_irq(1) calls. This is because the standard code
|
|
||||||
disables interrupts while processing and re-enables them after.
|
|
||||||
- While interrupts are disabled, there's technically a period where
|
|
||||||
we could get runtime disabled while processing interrupts.
|
|
||||||
- If we are runtime disabled while processing interrupts, we'll
|
|
||||||
reset the controller at resume time (see dw_mci_runtime_resume),
|
|
||||||
which seems like a terrible idea because we could possibly have
|
|
||||||
another interrupt pending.
|
|
||||||
|
|
||||||
To fix the above isues we'd want to put something in the standard
|
|
||||||
sdio_irq code that makes sure to call pm_runtime get/put when
|
|
||||||
interrupts are being actively being processed. That's possible to do,
|
|
||||||
but it seems like a more complicated mechanism when we really just
|
|
||||||
want the runtime pm disabled always for SDIO cards given that all the
|
|
||||||
other bits needed to get Runtime PM vs. SDIO just aren't there.
|
|
||||||
|
|
||||||
NOTE: at some point in time someone might come up with a fancy way to
|
|
||||||
do SDIO interrupts and still allow (some) amount of runtime PM.
|
|
||||||
Technically we could turn off the card clock if we used an alternate
|
|
||||||
way of signaling SDIO interrupts (and out of band interrupt is one way
|
|
||||||
to do this). We probably wouldn't actually want to fully runtime
|
|
||||||
suspend in this case though--at least not with the current
|
|
||||||
dw_mci_runtime_resume() which basically fully resets the controller at
|
|
||||||
resume time.
|
|
||||||
|
|
||||||
Fixes: e9ed8835e990 ("mmc: dw_mmc: add runtime PM callback")
|
|
||||||
Cc: <stable@vger.kernel.org>
|
|
||||||
Reported-by: Brian Norris <briannorris@chromium.org>
|
|
||||||
Signed-off-by: Douglas Anderson <dianders@chromium.org>
|
|
||||||
---
|
|
||||||
drivers/mmc/host/dw_mmc.c | 11 +++++++++--
|
|
||||||
1 file changed, 9 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/mmc/host/dw_mmc.c b/drivers/mmc/host/dw_mmc.c
|
|
||||||
index a9ac0b457313..8718432751c5 100644
|
|
||||||
--- a/drivers/mmc/host/dw_mmc.c
|
|
||||||
+++ b/drivers/mmc/host/dw_mmc.c
|
|
||||||
@@ -22,6 +22,7 @@
|
|
||||||
#include <linux/ioport.h>
|
|
||||||
#include <linux/module.h>
|
|
||||||
#include <linux/platform_device.h>
|
|
||||||
+#include <linux/pm_runtime.h>
|
|
||||||
#include <linux/seq_file.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
#include <linux/stat.h>
|
|
||||||
@@ -1621,10 +1622,16 @@ static void dw_mci_init_card(struct mmc_host *mmc, struct mmc_card *card)
|
|
||||||
|
|
||||||
if (card->type == MMC_TYPE_SDIO ||
|
|
||||||
card->type == MMC_TYPE_SD_COMBO) {
|
|
||||||
- set_bit(DW_MMC_CARD_NO_LOW_PWR, &slot->flags);
|
|
||||||
+ if (!test_bit(DW_MMC_CARD_NO_LOW_PWR, &slot->flags)) {
|
|
||||||
+ pm_runtime_get_noresume(mmc->parent);
|
|
||||||
+ set_bit(DW_MMC_CARD_NO_LOW_PWR, &slot->flags);
|
|
||||||
+ }
|
|
||||||
clk_en_a = clk_en_a_old & ~clken_low_pwr;
|
|
||||||
} else {
|
|
||||||
- clear_bit(DW_MMC_CARD_NO_LOW_PWR, &slot->flags);
|
|
||||||
+ if (test_bit(DW_MMC_CARD_NO_LOW_PWR, &slot->flags)) {
|
|
||||||
+ pm_runtime_put_noidle(mmc->parent);
|
|
||||||
+ clear_bit(DW_MMC_CARD_NO_LOW_PWR, &slot->flags);
|
|
||||||
+ }
|
|
||||||
clk_en_a = clk_en_a_old | clken_low_pwr;
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
2.12.1
|
|
||||||
|
|
|
@ -4,7 +4,7 @@
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
_rcver=4.11
|
_rcver=4.11
|
||||||
_rcrel=7
|
_rcrel=8
|
||||||
_rcnrel=armv7-x0
|
_rcnrel=armv7-x0
|
||||||
|
|
||||||
pkgbase=linux-armv7-rc
|
pkgbase=linux-armv7-rc
|
||||||
|
@ -29,25 +29,23 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz
|
||||||
'0007-set-default-cubietruck-led-triggers.patch'
|
'0007-set-default-cubietruck-led-triggers.patch'
|
||||||
'0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
|
'0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
|
||||||
'0009-disable-USB3-port-on-ODROID-XU.patch'
|
'0009-disable-USB3-port-on-ODROID-XU.patch'
|
||||||
'0010-mmc-dw_mmc-Don-t-allow-Runtime-PM-for-SDIO-cards.patch'
|
|
||||||
'config'
|
'config'
|
||||||
'kernel.its'
|
'kernel.its'
|
||||||
'kernel.keyblock'
|
'kernel.keyblock'
|
||||||
'kernel_data_key.vbprivk'
|
'kernel_data_key.vbprivk'
|
||||||
'linux.preset'
|
'linux.preset'
|
||||||
'99-linux.hook')
|
'99-linux.hook')
|
||||||
md5sums=('4eeb08204584dea7d2581420a1e5808b'
|
md5sums=('6eb1b94743f781f0dab2a6c6f673908c'
|
||||||
'b7322b13126c039f4baa1ee0f2d26e68'
|
'318dd7b5a8247cfabcf7db61226c1326'
|
||||||
'9744ba999ef16ca72418b567a81a07b3'
|
'35050d4086083976228b1aad40eb9685'
|
||||||
'15dadd9a797cbbb9ea5946503ce4b894'
|
'b1f82c5ab2c1f49839a55f3bfd79e3b4'
|
||||||
'6c9dbd501d56c9502d7a091df40c9ff9'
|
'7d2eb3a79013bbcc9eac8aae14ec95ed'
|
||||||
'f72f093000716f9c59bd993c6519c075'
|
'887172b2dbca6a024d2fc7dd2865ca17'
|
||||||
'8c874fb48bc133e547d10ca7d119f5df'
|
'cc15319d42d3dac4225523ee319f0b4e'
|
||||||
'4af65bd9bf6f5f0b04194bb561e3ae00'
|
'5be4c09f985310ec1c157621a1e0bb8e'
|
||||||
'c327647f6f183d9218b21340cf74e7bd'
|
'7902ffb9e4e48cd3426777d6fb3f2e9b'
|
||||||
'e2ad1eb88b23ae2a1863f1d4445b4321'
|
'3cd8942f980b0e85eb832168d086988b'
|
||||||
'e435bb7d5ebdbe45bb2e92e320343542'
|
'9f62b9c953a01b64b7dcf2e90aac6e37'
|
||||||
'35b7f0485d37532e6d02860de082b192'
|
|
||||||
'd4a3f20ff5211f68f8d4822bfc2ef1eb'
|
'd4a3f20ff5211f68f8d4822bfc2ef1eb'
|
||||||
'4f2379ed84258050edb858ee8d281678'
|
'4f2379ed84258050edb858ee8d281678'
|
||||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||||
|
@ -72,7 +70,6 @@ prepare() {
|
||||||
git apply ../0007-set-default-cubietruck-led-triggers.patch
|
git apply ../0007-set-default-cubietruck-led-triggers.patch
|
||||||
git apply ../0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
|
git apply ../0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
|
||||||
git apply ../0009-disable-USB3-port-on-ODROID-XU.patch
|
git apply ../0009-disable-USB3-port-on-ODROID-XU.patch
|
||||||
git apply ../0010-mmc-dw_mmc-Don-t-allow-Runtime-PM-for-SDIO-cards.patch
|
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue